aboutsummaryrefslogtreecommitdiff
path: root/deskutils/libstreamanalyzer
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-10-21 15:45:53 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-10-21 15:45:53 +0000
commitf4c56f4aa9e0e8035878450416f3c2745868d1c6 (patch)
tree23c2d838eced9e100653ca4704cef872ba694470 /deskutils/libstreamanalyzer
parent3775d3167315395260e0f1d53ddcb0fd9d59f24e (diff)
downloadports-f4c56f4aa9e0e8035878450416f3c2745868d1c6.tar.gz
ports-f4c56f4aa9e0e8035878450416f3c2745868d1c6.zip
Notes
Diffstat (limited to 'deskutils/libstreamanalyzer')
-rw-r--r--deskutils/libstreamanalyzer/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/deskutils/libstreamanalyzer/Makefile b/deskutils/libstreamanalyzer/Makefile
index 79e266162a22..bdc65a07e5b5 100644
--- a/deskutils/libstreamanalyzer/Makefile
+++ b/deskutils/libstreamanalyzer/Makefile
@@ -2,17 +2,17 @@
PORTNAME= libstreamanalyzer
PORTVERSION= ${STRIGI_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils
MASTER_SITES= ${STRIGI_MASTER_SITES}
MAINTAINER= kde@FreeBSD.org
COMMENT= Strigi desktop search: streamanalyzer library
-LIB_DEPENDS= avcodec${FFMPEG_SUFFIX}:${PORTSDIR}/multimedia/ffmpeg${FFMPEG_SUFFIX} \
- clucene-core:${PORTSDIR}/textproc/clucene \
- exiv2:${PORTSDIR}/graphics/exiv2 \
- streams:${PORTSDIR}/deskutils/libstreams
+LIB_DEPENDS= libavcodec${FFMPEG_SUFFIX}.so:${PORTSDIR}/multimedia/ffmpeg${FFMPEG_SUFFIX} \
+ libclucene-core.so:${PORTSDIR}/textproc/clucene \
+ libexiv2.so:${PORTSDIR}/graphics/exiv2 \
+ libstreams.so:${PORTSDIR}/deskutils/libstreams
USES= pkgconfig iconv
USE_GNOME= libxml2
@@ -20,7 +20,7 @@ USE_LDCONFIG= yes
# supported versions: ffmpeg, ffmpeg1, ffmpeg-devel
# corresponding FFMPEG_SUFFIX: '', '1', '-devel'
-FFMPEG_SUFFIX?= 1
+FFMPEG_SUFFIX?=
CMAKE_ARGS+= -DFFMPEG_SUFFIX:STRING="${FFMPEG_SUFFIX}"
.if !empty(FFMPEG_SUFFIX)