aboutsummaryrefslogtreecommitdiff
path: root/deskutils/ljit/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2004-10-27 11:37:54 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2004-10-27 11:37:54 +0000
commite1dd81efcf3ec1114d9e86fac0e747d00b4fb6af (patch)
tree4dc39b2b0e0390ae5e65983a56f17891c147b62d /deskutils/ljit/Makefile
parent925bc61460b2b11bc78fa732bb7f36edcd8c2f5f (diff)
Notes
Diffstat (limited to 'deskutils/ljit/Makefile')
-rw-r--r--deskutils/ljit/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/deskutils/ljit/Makefile b/deskutils/ljit/Makefile
new file mode 100644
index 000000000000..dca68aca5558
--- /dev/null
+++ b/deskutils/ljit/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: ljit
+# Date created: 09 Sep 2004
+# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ljit
+PORTVERSION= 0.2.5
+CATEGORIES= deskutils
+MASTER_SITES= http://kir.vtx.ru/ljit/dl/ \
+ http://freebsd.nsu.ru/distfiles/
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= GUI tool to help LiveJournal users post images
+
+LIB_DEPENDS= curl.3:${PORTSDIR}/ftp/curl
+#RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+USE_GETTEXT= yes
+USE_GNOME= gtk20
+USE_REINPLACE= yes
+
+post-extract:
+ @${REINPLACE_CMD} -e 's, -DMTRACE$$,,' -e 's,prefix)/$$(DATADIRNAME,datadir,' \
+ ${WRKSRC}/src/Makefile.in
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/po/ru_RU.mo ${PREFIX}/share/locale/ru/LC_MESSAGES/${PORTNAME}.mo
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+. for f in BUGS NEWS README THANKS TODO
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.mk>