aboutsummaryrefslogtreecommitdiff
path: root/deskutils/mate-character-map/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-11-23 11:39:07 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-11-23 11:39:07 +0000
commita236e2d0bfa53f22be02c6a4cc7b2cf730bc69e1 (patch)
tree000a9ce64a1e669ce72ebf4b639d75f2ef29c214 /deskutils/mate-character-map/Makefile
parentfdf023af8a1f19bbc7987f3abfb59c503eb6d52c (diff)
downloadports-a236e2d0bfa53f22be02c6a4cc7b2cf730bc69e1.tar.gz
ports-a236e2d0bfa53f22be02c6a4cc7b2cf730bc69e1.zip
Notes
Diffstat (limited to 'deskutils/mate-character-map/Makefile')
-rw-r--r--deskutils/mate-character-map/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/deskutils/mate-character-map/Makefile b/deskutils/mate-character-map/Makefile
new file mode 100644
index 000000000000..f2fa8750b069
--- /dev/null
+++ b/deskutils/mate-character-map/Makefile
@@ -0,0 +1,34 @@
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mate-character-map
+PORTVERSION= 1.6.0
+CATEGORIES= deskutils mate
+MASTER_SITES= MATE
+DIST_SUBDIR= mate
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Unicode/ISO10646 character map and font viewer
+
+BUILD_DEPENDS= gtkdoc-check:${PORTSDIR}/textproc/gtk-doc
+
+PORTSCOUT= limitw:1,even
+
+USES= gettext gmake pathfix pkgconfig
+USE_XZ= yes
+USE_MATE= autogen common:build docutils intlhack ltverhack
+USE_GNOME= glib20 gnomehier gtk20 gnomedocutils
+USE_LDCONFIG= yes
+INSTALLS_OMF= yes
+USE_AUTOTOOLS= aclocal:env autoconf:env automake:env libtool libtoolize:env
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-gtk=2.0 \
+ --disable-unihan
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+PATHFIX_MAKEFILEIN= Makefile.*
+
+GLIB_SCHEMAS= org.mate.mucharmap.enums.xml \
+ org.mate.mucharmap.gschema.xml
+
+.include <bsd.port.mk>