aboutsummaryrefslogtreecommitdiff
path: root/deskutils/mdh
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-10-10 10:28:04 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-10-10 10:28:04 +0000
commitb00f54f25c16bdf1ba1e8f1422531e584f349575 (patch)
treea3eae80d18a331fe4a5a283cd7924d7b53b508f3 /deskutils/mdh
parentbf9f4f9217c28e695949565cb864dab42157e744 (diff)
downloadports-b00f54f25c16bdf1ba1e8f1422531e584f349575.tar.gz
ports-b00f54f25c16bdf1ba1e8f1422531e584f349575.zip
Notes
Diffstat (limited to 'deskutils/mdh')
-rw-r--r--deskutils/mdh/Makefile39
-rw-r--r--deskutils/mdh/distinfo4
-rw-r--r--deskutils/mdh/files/patch-lib-gini-gini.c11
-rw-r--r--deskutils/mdh/pkg-plist54
4 files changed, 99 insertions, 9 deletions
diff --git a/deskutils/mdh/Makefile b/deskutils/mdh/Makefile
index 5c905923dde0..3a66a7eb12ac 100644
--- a/deskutils/mdh/Makefile
+++ b/deskutils/mdh/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= mdh
-PORTVERSION= 1.9.54
-PORTREVISION= 7
+PORTVERSION= 1.9.59
CATEGORIES= deskutils gnome
MASTER_SITES= http://www.gozer.org/my_stuff/gtk/gtk/mdh/
@@ -16,13 +15,39 @@ COMMENT= GTK2-based toolbar, like a smaller GNOME panel
USE_BZIP2= yes
USE_X_PREFIX= yes
-GNU_CONFIGURE= yes
USE_GNOME= gnometarget gtk20
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+USE_GETOPT_LONG= yes
+USE_REINPLACE= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+
+.if defined(WITHOUT_GTOP)
+CONFIGURE_ARGS+= --disable-gtop
+.else
+LIB_DEPENDS+= gtop-2.0:${PORTSDIR}/devel/libgtop2
+.endif
+
+.if defined(WITHOUT_CURL)
+CONFIGURE_ARGS+= --disable-curl
+.else
+LIB_DEPENDS+= curl.3:${PORTSDIR}/ftp/curl
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's| make| $$(MAKE)|g' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|\.\./lib/getopt/getopt\.c||g ; \
+ s|\.\./lib/getopt/getopt1\.c||g ; \
+ s|-I../lib/getopt||g ; \
+ s|$$(CC) -g|$$(CC)|g ; \
+ s|@INSTALL@ -m 0775|@INSTALL_PROGRAM@|g ; \
+ s|cp -p|@INSTALL_DATA@|g' ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e 's|"getopt\.h"|<getopt.h>|g' ${WRKSRC}/src/mdh.c
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
+post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
diff --git a/deskutils/mdh/distinfo b/deskutils/mdh/distinfo
index 027374440b8f..24bdf86b20c9 100644
--- a/deskutils/mdh/distinfo
+++ b/deskutils/mdh/distinfo
@@ -1,2 +1,2 @@
-MD5 (mdh-1.9.54.tar.bz2) = 62c64932d30fb94319e601ec020dde80
-SIZE (mdh-1.9.54.tar.bz2) = 115043
+MD5 (mdh-1.9.59.tar.bz2) = 3fcc2d65aa05ffd16627e72551074502
+SIZE (mdh-1.9.59.tar.bz2) = 190090
diff --git a/deskutils/mdh/files/patch-lib-gini-gini.c b/deskutils/mdh/files/patch-lib-gini-gini.c
new file mode 100644
index 000000000000..2f97ccb72861
--- /dev/null
+++ b/deskutils/mdh/files/patch-lib-gini-gini.c
@@ -0,0 +1,11 @@
+--- lib/gini/gini.c.orig Fri Jul 8 08:10:18 2005
++++ lib/gini/gini.c Fri Oct 7 03:35:03 2005
+@@ -190,7 +190,7 @@
+
+ static void value_transform_string_int64(const GValue *src, GValue *dst)
+ {
+- dst->data[0].v_int64 = atoll(src->data[0].v_pointer);
++ dst->data[0].v_int64 = strtoll(src->data[0].v_pointer, NULL, 10);
+ }
+
+ static void value_transform_string_uint64(const GValue *src, GValue *dst)
diff --git a/deskutils/mdh/pkg-plist b/deskutils/mdh/pkg-plist
index 051427dac134..68dd9523027e 100644
--- a/deskutils/mdh/pkg-plist
+++ b/deskutils/mdh/pkg-plist
@@ -1,3 +1,57 @@
bin/mdh
%%PORTDOCS%%%%DOCSDIR%%/README
+%%DATADIR%%/icons/default.png
+%%DATADIR%%/icons/mixer.png
+%%DATADIR%%/icons/weather/0.png
+%%DATADIR%%/icons/weather/1.png
+%%DATADIR%%/icons/weather/10.png
+%%DATADIR%%/icons/weather/11.png
+%%DATADIR%%/icons/weather/12.png
+%%DATADIR%%/icons/weather/13.png
+%%DATADIR%%/icons/weather/14.png
+%%DATADIR%%/icons/weather/15.png
+%%DATADIR%%/icons/weather/16.png
+%%DATADIR%%/icons/weather/17.png
+%%DATADIR%%/icons/weather/18.png
+%%DATADIR%%/icons/weather/19.png
+%%DATADIR%%/icons/weather/2.png
+%%DATADIR%%/icons/weather/20.png
+%%DATADIR%%/icons/weather/21.png
+%%DATADIR%%/icons/weather/22.png
+%%DATADIR%%/icons/weather/23.png
+%%DATADIR%%/icons/weather/24.png
+%%DATADIR%%/icons/weather/25.png
+%%DATADIR%%/icons/weather/26.png
+%%DATADIR%%/icons/weather/27.png
+%%DATADIR%%/icons/weather/28.png
+%%DATADIR%%/icons/weather/29.png
+%%DATADIR%%/icons/weather/3.png
+%%DATADIR%%/icons/weather/30.png
+%%DATADIR%%/icons/weather/31.png
+%%DATADIR%%/icons/weather/32.png
+%%DATADIR%%/icons/weather/33.png
+%%DATADIR%%/icons/weather/34.png
+%%DATADIR%%/icons/weather/35.png
+%%DATADIR%%/icons/weather/36.png
+%%DATADIR%%/icons/weather/37.png
+%%DATADIR%%/icons/weather/38.png
+%%DATADIR%%/icons/weather/39.png
+%%DATADIR%%/icons/weather/4.png
+%%DATADIR%%/icons/weather/40.png
+%%DATADIR%%/icons/weather/41.png
+%%DATADIR%%/icons/weather/42.png
+%%DATADIR%%/icons/weather/43.png
+%%DATADIR%%/icons/weather/44.png
+%%DATADIR%%/icons/weather/45.png
+%%DATADIR%%/icons/weather/46.png
+%%DATADIR%%/icons/weather/47.png
+%%DATADIR%%/icons/weather/5.png
+%%DATADIR%%/icons/weather/6.png
+%%DATADIR%%/icons/weather/7.png
+%%DATADIR%%/icons/weather/8.png
+%%DATADIR%%/icons/weather/9.png
+%%DATADIR%%/icons/weather/na.png
+@dirrm %%DATADIR%%/icons/weather
+@dirrm %%DATADIR%%/icons
+@dirrm %%DATADIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%