aboutsummaryrefslogtreecommitdiff
path: root/deskutils/mencal/Makefile
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-11-02 14:17:45 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-11-02 14:17:45 +0000
commit9a758f1909ccbfd9aa2174b4ef27151bb95e01be (patch)
treeaef8e01f6d07ff2bb4af9bae76473edbd765886c /deskutils/mencal/Makefile
parentf7e6363f7aa82319e24659d9bcabe212d8fec7b6 (diff)
downloadports-9a758f1909ccbfd9aa2174b4ef27151bb95e01be.tar.gz
ports-9a758f1909ccbfd9aa2174b4ef27151bb95e01be.zip
Notes
Diffstat (limited to 'deskutils/mencal/Makefile')
-rw-r--r--deskutils/mencal/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/deskutils/mencal/Makefile b/deskutils/mencal/Makefile
index 544dceadf5c1..4d07b050a257 100644
--- a/deskutils/mencal/Makefile
+++ b/deskutils/mencal/Makefile
@@ -2,27 +2,24 @@
# $FreeBSD$
PORTNAME= mencal
-PORTVERSION= 2.4
+PORTVERSION= 3.0
CATEGORIES= deskutils
MASTER_SITES= http://kyberdigi.cz/projects/mencal/files/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A variation of the unix command cal
+COMMENT= Simple variation of the unix command cal
LICENSE= GPLv2
NO_BUILD= yes
-USES= perl5
+USES= perl5 shebangfix
+SHEBANG_FILES= ${PORTNAME}
USE_PERL5= run
PLIST_FILES= bin/mencal
-NO_STAGE= yes
-post-patch:
- @${REINPLACE_CMD} -e '/^#!/s|/.*|${PERL} -w|' ${WRKSRC}/${PORTNAME}
-
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/mencal ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>