aboutsummaryrefslogtreecommitdiff
path: root/deskutils/mencal
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-18 10:21:36 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-18 10:21:36 +0000
commit9077593494cf521a480f96247c835ccd0ed508a2 (patch)
treedc1f104ee415935eef0e7b7db497ca8339516cd1 /deskutils/mencal
parente9bb8260394a98514abc3859775185c5fcab32b5 (diff)
downloadports-9077593494cf521a480f96247c835ccd0ed508a2.tar.gz
ports-9077593494cf521a480f96247c835ccd0ed508a2.zip
Notes
Diffstat (limited to 'deskutils/mencal')
-rw-r--r--deskutils/mencal/Makefile22
-rw-r--r--deskutils/mencal/distinfo1
-rw-r--r--deskutils/mencal/files/patch-mencal22
-rw-r--r--deskutils/mencal/pkg-comment1
-rw-r--r--deskutils/mencal/pkg-descr9
-rw-r--r--deskutils/mencal/pkg-plist1
6 files changed, 56 insertions, 0 deletions
diff --git a/deskutils/mencal/Makefile b/deskutils/mencal/Makefile
new file mode 100644
index 000000000000..5e6452f0e0c5
--- /dev/null
+++ b/deskutils/mencal/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: mencal
+# Date created: 17 April 2002
+# Whom: Christian Brueffer <chris@unixpages.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mencal
+PORTVERSION= 2.0
+CATEGORIES= deskutils
+MASTER_SITES= http://mencal.kyberdigi.cz/ \
+ http://unixpages.org/distfiles/
+
+MAINTAINER= chris@unixpages.org
+
+USE_PERL= yes
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/mencal ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/deskutils/mencal/distinfo b/deskutils/mencal/distinfo
new file mode 100644
index 000000000000..7888a069438c
--- /dev/null
+++ b/deskutils/mencal/distinfo
@@ -0,0 +1 @@
+MD5 (mencal-2.0.tar.gz) = abd648a8b195648b2c9bf0fa889ee305
diff --git a/deskutils/mencal/files/patch-mencal b/deskutils/mencal/files/patch-mencal
new file mode 100644
index 000000000000..baf21677526b
--- /dev/null
+++ b/deskutils/mencal/files/patch-mencal
@@ -0,0 +1,22 @@
+--- mencal.orig Fri Mar 29 08:14:03 2002
++++ mencal Wed Sep 18 18:19:07 2002
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl -w
++#!/usr/bin/env perl -w
+
+ ##< month object >##
+
+@@ -271,13 +271,6 @@
+ }
+ }
+
+- my @locales=split("\n", `locale -c LC_TIME`);
+- if(($#locales>=1) && length($locales[1])) {
+- $config{'topline'}='';
+- foreach my $day (split(';', $locales[1])) { $day=~s/^(..).+$/$1/; $config{'topline'}.=$day.' '; }
+- $config{'topline'}=~s/ +$//;
+- }
+- $config{'topline'}=~s/;/ /g;
+ $config{'monday_first'} && $config{'topline'}=~s/^(..) (.+)$/$2 $1/;
+
+ $config{'show_type'}=~/^(1|3|y)$/ || ($config{'show_type'}='1');
diff --git a/deskutils/mencal/pkg-comment b/deskutils/mencal/pkg-comment
new file mode 100644
index 000000000000..7ba2348b6856
--- /dev/null
+++ b/deskutils/mencal/pkg-comment
@@ -0,0 +1 @@
+A variation of the unix command cal
diff --git a/deskutils/mencal/pkg-descr b/deskutils/mencal/pkg-descr
new file mode 100644
index 000000000000..e545e2e7e259
--- /dev/null
+++ b/deskutils/mencal/pkg-descr
@@ -0,0 +1,9 @@
+Mencal is a simple variation of the well-known unix command cal.
+The main difference is that you can have some periodically
+repeating days highlighted in color. This can be used to track
+menstruation (or other) cycles conveniently.
+
+WWW: http://mencal.kyberdigi.cz/english.html
+
+- Christian Brueffer
+chris@unixpages.org
diff --git a/deskutils/mencal/pkg-plist b/deskutils/mencal/pkg-plist
new file mode 100644
index 000000000000..65c1623e6939
--- /dev/null
+++ b/deskutils/mencal/pkg-plist
@@ -0,0 +1 @@
+bin/mencal