aboutsummaryrefslogtreecommitdiff
path: root/deskutils/moregroupware
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-01-29 17:45:44 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-01-29 17:45:44 +0000
commite3ba99f7ef438d35ee68552c91f3135874550219 (patch)
treec2a30061f53012b42046d4c590c827770821fb1f /deskutils/moregroupware
parente4a386db82ad55585b8eb48763b0e2311fb3da4d (diff)
downloadports-e3ba99f7ef438d35ee68552c91f3135874550219.tar.gz
ports-e3ba99f7ef438d35ee68552c91f3135874550219.zip
Notes
Diffstat (limited to 'deskutils/moregroupware')
-rw-r--r--deskutils/moregroupware/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/deskutils/moregroupware/Makefile b/deskutils/moregroupware/Makefile
index d4b6f7c12011..106596bc6492 100644
--- a/deskutils/moregroupware/Makefile
+++ b/deskutils/moregroupware/Makefile
@@ -7,6 +7,7 @@
PORTNAME= moregroupware
PORTVERSION= 0.7.1
+PORTREVISION= 1
CATEGORIES= deskutils www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= moregroupware
@@ -19,10 +20,20 @@ DISTFILES= ${PORTNAME}-core-${PORTVERSION}${EXTRACT_SUFX} \
MAINTAINER= rob@debank.tv
COMMENT= A web based GroupWare system
-.if defined(WITH_APACHE2)
-RUN_DEPENDS= ${LOCALBASE}/libexec/apache2/libphp4.so:${PORTSDIR}/www/mod_php4
+# php extensions
+USE_PHP= \
+ curl \
+ gd \
+ pcre \
+ session \
+ xml
+# uses apache , php4 port decides if it is apache 1 or 2
+WANT_PHP_MOD= yes
+
+.if defined(WITH_POSTGRESQL)
+RUN_DEPENDS+= ${LOCALBASE}/bin/psql:${PORTSDIR}/databases/postgresql74-server
.else
-RUN_DEPENDS= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
+RUN_DEPENDS+= ${LOCALBASE}/bin/mysql:${PORTSDIR}/databases/mysql41-server
.endif
.if defined(WITH_MODULES)