aboutsummaryrefslogtreecommitdiff
path: root/deskutils/multi-backgrounds-daemon/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-10-10 06:41:59 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-10-10 06:41:59 +0000
commitd5cc33d264370613d13484f77b54cf11b47ca3f6 (patch)
tree837c221835f6f6288a0d33f53c3a467d9079e08e /deskutils/multi-backgrounds-daemon/Makefile
parent36bf7b00da1bdaf8f88ccb2eacbcd2077f93b12b (diff)
Notes
Diffstat (limited to 'deskutils/multi-backgrounds-daemon/Makefile')
-rw-r--r--deskutils/multi-backgrounds-daemon/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/deskutils/multi-backgrounds-daemon/Makefile b/deskutils/multi-backgrounds-daemon/Makefile
new file mode 100644
index 000000000000..a1ae5e2356f6
--- /dev/null
+++ b/deskutils/multi-backgrounds-daemon/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: deskutils/multi-backgrounds-daemon
+# Date created: 16 Jul 2003
+# Whom: Juan Salaverria <rael@vectorstar.net>
+#
+# $FreeBSD$
+
+PORTNAME= multi-backgrounds-daemon
+PORTVERSION= 0.1.1
+CATEGORIES= deskutils gnome
+MASTER_SITES= http://jk24.free.fr/multi-backgrounds-daemon/
+
+MAINTAINER= rael@vectorstar.net
+COMMENT= Change your GNOME2 backgound when you switch to other workspace
+
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+USE_GNOME= gnomehack gnomeprefix libgnomeui libwnck
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+DOCS= AUTHORS COPYING ChangeLog INSTALL NEWS README
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ;' ${WRKSRC}/configure
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${INSTALL} -d -o root -g wheel -m 0755 ${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+ @${CAT} pkg-message
+
+.include <bsd.port.mk>