aboutsummaryrefslogtreecommitdiff
path: root/deskutils/multisync
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
commit216b5a285fdcc1456a307fcc60f3507c20d613eb (patch)
treed0c8617b772b8f0a175d436d938b8d844590b41f /deskutils/multisync
parentb829518a7d432b7cc2546fde7f032238d1db13dc (diff)
downloadports-216b5a285fdcc1456a307fcc60f3507c20d613eb.tar.gz
ports-216b5a285fdcc1456a307fcc60f3507c20d613eb.zip
Notes
Diffstat (limited to 'deskutils/multisync')
-rw-r--r--deskutils/multisync/Makefile12
-rw-r--r--deskutils/multisync/files/patch-src-Makefile.am11
2 files changed, 13 insertions, 10 deletions
diff --git a/deskutils/multisync/Makefile b/deskutils/multisync/Makefile
index 03399768ca0b..32650ea99e86 100644
--- a/deskutils/multisync/Makefile
+++ b/deskutils/multisync/Makefile
@@ -11,12 +11,10 @@ DISTNAME= multisync-${PORTVERSION}
MAINTAINER?= ports@FreeBSD.org
COMMENT?= Synchronize calendars, addressbooks, and other PIM data
-WRKSRC?= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-WRKSRCMASTER= ${WRKDIR}/multisync-${PORTVERSION}
USE_GNOME= gnomeprefix libgnomeui
USES= gmake libtool pathfix pkgconfig tar:bzip2
-USE_AUTOTOOLS= libtoolize aclocal autoconf automake
-AUTOMAKE_ARGS= --add-missing
+USE_AUTOTOOLS= libtoolize aclocal autoconf autoheader automake
+AUTOMAKE_ARGS= -a -c -f
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
@@ -24,11 +22,5 @@ MAKE_JOBS_UNSAFE= yes
pre-configure:
@${FIND} ${WRKDIR} -type l -delete
-.for FILE in missing install-sh mkinstalldirs config.guess config.sub depcomp
- @${CP} -f ${AUTOMAKE_DIR}/${FILE} ${WRKSRC}
- @${CP} -f ${AUTOMAKE_DIR}/${FILE} ${WRKSRCMASTER}
-.endfor
- @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|-lpthread||'
.include <bsd.port.mk>
diff --git a/deskutils/multisync/files/patch-src-Makefile.am b/deskutils/multisync/files/patch-src-Makefile.am
new file mode 100644
index 000000000000..b26f1df890a5
--- /dev/null
+++ b/deskutils/multisync/files/patch-src-Makefile.am
@@ -0,0 +1,11 @@
+--- src/Makefile.am.orig
++++ src/Makefile.am
+@@ -23,7 +23,7 @@
+
+ multisync_LDFLAGS = -rdynamic
+
+-multisync_LDADD = @PACKAGE_LIBS@ $(INTLLIBS) -lpthread -L./libversit -lversit
++multisync_LDADD = @PACKAGE_LIBS@ -lX11 $(INTLLIBS) -lpthread -L./libversit -lversit
+
+ SUBDIRS = libversit
+