aboutsummaryrefslogtreecommitdiff
path: root/deskutils/myitcrm
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-05-15 18:41:24 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-05-15 18:41:24 +0000
commitefd139ed48ff79404916e9ab71bee25dbf809441 (patch)
tree6463e18c574c71dccfd2f3087538042cb0186437 /deskutils/myitcrm
parent795fc4961d8a015346072b047cbd9594ab083fb7 (diff)
downloadports-efd139ed48ff79404916e9ab71bee25dbf809441.tar.gz
ports-efd139ed48ff79404916e9ab71bee25dbf809441.zip
Notes
Diffstat (limited to 'deskutils/myitcrm')
-rw-r--r--deskutils/myitcrm/Makefile46
-rw-r--r--deskutils/myitcrm/pkg-plist4
2 files changed, 18 insertions, 32 deletions
diff --git a/deskutils/myitcrm/Makefile b/deskutils/myitcrm/Makefile
index b789f81f4a42..1bfac526790d 100644
--- a/deskutils/myitcrm/Makefile
+++ b/deskutils/myitcrm/Makefile
@@ -3,7 +3,7 @@
PORTNAME= myitcrm
PORTVERSION= 0.2.9.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils
MASTER_SITES= SF/myitcrm/
DISTNAME= MyITCRM1-${PORTVERSION}
@@ -26,12 +26,15 @@ PORTEXAMPLES= htaccess.txt
PORTDOCS= changelog.txt README.textile
USE_DOS2UNIX= yes
-OPTIONS_DEFINE= APACHE PHPMOD LIGHTTPD NGINX
+OPTIONS_DEFINE= APACHE PHPMOD LIGHTTPD NGINX DOCS EXAMPLES
OPTIONS_DEFAULT= APACHE
PHPMOD_DESC= Use PHP module for Apache
NGINX_DESC= Use Nginx
-NO_STAGE= yes
+APACHE_USE= APACHE_RUN=22+
+LIGHTTPD_RUN_DEPENDS= lighttpd:${PORTSDIR}/www/lighttpd
+NGINX_RUN_DEPENDS= nginx:${PORTSDIR}/www/nginx
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPHPMOD}
@@ -40,16 +43,6 @@ WANT_PHP_MOD= yes
WANT_PHP_CGI= yes
.endif
-.if ${PORT_OPTIONS:MAPACHE}
-USE_APACHE_RUN= 22+
-.endif
-.if ${PORT_OPTIONS:MLIGHTTPD}
-RUN_DEPENDS+= lighttpd:${PORTSDIR}/www/lighttpd
-.endif
-.if ${PORT_OPTIONS:MNGINX}
-RUN_DEPENDS+= nginx:${PORTSDIR}/www/nginx
-.endif
-
# Set files to ignore.
.for file in ${PORTEXAMPLES} ${PORTDOCS} LICENSE.txt
WWW_IGNORE+= -not -name ${file}
@@ -64,31 +57,26 @@ rm-install:
.endif
+post-patch:
+ ${MV} ${WRKSRC}/conf-default.php ${WRKSRC}/conf.php.sample
+
do-install:
- @${MKDIR} ${WWWDIR}
- @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${WWWDIR} '${WWW_IGNORE}'
- @if [ ! -f ${WWWDIR}/conf.php ]; then \
- ${CP} ${WWWDIR}/conf-default.php ${WWWDIR}/conf.php; \
- fi
+ @${MKDIR} ${STAGEDIR}${WWWDIR}
+ (@cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR} '${WWW_IGNORE}')
.for ent in ${WRITEABLE}
- @${CHOWN} ${WWWOWN}:${WWWGRP} ${WWWDIR}/${ent}
- @${CHMOD} u+w ${WWWDIR}/${ent}
+ @${CHOWN} ${WWWOWN}:${WWWGRP} ${STAGEDIR}${WWWDIR}/${ent}
+ @${CHMOD} u+w ${STAGEDIR}${WWWDIR}/${ent}
.endfor
-.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for ex in ${PORTEXAMPLES}
- @${INSTALL_DATA} ${WRKSRC}/${ex} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${ex} ${STAGEDIR}${EXAMPLESDIR}
.endfor
-.endif # PORTEXAMPLES
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for doc in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif # PORTDOCS
post-install:
- @${CAT} ${PKGMESSAGE}
.if defined(MAINTAINER_MODE)
@${MAKE} -C ${.CURDIR} rm-install
.endif
diff --git a/deskutils/myitcrm/pkg-plist b/deskutils/myitcrm/pkg-plist
index 29c5de55ba2a..eafbf6c4da71 100644
--- a/deskutils/myitcrm/pkg-plist
+++ b/deskutils/myitcrm/pkg-plist
@@ -1,8 +1,7 @@
-@unexec if cmp -s %D/%%WWWDIR%%/conf.php %D/%%WWWDIR%%/conf-default.php; then rm -f %D/%%WWWDIR%%/conf.php; fi
%%WWWDIR%%/backup/.htaccess
%%WWWDIR%%/backup/bigdump.php
%%WWWDIR%%/cache/index.php
-%%WWWDIR%%/conf-default.php
+@sample %%WWWDIR%%/conf.php.sample
%%WWWDIR%%/cron/.htaccess
%%WWWDIR%%/cron/backup.php
%%WWWDIR%%/cron/index.php
@@ -1360,4 +1359,3 @@
@dirrm %%WWWDIR%%/cron
@dirrmtry %%WWWDIR%%/cache
@dirrm %%WWWDIR%%/backup
-@exec if [ ! -f %D/%%WWWDIR%%/conf.php ]; then cp -p %D/%%WWWDIR%%/conf-default.php %D/%%WWWDIR%%/conf.php; fi