aboutsummaryrefslogtreecommitdiff
path: root/deskutils/nag
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-12-26 10:25:26 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-12-26 10:25:26 +0000
commit4d0eb180f00326f4c6d4794f27f9bc3744b9701a (patch)
tree82124ada2ea3bc4da940224048fb3a5f43467d14 /deskutils/nag
parentfe309f86808e2777a2d339ee9c48074bbee17af7 (diff)
downloadports-4d0eb180f00326f4c6d4794f27f9bc3744b9701a.tar.gz
ports-4d0eb180f00326f4c6d4794f27f9bc3744b9701a.zip
Notes
Diffstat (limited to 'deskutils/nag')
-rw-r--r--deskutils/nag/Makefile40
-rw-r--r--deskutils/nag/distinfo4
-rw-r--r--deskutils/nag/files/patch-aa8
-rw-r--r--deskutils/nag/files/patch-ab21
-rw-r--r--deskutils/nag/files/pkg-message.in19
-rw-r--r--deskutils/nag/pkg-message21
-rw-r--r--deskutils/nag/pkg-plist245
7 files changed, 163 insertions, 195 deletions
diff --git a/deskutils/nag/Makefile b/deskutils/nag/Makefile
index be757118e426..9542fe6901f8 100644
--- a/deskutils/nag/Makefile
+++ b/deskutils/nag/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nag
-PORTVERSION= 1.1.1
+PORTVERSION= 2.0
CATEGORIES= deskutils www
MASTER_SITES= ftp://ftp.horde.org/pub/nag/ \
ftp://ftp.planetmirror.com/pub/horde/nag/ \
@@ -17,36 +17,35 @@ MASTER_SITES= ftp://ftp.horde.org/pub/nag/ \
ftp://ftp.nl.horde.org/mirror/horde-ftp/pub/nag/ \
ftp://ftp.uk.horde.org/mirrors/ftp.horde.org/pub/nag/ \
http://ftp.horde.org/pub/nag/
+DISTNAME= ${PORTNAME}-h3-${PORTVERSION}
-MAINTAINER= thierry@pompo.net
+MAINTAINER= thierry@FreeBSD.org
COMMENT= Nag is a simple, multiuser task list manager
-RUN_DEPENDS= ${LOCALBASE}/www/horde/imp/index.php:${PORTSDIR}/mail/imp3
+RUN_DEPENDS= ${LOCALBASE}/www/horde/rpc.php:${PORTSDIR}/www/horde
NO_BUILD= yes
USE_REINPLACE= yes
-REINPLACE_ARGS= -i.beforeNag
-
-PLIST_SUB= HORDEDIR=${LHORDEDIR} NAGDIR=${LNAGDIR}
+PLIST_SUB= NAGDIR=${LNAGDIR}
+PKGMESSAGE= ${WRKDIR}/pkg-message
DOCS= COPYING README docs/CHANGES docs/CREDITS docs/INSTALL \
- docs/RELEASE_NOTES docs/TODO
-CONFFILE= conf.php html.php menu.php prefs.php
-SUB_DIRS= config graphics lib locale po scripts templates
+ docs/RELEASE_NOTES docs/TODO docs/UPGRADING
+CONFFILE= menu.php prefs.php
+SUB_DIRS= config lib locale po scripts templates themes
LHORDEDIR?= www/horde
LNAGDIR?= ${LHORDEDIR}/nag
-HORDEDIR= ${PREFIX}/${LHORDEDIR}
NAGDIR= ${PREFIX}/${LNAGDIR}
CONFDIR= ${NAGDIR}/config
HORDE_INC= ${LOCALBASE}/etc/horde
-post-patch:
- @${RM} ${WRKSRC}/config/conf.php.dist.orig \
- ${WRKSRC}/scripts/drivers/nag_tasks.sql.orig
+pre-configure:
+ @${SED} -e "s:/home/httpd/html/horde/nag:${NAGDIR}:g" \
+ ${FILESDIR}/httpd.conf.nag > ${WRKDIR}/httpd.conf.nag
do-install:
@${MKDIR} ${NAGDIR}
@@ -59,15 +58,9 @@ do-install:
${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
fi
.endfor
- @${CHOWN} -R www:www ${NAGDIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${NAGDIR}
@${CHMOD} -R o-rwx ${CONFDIR}
- @${CP} -p ${FILESDIR}/httpd.conf.nag ${HORDE_INC}
- @${REINPLACE_CMD} -e "s:/home/httpd/html/horde/nag:${NAGDIR}:g" \
- ${HORDE_INC}/httpd.conf.nag
- @${RM} ${HORDE_INC}/httpd.conf.nag.beforeNag
- @${REINPLACE_CMD} -e "s://UNCOMMENTWHENINSTNAG::" ${HORDEDIR}/config/registry.php
- @${CP} -p ${HORDEDIR}/config/registry.php \
- ${HORDEDIR}/config/registry.php.afterNag
+ @${INSTALL_DATA} ${WRKDIR}/httpd.conf.nag ${HORDE_INC}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for FILE in ${DOCS}
@@ -77,9 +70,10 @@ do-install:
.endif
post-install:
+ @${SED} -e "s:%%NAGDIR%%:${NAGDIR}:g;s:%%DOCSDIR%%:${DOCSDIR}:g" \
+ < ${FILESDIR}/pkg-message.in > ${PKGMESSAGE}
@${ECHO_MSG}
- @${SED} -e "s:%%NAGDIR%%:${NAGDIR}:g;s:%%PORTSDIR%%:${PORTSDIR}:g" \
- -e "s:%%CONFDIR%%:${CONFDIR}:g;s:%%HORDEDIR%%:${HORDEDIR}:" ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
@${ECHO_MSG}
.include <bsd.port.mk>
diff --git a/deskutils/nag/distinfo b/deskutils/nag/distinfo
index b94f7c7c6bcf..5c4c4d5bfcee 100644
--- a/deskutils/nag/distinfo
+++ b/deskutils/nag/distinfo
@@ -1,2 +1,2 @@
-MD5 (nag-1.1.1.tar.gz) = 59843745081fb5d8902bed27206364ee
-SIZE (nag-1.1.1.tar.gz) = 326416
+MD5 (nag-h3-2.0.tar.gz) = 0db47fde7d618311831a525fe784588c
+SIZE (nag-h3-2.0.tar.gz) = 936114
diff --git a/deskutils/nag/files/patch-aa b/deskutils/nag/files/patch-aa
deleted file mode 100644
index 2ee4d373ca48..000000000000
--- a/deskutils/nag/files/patch-aa
+++ /dev/null
@@ -1,8 +0,0 @@
---- scripts/drivers/nag_tasks.sql.orig Tue Dec 11 14:47:41 2001
-+++ scripts/drivers/nag_tasks.sql Sat Dec 15 00:42:13 2001
-@@ -13,4 +13,4 @@
- primary key (task_owner, task_id)
- );
-
--grant select, insert, update, delete on nag_tasks to horde;
-+grant select, insert, update, delete on nag_tasks to hordemgr;
diff --git a/deskutils/nag/files/patch-ab b/deskutils/nag/files/patch-ab
deleted file mode 100644
index 26192dede93d..000000000000
--- a/deskutils/nag/files/patch-ab
+++ /dev/null
@@ -1,21 +0,0 @@
---- config/conf.php.dist.orig Tue Mar 12 18:07:16 2002
-+++ config/conf.php.dist Mon Apr 8 23:08:04 2002
-@@ -42,12 +42,12 @@
- // Below is an example configuration for an sql driver, in this case
- // MySQL.
- $conf['storage']['params'] = array();
--// $conf['storage']['params']['phptype'] = 'mysql';
--// $conf['storage']['params']['hostspec'] = 'localhost';
--// $conf['storage']['params']['username'] = 'horde';
--// $conf['storage']['params']['password'] = '*****';
--// $conf['storage']['params']['database'] = 'horde';
--// $conf['storage']['params']['table'] = 'nag_tasks';
-+$conf['storage']['params']['phptype'] = 'mysql';
-+$conf['storage']['params']['hostspec'] = 'localhost';
-+$conf['storage']['params']['username'] = 'hordemgr';
-+$conf['storage']['params']['password'] = 'hordemgr';
-+$conf['storage']['params']['database'] = 'horde';
-+$conf['storage']['params']['table'] = 'nag_tasks';
-
-
- /**
diff --git a/deskutils/nag/files/pkg-message.in b/deskutils/nag/files/pkg-message.in
new file mode 100644
index 000000000000..db8489feb386
--- /dev/null
+++ b/deskutils/nag/files/pkg-message.in
@@ -0,0 +1,19 @@
+************************************************************************
+Nag has been installed in %%NAGDIR%% with your blank
+configuration files.
+
+Horde must be configured; if not, see `pkg_info -D -x horde'.
+
+Then, you have to create the table nag_tasks, from the SQL script
+%%NAGDIR%%/scripts/sql/nag.sql.
+For example, if your database is MySQL, you may run
+mysql --user=root --password=yourpass horde < nag.sql
+
+WARNING! if you are upgrading from Nag v. 1.1.x, you have to alter your
+******** schemas. Please read the doc %%DOCSDIR%%/UPGRADING.
+
+Finally, you must login to Horde as a Horde Administrator to finish the
+configuration.
+
+To protect your configuration files, you have to restart Apache.
+************************************************************************
diff --git a/deskutils/nag/pkg-message b/deskutils/nag/pkg-message
deleted file mode 100644
index 82fde213db7b..000000000000
--- a/deskutils/nag/pkg-message
+++ /dev/null
@@ -1,21 +0,0 @@
-************************************************************************
-Nag has been installed in %%NAGDIR%% with your blank
-configuration files.
-
-Horde and IMP must be configured; if not, see:
-- %%PORTSDIR%%/www/horde2/pkg-message
-- %%PORTSDIR%%/mail/imp3/pkg-message
-
-Then, you have to create the table nag_tasks, from the SQL script
-%%NAGDIR%%/scripts/drivers/nag_tasks.sql.
-For example, if your database is MySQL, you may run
-mysql --user=hordemgr --password=yourpass horde < nag_tasks.sql
-(If you run another database server, see
- %%HORDEDIR%%/scripts/db/README
- for more explanations.)
-
-Finally, you may have to tune the configuration files located in
-%%CONFDIR%%/, specially the files conf.php.
-
-To protect your configuration files, you have to restart Apache.
-************************************************************************
diff --git a/deskutils/nag/pkg-plist b/deskutils/nag/pkg-plist
index 3d3943842384..28b6869a8424 100644
--- a/deskutils/nag/pkg-plist
+++ b/deskutils/nag/pkg-plist
@@ -1,47 +1,44 @@
-%%PORTDOCS%%share/doc/nag/CHANGES
-%%PORTDOCS%%share/doc/nag/COPYING
-%%PORTDOCS%%share/doc/nag/CREDITS
-%%PORTDOCS%%share/doc/nag/INSTALL
-%%PORTDOCS%%share/doc/nag/README
-%%PORTDOCS%%share/doc/nag/RELEASE_NOTES
-%%PORTDOCS%%share/doc/nag/TODO
-%%NAGDIR%%/config/conf.php
-%%NAGDIR%%/config/conf.php.dist
-%%NAGDIR%%/config/html.php
-%%NAGDIR%%/config/html.php.dist
+etc/horde/httpd.conf.nag
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/CREDITS
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/RELEASE_NOTES
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/UPGRADING
+%%NAGDIR%%/config/.htaccess
+%%NAGDIR%%/config/conf.xml
%%NAGDIR%%/config/menu.php
%%NAGDIR%%/config/menu.php.dist
%%NAGDIR%%/config/prefs.php
%%NAGDIR%%/config/prefs.php.dist
-%%NAGDIR%%/graphics/add.gif
-%%NAGDIR%%/graphics/checkbox.gif
-%%NAGDIR%%/graphics/complete.gif
-%%NAGDIR%%/graphics/down.gif
-%%NAGDIR%%/graphics/list.gif
-%%NAGDIR%%/graphics/nag.gif
-%%NAGDIR%%/graphics/note.gif
-%%NAGDIR%%/graphics/print.gif
-%%NAGDIR%%/graphics/refresh.gif
-%%NAGDIR%%/graphics/search.gif
-%%NAGDIR%%/graphics/up.gif
+%%NAGDIR%%/data.php
%%NAGDIR%%/index.php
+%%NAGDIR%%/lib/.htaccess
+%%NAGDIR%%/lib/Block/summary.php
%%NAGDIR%%/lib/Driver.php
+%%NAGDIR%%/lib/Driver/datatree.php
+%%NAGDIR%%/lib/Driver/kolab.php
%%NAGDIR%%/lib/Driver/sql.php
%%NAGDIR%%/lib/Nag.php
+%%NAGDIR%%/lib/Notification/Listener/status.php
+%%NAGDIR%%/lib/Widgets.php
%%NAGDIR%%/lib/api.php
%%NAGDIR%%/lib/base.php
-%%NAGDIR%%/lib/constants.php
+%%NAGDIR%%/lib/prefs.php
%%NAGDIR%%/lib/version.php
%%NAGDIR%%/list.php
%%NAGDIR%%/locale/ar_SY/LC_MESSAGES/nag.mo
%%NAGDIR%%/locale/bg_BG/LC_MESSAGES/nag.mo
%%NAGDIR%%/locale/cs_CZ/LC_MESSAGES/nag.mo
%%NAGDIR%%/locale/da_DK/LC_MESSAGES/nag.mo
-%%NAGDIR%%/locale/de_DE/LC_MESSAGES/nag.mo
%%NAGDIR%%/locale/de_DE/help.xml
+%%NAGDIR%%/locale/de_DE/LC_MESSAGES/nag.mo
%%NAGDIR%%/locale/el_GR/LC_MESSAGES/nag.mo
%%NAGDIR%%/locale/en_US/help.xml
%%NAGDIR%%/locale/es_ES/LC_MESSAGES/nag.mo
+%%NAGDIR%%/locale/es_ES/help.xml
%%NAGDIR%%/locale/fi_FI/LC_MESSAGES/nag.mo
%%NAGDIR%%/locale/fi_FI/help.xml
%%NAGDIR%%/locale/fr_FR/LC_MESSAGES/nag.mo
@@ -51,21 +48,21 @@
%%NAGDIR%%/locale/it_IT/LC_MESSAGES/nag.mo
%%NAGDIR%%/locale/ko_KR/LC_MESSAGES/nag.mo
%%NAGDIR%%/locale/lt_LT/LC_MESSAGES/nag.mo
+%%NAGDIR%%/locale/lv_LV/LC_MESSAGES/nag.mo
+%%NAGDIR%%/locale/lv_LV/help.xml
%%NAGDIR%%/locale/nb_NO/LC_MESSAGES/nag.mo
%%NAGDIR%%/locale/nl_NL/LC_MESSAGES/nag.mo
%%NAGDIR%%/locale/nl_NL/help.xml
%%NAGDIR%%/locale/nn_NO/LC_MESSAGES/nag.mo
+%%NAGDIR%%/locale/pl_PL/LC_MESSAGES/nag.mo
%%NAGDIR%%/locale/pt_BR/LC_MESSAGES/nag.mo
%%NAGDIR%%/locale/ro_RO/LC_MESSAGES/nag.mo
%%NAGDIR%%/locale/ru_RU/LC_MESSAGES/nag.mo
-%%NAGDIR%%/locale/ru_RU.KOI8-R/LC_MESSAGES/nag.mo
%%NAGDIR%%/locale/sk_SK/LC_MESSAGES/nag.mo
%%NAGDIR%%/locale/sk_SK/help.xml
%%NAGDIR%%/locale/sv_SE/LC_MESSAGES/nag.mo
%%NAGDIR%%/locale/zh_CN/LC_MESSAGES/nag.mo
%%NAGDIR%%/locale/zh_TW/LC_MESSAGES/nag.mo
-%%NAGDIR%%/menu.php
-%%NAGDIR%%/po/Makefile
%%NAGDIR%%/po/README
%%NAGDIR%%/po/ar_SY.po
%%NAGDIR%%/po/bg_BG.po
@@ -74,7 +71,6 @@
%%NAGDIR%%/po/de_DE.po
%%NAGDIR%%/po/el_GR.po
%%NAGDIR%%/po/es_ES.po
-%%NAGDIR%%/po/extract.pl
%%NAGDIR%%/po/fi_FI.po
%%NAGDIR%%/po/fr_FR.po
%%NAGDIR%%/po/hu_HU.po
@@ -82,120 +78,129 @@
%%NAGDIR%%/po/it_IT.po
%%NAGDIR%%/po/ko_KR.po
%%NAGDIR%%/po/lt_LT.po
+%%NAGDIR%%/po/lv_LV.po
%%NAGDIR%%/po/nag.pot
%%NAGDIR%%/po/nb_NO.po
%%NAGDIR%%/po/nl_NL.po
%%NAGDIR%%/po/nn_NO.po
+%%NAGDIR%%/po/pl_PL.po
%%NAGDIR%%/po/pt_BR.po
%%NAGDIR%%/po/ro_RO.po
%%NAGDIR%%/po/ru_RU.po
-%%NAGDIR%%/po/ru_RU.KOI8-R.po
%%NAGDIR%%/po/sk_SK.po
%%NAGDIR%%/po/sv_SE.po
%%NAGDIR%%/po/zh_CN.po
%%NAGDIR%%/po/zh_TW.po
-%%NAGDIR%%/po/shtool
-%%NAGDIR%%/po/xgettext.sh
-%%NAGDIR%%/prefs.php
-%%NAGDIR%%/scripts/drivers/nag_tasks.sql
+%%NAGDIR%%/scripts/.htaccess
+%%NAGDIR%%/scripts/migrate_to_datatree_driver.php
+%%NAGDIR%%/scripts/sql/nag.sql
+%%NAGDIR%%/scripts/upgrades/1.1_to_2.0.mysql.sql
+%%NAGDIR%%/scripts/upgrades/2004-09-13_add_uid_field.php
%%NAGDIR%%/search.php
%%NAGDIR%%/task.php
-%%NAGDIR%%/templates/common-footer.inc
+%%NAGDIR%%/tasklists.php
%%NAGDIR%%/templates/common-header.inc
-%%NAGDIR%%/templates/index/css.inc
-%%NAGDIR%%/templates/index/notconfigured.inc
-%%NAGDIR%%/templates/javascript/open_print_win.js
-%%NAGDIR%%/templates/javascript/print.js
-%%NAGDIR%%/templates/list/actions.inc
+%%NAGDIR%%/templates/data/export.inc
+%%NAGDIR%%/templates/data/import.inc
%%NAGDIR%%/templates/list/empty.inc
-%%NAGDIR%%/templates/list/footer.inc
%%NAGDIR%%/templates/list/header.inc
-%%NAGDIR%%/templates/list/javascript.inc
%%NAGDIR%%/templates/list/task_footers.inc
%%NAGDIR%%/templates/list/task_headers.inc
%%NAGDIR%%/templates/list/task_summaries.inc
-%%NAGDIR%%/templates/menu/menu.inc
-%%NAGDIR%%/templates/prefs/category_management.inc
-%%NAGDIR%%/templates/search/begin.inc
-%%NAGDIR%%/templates/search/end.inc
+%%NAGDIR%%/templates/menu.inc
+%%NAGDIR%%/templates/prefs/tasklistselect.inc
%%NAGDIR%%/templates/search/search.inc
-%%NAGDIR%%/templates/task/begin.inc
-%%NAGDIR%%/templates/task/end.inc
%%NAGDIR%%/templates/task/task.inc
-%%NAGDIR%%/templates/view/description.inc
-%%NAGDIR%%/templates/view/headers.inc
-%%NAGDIR%%/templates/view/navbar.inc
-%%NAGDIR%%/templates/view/no-task.inc
+%%NAGDIR%%/templates/tasklists/tasklists.inc
+%%NAGDIR%%/templates/view/task.inc
+%%NAGDIR%%/themes/grey/screen.css
+%%NAGDIR%%/themes/graphics/add.png
+%%NAGDIR%%/themes/graphics/alarm.png
+%%NAGDIR%%/themes/graphics/alarm_small.png
+%%NAGDIR%%/themes/graphics/checkbox.png
+%%NAGDIR%%/themes/graphics/checked.png
+%%NAGDIR%%/themes/graphics/nag.png
+%%NAGDIR%%/themes/graphics/note.png
+%%NAGDIR%%/themes/graphics/tasklists.png
+%%NAGDIR%%/themes/graphics/unchecked.png
+%%NAGDIR%%/themes/screen.css
+%%NAGDIR%%/themes/simplex/screen.css
%%NAGDIR%%/view.php
-@dirrm %%NAGDIR%%/config
-@dirrm %%NAGDIR%%/graphics
-@dirrm %%NAGDIR%%/lib/Driver
-@dirrm %%NAGDIR%%/lib
-@dirrm %%NAGDIR%%/locale/ar_SY/LC_MESSAGES
-@dirrm %%NAGDIR%%/locale/ar_SY
-@dirrm %%NAGDIR%%/locale/bg_BG/LC_MESSAGES
-@dirrm %%NAGDIR%%/locale/bg_BG
-@dirrm %%NAGDIR%%/locale/cs_CZ/LC_MESSAGES
-@dirrm %%NAGDIR%%/locale/cs_CZ
-@dirrm %%NAGDIR%%/locale/da_DK/LC_MESSAGES
-@dirrm %%NAGDIR%%/locale/da_DK
-@dirrm %%NAGDIR%%/locale/de_DE/LC_MESSAGES
-@dirrm %%NAGDIR%%/locale/de_DE
-@dirrm %%NAGDIR%%/locale/el_GR/LC_MESSAGES
-@dirrm %%NAGDIR%%/locale/el_GR
-@dirrm %%NAGDIR%%/locale/en_US
-@dirrm %%NAGDIR%%/locale/es_ES/LC_MESSAGES
-@dirrm %%NAGDIR%%/locale/es_ES
-@dirrm %%NAGDIR%%/locale/fi_FI/LC_MESSAGES
-@dirrm %%NAGDIR%%/locale/fi_FI
-@dirrm %%NAGDIR%%/locale/fr_FR/LC_MESSAGES
-@dirrm %%NAGDIR%%/locale/fr_FR
-@dirrm %%NAGDIR%%/locale/hu_HU/LC_MESSAGES
-@dirrm %%NAGDIR%%/locale/hu_HU
-@dirrm %%NAGDIR%%/locale/id_ID/LC_MESSAGES
-@dirrm %%NAGDIR%%/locale/id_ID
-@dirrm %%NAGDIR%%/locale/it_IT/LC_MESSAGES
-@dirrm %%NAGDIR%%/locale/it_IT
-@dirrm %%NAGDIR%%/locale/ko_KR/LC_MESSAGES
-@dirrm %%NAGDIR%%/locale/ko_KR
-@dirrm %%NAGDIR%%/locale/lt_LT/LC_MESSAGES
-@dirrm %%NAGDIR%%/locale/lt_LT
-@dirrm %%NAGDIR%%/locale/nb_NO/LC_MESSAGES
-@dirrm %%NAGDIR%%/locale/nb_NO
-@dirrm %%NAGDIR%%/locale/nl_NL/LC_MESSAGES
-@dirrm %%NAGDIR%%/locale/nl_NL
-@dirrm %%NAGDIR%%/locale/nn_NO/LC_MESSAGES
-@dirrm %%NAGDIR%%/locale/nn_NO
-@dirrm %%NAGDIR%%/locale/pt_BR/LC_MESSAGES
-@dirrm %%NAGDIR%%/locale/pt_BR
-@dirrm %%NAGDIR%%/locale/ro_RO/LC_MESSAGES
-@dirrm %%NAGDIR%%/locale/ro_RO
-@dirrm %%NAGDIR%%/locale/ru_RU/LC_MESSAGES
-@dirrm %%NAGDIR%%/locale/ru_RU
-@dirrm %%NAGDIR%%/locale/ru_RU.KOI8-R/LC_MESSAGES
-@dirrm %%NAGDIR%%/locale/ru_RU.KOI8-R
-@dirrm %%NAGDIR%%/locale/sk_SK/LC_MESSAGES
-@dirrm %%NAGDIR%%/locale/sk_SK
-@dirrm %%NAGDIR%%/locale/sv_SE/LC_MESSAGES
-@dirrm %%NAGDIR%%/locale/sv_SE
-@dirrm %%NAGDIR%%/locale/zh_CN/LC_MESSAGES
-@dirrm %%NAGDIR%%/locale/zh_CN
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%NAGDIR%%/themes/simplex
+@dirrm %%NAGDIR%%/themes/graphics
+@dirrm %%NAGDIR%%/themes/grey
+@dirrm %%NAGDIR%%/themes
+@dirrm %%NAGDIR%%/templates/view
+@dirrm %%NAGDIR%%/templates/tasklists
+@dirrm %%NAGDIR%%/templates/task
+@dirrm %%NAGDIR%%/templates/search
+@dirrm %%NAGDIR%%/templates/prefs
+@dirrm %%NAGDIR%%/templates/list
+@dirrm %%NAGDIR%%/templates/data
+@dirrm %%NAGDIR%%/templates
+@dirrm %%NAGDIR%%/scripts/upgrades
+@dirrm %%NAGDIR%%/scripts/sql
+@dirrm %%NAGDIR%%/scripts
+@dirrm %%NAGDIR%%/po
@dirrm %%NAGDIR%%/locale/zh_TW/LC_MESSAGES
@dirrm %%NAGDIR%%/locale/zh_TW
+@dirrm %%NAGDIR%%/locale/zh_CN/LC_MESSAGES
+@dirrm %%NAGDIR%%/locale/zh_CN
+@dirrm %%NAGDIR%%/locale/sv_SE/LC_MESSAGES
+@dirrm %%NAGDIR%%/locale/sv_SE
+@dirrm %%NAGDIR%%/locale/sk_SK/LC_MESSAGES
+@dirrm %%NAGDIR%%/locale/sk_SK
+@dirrm %%NAGDIR%%/locale/ru_RU/LC_MESSAGES
+@dirrm %%NAGDIR%%/locale/ru_RU
+@dirrm %%NAGDIR%%/locale/ro_RO/LC_MESSAGES
+@dirrm %%NAGDIR%%/locale/ro_RO
+@dirrm %%NAGDIR%%/locale/pt_BR/LC_MESSAGES
+@dirrm %%NAGDIR%%/locale/pt_BR
+@dirrm %%NAGDIR%%/locale/pl_PL/LC_MESSAGES
+@dirrm %%NAGDIR%%/locale/pl_PL
+@dirrm %%NAGDIR%%/locale/nn_NO/LC_MESSAGES
+@dirrm %%NAGDIR%%/locale/nn_NO
+@dirrm %%NAGDIR%%/locale/nl_NL/LC_MESSAGES
+@dirrm %%NAGDIR%%/locale/nl_NL
+@dirrm %%NAGDIR%%/locale/nb_NO/LC_MESSAGES
+@dirrm %%NAGDIR%%/locale/nb_NO
+@dirrm %%NAGDIR%%/locale/lv_LV/LC_MESSAGES
+@dirrm %%NAGDIR%%/locale/lv_LV
+@dirrm %%NAGDIR%%/locale/lt_LT/LC_MESSAGES
+@dirrm %%NAGDIR%%/locale/lt_LT
+@dirrm %%NAGDIR%%/locale/ko_KR/LC_MESSAGES
+@dirrm %%NAGDIR%%/locale/ko_KR
+@dirrm %%NAGDIR%%/locale/it_IT/LC_MESSAGES
+@dirrm %%NAGDIR%%/locale/it_IT
+@dirrm %%NAGDIR%%/locale/id_ID/LC_MESSAGES
+@dirrm %%NAGDIR%%/locale/id_ID
+@dirrm %%NAGDIR%%/locale/hu_HU/LC_MESSAGES
+@dirrm %%NAGDIR%%/locale/hu_HU
+@dirrm %%NAGDIR%%/locale/fr_FR/LC_MESSAGES
+@dirrm %%NAGDIR%%/locale/fr_FR
+@dirrm %%NAGDIR%%/locale/fi_FI/LC_MESSAGES
+@dirrm %%NAGDIR%%/locale/fi_FI
+@dirrm %%NAGDIR%%/locale/es_ES/LC_MESSAGES
+@dirrm %%NAGDIR%%/locale/es_ES
+@dirrm %%NAGDIR%%/locale/en_US
+@dirrm %%NAGDIR%%/locale/el_GR/LC_MESSAGES
+@dirrm %%NAGDIR%%/locale/el_GR
+@dirrm %%NAGDIR%%/locale/de_DE/LC_MESSAGES
+@dirrm %%NAGDIR%%/locale/de_DE
+@dirrm %%NAGDIR%%/locale/da_DK/LC_MESSAGES
+@dirrm %%NAGDIR%%/locale/da_DK
+@dirrm %%NAGDIR%%/locale/cs_CZ/LC_MESSAGES
+@dirrm %%NAGDIR%%/locale/cs_CZ
+@dirrm %%NAGDIR%%/locale/bg_BG/LC_MESSAGES
+@dirrm %%NAGDIR%%/locale/bg_BG
+@dirrm %%NAGDIR%%/locale/ar_SY/LC_MESSAGES
+@dirrm %%NAGDIR%%/locale/ar_SY
@dirrm %%NAGDIR%%/locale
-@dirrm %%NAGDIR%%/po
-@dirrm %%NAGDIR%%/scripts/drivers
-@dirrm %%NAGDIR%%/scripts
-@dirrm %%NAGDIR%%/templates/index
-@dirrm %%NAGDIR%%/templates/javascript
-@dirrm %%NAGDIR%%/templates/list
-@dirrm %%NAGDIR%%/templates/menu
-@dirrm %%NAGDIR%%/templates/prefs
-@dirrm %%NAGDIR%%/templates/search
-@dirrm %%NAGDIR%%/templates/task
-@dirrm %%NAGDIR%%/templates/view
-@dirrm %%NAGDIR%%/templates
-@dirrm %%NAGDIR%%
-etc/horde/httpd.conf.nag
-%%PORTDOCS%%@dirrm share/doc/nag
-@unexec if cmp -s %D/www/horde/config/registry.php %D/www/horde/config/registry.php.afterNag; then rm -f %D/www/horde/config/registry.php.afterNag; mv %D/www/horde/config/registry.php.beforeNag %D/www/horde/config/registry.php; fi
+@dirrm %%NAGDIR%%/lib/Notification/Listener
+@dirrm %%NAGDIR%%/lib/Notification
+@dirrm %%NAGDIR%%/lib/Driver
+@dirrm %%NAGDIR%%/lib/Block
+@dirrm %%NAGDIR%%/lib
+@unexec rmdir %D/%%NAGDIR%%/config 2>/dev/null || true
+@unexec rmdir %D/%%NAGDIR%% 2>/dev/null || true