aboutsummaryrefslogtreecommitdiff
path: root/deskutils/nautilus-actions
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-09-11 03:24:05 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-09-11 03:24:05 +0000
commitb15efad8d60da7539dc3c4cf12412e11b739bc60 (patch)
tree269e26ed4c0568ac458c2287e0f8fed6e192ab90 /deskutils/nautilus-actions
parent7bb493fa225175d2345b2dfde432f2d7759fa7fd (diff)
downloadports-b15efad8d60da7539dc3c4cf12412e11b739bc60.tar.gz
ports-b15efad8d60da7539dc3c4cf12412e11b739bc60.zip
Notes
Diffstat (limited to 'deskutils/nautilus-actions')
-rw-r--r--deskutils/nautilus-actions/Makefile8
-rw-r--r--deskutils/nautilus-actions/pkg-plist4
2 files changed, 9 insertions, 3 deletions
diff --git a/deskutils/nautilus-actions/Makefile b/deskutils/nautilus-actions/Makefile
index 6e285a73ab64..f420a0317012 100644
--- a/deskutils/nautilus-actions/Makefile
+++ b/deskutils/nautilus-actions/Makefile
@@ -7,6 +7,7 @@
PORTNAME= nautilus-actions
PORTVERSION= 0.6
+PORTREVISION= 1
CATEGORIES= deskutils
MASTER_SITES= ${MASTER_SITE_LOCAL} \
http://people.freebsd.org/~ahze/distfiles/
@@ -15,15 +16,20 @@ MASTER_SITE_SUBDIR= ahze
MAINTAINER= ahze@FreeBSD.org
COMMENT= Extension for Nautilus to configure programs to launch on files
-USE_GNOME= nautilus2 pygtk2 intlhack
+USE_GNOME= nautilus2 intlhack pygtk2
USE_GMAKE= yes
USE_LIBTOOL_VER=15
USE_PYTHON= yes
USE_X_PREFIX= yes
+USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
INTLTOOLIZE?= ${LOCALBASE}/bin/intltoolize
+post-patch:
+ @${REINPLACE_CMD} -e 's|@datadir@datadir@/pixmaps|${DATADIR}/nact|' \
+ ${WRKSRC}/nact/nact.desktop.in.in
+
pre-configure:
cd ${WRKSRC} && ${INTLTOOLIZE} --force
diff --git a/deskutils/nautilus-actions/pkg-plist b/deskutils/nautilus-actions/pkg-plist
index f7c77955afa0..5ab68bf4d0bb 100644
--- a/deskutils/nautilus-actions/pkg-plist
+++ b/deskutils/nautilus-actions/pkg-plist
@@ -4,6 +4,6 @@ share/locale/es/LC_MESSAGES/nautilus-actions.mo
%%DATADIR%%/config_newaction.xml
%%DATADIR%%/nact/nautilus-actions-config.glade
%%DATADIR%%/nact/nautilus-launch-icon.png
-@dirrm %%DATADIR%%/nact
-@dirrm %%DATADIR%%
+@unexec rmdir %D/%%DATADIR%%/nact 2> /dev/null || true
+@unexec rmdir %D/%%DATADIR%% 2> /dev/null || true
@unexec rmdir %D/share/applications 2> /dev/null || true