aboutsummaryrefslogtreecommitdiff
path: root/deskutils/nautilus-locked-folder
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 05:47:40 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-11-05 05:47:40 +0000
commit0343e179844d755bd8e0c41e9c3905e682bf3ec5 (patch)
treea542e7c06ef913ad3928a3e2ca44958e0f9e6018 /deskutils/nautilus-locked-folder
parente130c95d6b664d138f50f64cb07373b50ecccfae (diff)
downloadports-0343e179844d755bd8e0c41e9c3905e682bf3ec5.tar.gz
ports-0343e179844d755bd8e0c41e9c3905e682bf3ec5.zip
Notes
Diffstat (limited to 'deskutils/nautilus-locked-folder')
-rw-r--r--deskutils/nautilus-locked-folder/Makefile31
-rw-r--r--deskutils/nautilus-locked-folder/distinfo2
-rw-r--r--deskutils/nautilus-locked-folder/files/patch-configure11
-rw-r--r--deskutils/nautilus-locked-folder/pkg-descr6
4 files changed, 50 insertions, 0 deletions
diff --git a/deskutils/nautilus-locked-folder/Makefile b/deskutils/nautilus-locked-folder/Makefile
new file mode 100644
index 000000000000..2e8db90cf5b5
--- /dev/null
+++ b/deskutils/nautilus-locked-folder/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: nautilus-locked-folder
+# Date created: 2005-09-17
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/deskutils/nautilus-locked-folder/Makefile,v 1.2 2005/09/20 09:31:50 ahze Exp $
+#
+
+PORTNAME= nautilus-locked-folder
+PORTVERSION= 1.0.0
+CATEGORIES= deskutils security
+MASTER_SITES= http://www.ids.org.au/~jam6/locked-folders/
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Nautilus plugin that allows you to encrypt the contents of a folder
+
+USE_LIBTOOL_VER=15
+USE_REINPLACE= yes
+USE_X_PREFIX= yes
+USE_GNOME= nautilus2
+PKGCONFIGS= gtk+-2.0 libglade-2.0 libnautilus-extension libgnomeui-2.0
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include `pkg-config --cflags ${PKGCONFIGS}`" \
+ LDFLASG="-L${LOCALBASE}/lib -L${X11BASE}/lib `pkg-config --libs ${PKGCONFIGS}`" \
+ LIBS="-lssl"
+PLIST_FILES= lib/nautilus/extensions-1.0/libnautilus-locked-folder.so
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/share/icons/hicolor/32x32/stock/data/|${X11BASE}/share/icons/hicolor/32x32/stock/data/|' \
+ ${WRKSRC}/src/lockedfolder-extension.c
+
+.include <bsd.port.mk>
diff --git a/deskutils/nautilus-locked-folder/distinfo b/deskutils/nautilus-locked-folder/distinfo
new file mode 100644
index 000000000000..ea45191107c8
--- /dev/null
+++ b/deskutils/nautilus-locked-folder/distinfo
@@ -0,0 +1,2 @@
+MD5 (nautilus-locked-folder-1.0.0.tar.gz) = b83dd18fa26b524a61f6d61bfbcaf55c
+SIZE (nautilus-locked-folder-1.0.0.tar.gz) = 336027
diff --git a/deskutils/nautilus-locked-folder/files/patch-configure b/deskutils/nautilus-locked-folder/files/patch-configure
new file mode 100644
index 000000000000..f6801cb4b193
--- /dev/null
+++ b/deskutils/nautilus-locked-folder/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Wed Aug 31 07:17:44 2005
++++ configure Sat Sep 17 00:31:55 2005
+@@ -19277,7 +19277,7 @@
+ echo "$as_me:$LINENO: checking for libnautilus-extension >= $NAUTILUS_REQUIRED eel-2.0 >= $EEL_REQUIRED glib-2.0 >= $GLIB_REQUIRED openssl >= $OPENSSL_REQUIRED libglade-2.0 >= $LIBGLADE_REQUIRED libgnomeui-2.0 >= $LIBGNOMEUI_REQUIRED" >&5
+ echo $ECHO_N "checking for libnautilus-extension >= $NAUTILUS_REQUIRED eel-2.0 >= $EEL_REQUIRED glib-2.0 >= $GLIB_REQUIRED openssl >= $OPENSSL_REQUIRED libglade-2.0 >= $LIBGLADE_REQUIRED libgnomeui-2.0 >= $LIBGNOMEUI_REQUIRED... $ECHO_C" >&6
+
+- if $PKG_CONFIG --exists "libnautilus-extension >= $NAUTILUS_REQUIRED eel-2.0 >= $EEL_REQUIRED glib-2.0 >= $GLIB_REQUIRED openssl >= $OPENSSL_REQUIRED libglade-2.0 >= $LIBGLADE_REQUIRED libgnomeui-2.0 >= $LIBGNOMEUI_REQUIRED" ; then
++ if $PKG_CONFIG --exists "libnautilus-extension >= $NAUTILUS_REQUIRED eel-2.0 >= $EEL_REQUIRED glib-2.0 >= $GLIB_REQUIRED libglade-2.0 >= $LIBGLADE_REQUIRED libgnomeui-2.0 >= $LIBGNOMEUI_REQUIRED" ; then
+ echo "$as_me:$LINENO: result: yes" >&5
+ echo "${ECHO_T}yes" >&6
+ succeeded=yes
diff --git a/deskutils/nautilus-locked-folder/pkg-descr b/deskutils/nautilus-locked-folder/pkg-descr
new file mode 100644
index 000000000000..390cc98377af
--- /dev/null
+++ b/deskutils/nautilus-locked-folder/pkg-descr
@@ -0,0 +1,6 @@
+This is a plugin for Nautilus that adds a 'Lock folder' item to the
+right-click menus of folders. Locking a folder encrypts its contents
+and converts it into a '.locked' format archive. This archive can then
+be decrypted by right-clicking it and selecting 'Unlock folder'.
+
+WWW: http://www.ids.org.au/~jam6/locked-folders/