aboutsummaryrefslogtreecommitdiff
path: root/deskutils/nextcloudclient/files
diff options
context:
space:
mode:
authorMichael Reifenberger <mr@FreeBSD.org>2018-03-24 19:11:59 +0000
committerMichael Reifenberger <mr@FreeBSD.org>2018-03-24 19:11:59 +0000
commitea0ce349e74f02c68ed29292275c8b75dd4e8334 (patch)
tree7f177afc8023ae2a505d47cdcfe9770ad688b87d /deskutils/nextcloudclient/files
parent6165be3dfbf8a2ccc82c1b2b05a3812f79a24710 (diff)
downloadports-ea0ce349e74f02c68ed29292275c8b75dd4e8334.tar.gz
ports-ea0ce349e74f02c68ed29292275c8b75dd4e8334.zip
Notes
Diffstat (limited to 'deskutils/nextcloudclient/files')
-rw-r--r--deskutils/nextcloudclient/files/patch-doc_CMakeLists.txt11
-rw-r--r--deskutils/nextcloudclient/files/patch-man_CMakeLists.txt15
-rw-r--r--deskutils/nextcloudclient/files/patch-src_gui_accountsettings.cpp12
-rw-r--r--deskutils/nextcloudclient/files/patch-src_gui_generalsettings.cpp18
-rw-r--r--deskutils/nextcloudclient/files/patch-src_gui_owncloudgui.cpp11
-rw-r--r--deskutils/nextcloudclient/files/patch-src_libsync_configfile.cpp25
6 files changed, 92 insertions, 0 deletions
diff --git a/deskutils/nextcloudclient/files/patch-doc_CMakeLists.txt b/deskutils/nextcloudclient/files/patch-doc_CMakeLists.txt
new file mode 100644
index 000000000000..7aa57c6e3cb2
--- /dev/null
+++ b/deskutils/nextcloudclient/files/patch-doc_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- doc/CMakeLists.txt.orig 2017-12-20 15:03:02 UTC
++++ doc/CMakeLists.txt
+@@ -11,7 +11,7 @@ if(SPHINX_FOUND)
+ # assets
+ set(LATEX_LOGO "${CMAKE_CURRENT_SOURCE_DIR}/logo-blue.pdf")
+
+- set(APPLICATION_DOC_DIR "${CMAKE_INSTALL_DOCDIR}/${PACKAGE}")
++ set(APPLICATION_DOC_DIR "${CMAKE_INSTALL_DATAROOTDIR}/doc/owncloudclient")
+ install(DIRECTORY ${SPHINX_HTML_DIR} DESTINATION ${APPLICATION_DOC_DIR} OPTIONAL)
+ install(DIRECTORY ${SPHINX_PDF_DIR} DESTINATION ${APPLICATION_DOC_DIR} OPTIONAL)
+ install(DIRECTORY ${SPHINX_QCH_DIR} DESTINATION ${APPLICATION_DOC_DIR} OPTIONAL)
diff --git a/deskutils/nextcloudclient/files/patch-man_CMakeLists.txt b/deskutils/nextcloudclient/files/patch-man_CMakeLists.txt
new file mode 100644
index 000000000000..c5412b20ae9f
--- /dev/null
+++ b/deskutils/nextcloudclient/files/patch-man_CMakeLists.txt
@@ -0,0 +1,15 @@
+--- man/CMakeLists.txt.orig 2017-12-20 15:03:02 UTC
++++ man/CMakeLists.txt
+@@ -3,6 +3,12 @@ if(SPHINX_FOUND)
+ # Sphinx cache with pickled ReST documents
+ set(SPHINX_CACHE_DIR "${CMAKE_CURRENT_BINARY_DIR}/_doctrees")
+
++ if(WITH_DOC)
++ add_custom_target(man ALL DEPENDS doc-man COMMENT "Building manual pages...")
++ else(WITH_DOC)
++ add_custom_target(man DEPENDS doc-maan COMMENT "Building manual pages...")
++ endif(WITH_DOC)
++
+ # HTML output directory
+ set(SPHINX_MAN_DIR "${CMAKE_CURRENT_BINARY_DIR}/man1")
+ install(DIRECTORY ${SPHINX_MAN_DIR} DESTINATION ${CMAKE_INSTALL_MANDIR} OPTIONAL)
diff --git a/deskutils/nextcloudclient/files/patch-src_gui_accountsettings.cpp b/deskutils/nextcloudclient/files/patch-src_gui_accountsettings.cpp
new file mode 100644
index 000000000000..2f41eefd7126
--- /dev/null
+++ b/deskutils/nextcloudclient/files/patch-src_gui_accountsettings.cpp
@@ -0,0 +1,12 @@
+--- src/gui/accountsettings.cpp.orig 2017-12-20 15:03:02 UTC
++++ src/gui/accountsettings.cpp
+@@ -34,7 +34,8 @@
+ #include "tooltipupdater.h"
+ #include "filesystem.h"
+
+-#include <math.h>
++#include <climits>
++#include <cmath>
+
+ #include <QDesktopServices>
+ #include <QDir>
diff --git a/deskutils/nextcloudclient/files/patch-src_gui_generalsettings.cpp b/deskutils/nextcloudclient/files/patch-src_gui_generalsettings.cpp
new file mode 100644
index 000000000000..0b1683a51b39
--- /dev/null
+++ b/deskutils/nextcloudclient/files/patch-src_gui_generalsettings.cpp
@@ -0,0 +1,18 @@
+--- src/gui/generalsettings.cpp.orig 2017-12-20 15:03:02 UTC
++++ src/gui/generalsettings.cpp
+@@ -117,6 +117,7 @@ void GeneralSettings::loadMiscSettings()
+
+ void GeneralSettings::slotUpdateInfo()
+ {
++#if 0
+ // Note: the sparkle-updater is not an OCUpdater
+ OCUpdater *updater = qobject_cast<OCUpdater *>(Updater::instance());
+ if (ConfigFile().skipUpdateCheck()) {
+@@ -133,6 +134,7 @@ void GeneralSettings::slotUpdateInfo()
+ // can't have those infos from sparkle currently
+ _ui->updatesGroupBox->setVisible(false);
+ }
++#endif
+ }
+
+ void GeneralSettings::saveMiscSettings()
diff --git a/deskutils/nextcloudclient/files/patch-src_gui_owncloudgui.cpp b/deskutils/nextcloudclient/files/patch-src_gui_owncloudgui.cpp
new file mode 100644
index 000000000000..f9e0d7f0fd37
--- /dev/null
+++ b/deskutils/nextcloudclient/files/patch-src_gui_owncloudgui.cpp
@@ -0,0 +1,11 @@
+--- src/gui/owncloudgui.cpp.orig 2017-12-20 15:03:02 UTC
++++ src/gui/owncloudgui.cpp
+@@ -35,6 +35,8 @@
+ #include "common/syncjournalfilerecord.h"
+ #include "creds/abstractcredentials.h"
+
++#include <climits>
++
+ #include <QDesktopServices>
+ #include <QDir>
+ #include <QMessageBox>
diff --git a/deskutils/nextcloudclient/files/patch-src_libsync_configfile.cpp b/deskutils/nextcloudclient/files/patch-src_libsync_configfile.cpp
new file mode 100644
index 000000000000..09f5dc7f7598
--- /dev/null
+++ b/deskutils/nextcloudclient/files/patch-src_libsync_configfile.cpp
@@ -0,0 +1,25 @@
+--- src/libsync/configfile.cpp.orig 2017-12-20 15:03:02 UTC
++++ src/libsync/configfile.cpp
+@@ -448,11 +448,22 @@ bool ConfigFile::skipUpdateCheck(const QString &connec
+ if (connection.isEmpty())
+ con = defaultConnection();
+
++#if 0
+ QVariant fallback = getValue(QLatin1String(skipUpdateCheckC), con, false);
++#else
++ QVariant fallback = getValue(QLatin1String(skipUpdateCheckC), con, true);
++#endif
+ fallback = getValue(QLatin1String(skipUpdateCheckC), QString(), fallback);
+
+ QVariant value = getPolicySetting(QLatin1String(skipUpdateCheckC), fallback);
++#if 0
+ return value.toBool();
++#else
++ if ( !value.toBool() )
++ qDebug() << "FreeBSD package disabled the UpdateCheck mechanism.";
++
++ return true;
++#endif
+ }
+
+ void ConfigFile::setSkipUpdateCheck(bool skip, const QString &connection)