aboutsummaryrefslogtreecommitdiff
path: root/deskutils/noti
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2017-10-18 14:47:06 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2017-10-18 14:47:06 +0000
commit6061b621506158bef4103383739e12dea01eae3d (patch)
treedae6307932027320071f2d28e52018ee952c2df8 /deskutils/noti
parent45a75bcb6dc144375637eaec2b92831a47117844 (diff)
downloadports-6061b621506158bef4103383739e12dea01eae3d.tar.gz
ports-6061b621506158bef4103383739e12dea01eae3d.zip
Notes
Diffstat (limited to 'deskutils/noti')
-rw-r--r--deskutils/noti/Makefile30
-rw-r--r--deskutils/noti/distinfo3
-rw-r--r--deskutils/noti/pkg-descr7
3 files changed, 40 insertions, 0 deletions
diff --git a/deskutils/noti/Makefile b/deskutils/noti/Makefile
new file mode 100644
index 000000000000..c7140f311c60
--- /dev/null
+++ b/deskutils/noti/Makefile
@@ -0,0 +1,30 @@
+# Created by: Hiroki Tagato <tagattie@yandex.com>
+# $FreeBSD$
+
+PORTNAME= noti
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.7.0
+CATEGORIES= deskutils
+
+MAINTAINER= tagattie@yandex.com
+COMMENT= Trigger notifications when a process completes
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= notify-send:devel/libnotify
+
+USES= go
+USE_GITHUB= yes
+
+GH_ACCOUNT= variadico
+
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
+GO_TARGET= github.com/${GH_ACCOUNT}/${PORTNAME}/cmd/noti
+
+PLIST_FILES= bin/noti
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKDIR}/bin/noti ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/deskutils/noti/distinfo b/deskutils/noti/distinfo
new file mode 100644
index 000000000000..5ee3a9fe2780
--- /dev/null
+++ b/deskutils/noti/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1508212235
+SHA256 (variadico-noti-v2.7.0_GH0.tar.gz) = afa49bf15795e007b5cfd3cf65eb46187f16f39c2afd1040a2c6dccc4adeb2d0
+SIZE (variadico-noti-v2.7.0_GH0.tar.gz) = 3736439
diff --git a/deskutils/noti/pkg-descr b/deskutils/noti/pkg-descr
new file mode 100644
index 000000000000..7c893e3c1d38
--- /dev/null
+++ b/deskutils/noti/pkg-descr
@@ -0,0 +1,7 @@
+Trigger notifications when a process completes.
+
+Never sit and wait for some long-running process to finish! noti will
+alert you when it's done-on your computer or smartphone-so you can
+stop worrying about constantly checking the terminal.
+
+WWW: https://github.com/variadico/noti