aboutsummaryrefslogtreecommitdiff
path: root/deskutils/notification-daemon
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2006-11-14 13:01:25 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2006-11-14 13:01:25 +0000
commitfbbe817554d5bd3cef8b983653d238fb66b8ebbc (patch)
treea38086bc041082712fe966109c88c294d80a3af9 /deskutils/notification-daemon
parent095fdbcf13a90691a5a37ad37344db9bb90dd0b6 (diff)
downloadports-fbbe817554d5bd3cef8b983653d238fb66b8ebbc.tar.gz
ports-fbbe817554d5bd3cef8b983653d238fb66b8ebbc.zip
- Update to 0.3.6
- Make it work with dbus-glib >= 0.72 - Take maintainership PR: ports/104876 Submitted by: jylefort, Pawel Worach <pawel.worach@gmail.com> Approved by: maintainer timeout (17 days)
Notes
Notes: svn path=/head/; revision=177252
Diffstat (limited to 'deskutils/notification-daemon')
-rw-r--r--deskutils/notification-daemon/Makefile5
-rw-r--r--deskutils/notification-daemon/distinfo6
-rw-r--r--deskutils/notification-daemon/files/patch-src-Makefile.in11
-rw-r--r--deskutils/notification-daemon/files/patch-src-daemon.c69
4 files changed, 25 insertions, 66 deletions
diff --git a/deskutils/notification-daemon/Makefile b/deskutils/notification-daemon/Makefile
index adfa26ad4b18..f33307729438 100644
--- a/deskutils/notification-daemon/Makefile
+++ b/deskutils/notification-daemon/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= notification-daemon
-PORTVERSION= 0.3.5
-PORTREVISION= 3
+PORTVERSION= 0.3.6
CATEGORIES= deskutils gnome
MASTER_SITES= http://www.galago-project.org/files/releases/source/notification-daemon/
-MAINTAINER= andreas@syndrom23.de
+MAINTAINER= gnome@FreeBSD.org
COMMENT= Send small notifications to your desktop
LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
diff --git a/deskutils/notification-daemon/distinfo b/deskutils/notification-daemon/distinfo
index 51f8e9973003..b66b97c3b9e4 100644
--- a/deskutils/notification-daemon/distinfo
+++ b/deskutils/notification-daemon/distinfo
@@ -1,3 +1,3 @@
-MD5 (notification-daemon-0.3.5.tar.gz) = 7977c4c15139f9d53ddbfa8af707270f
-SHA256 (notification-daemon-0.3.5.tar.gz) = 83a15eb99bb7a895d52e31be1c1548789a8bc29e83d30e758cf034a6627a1184
-SIZE (notification-daemon-0.3.5.tar.gz) = 383582
+MD5 (notification-daemon-0.3.6.tar.gz) = a5a9aa63205e624da8468e35722b08bf
+SHA256 (notification-daemon-0.3.6.tar.gz) = a187976c1957a7a0e17014ed97cbb4341f6898d5f60301f1b0c37e52188ebd13
+SIZE (notification-daemon-0.3.6.tar.gz) = 402426
diff --git a/deskutils/notification-daemon/files/patch-src-Makefile.in b/deskutils/notification-daemon/files/patch-src-Makefile.in
new file mode 100644
index 000000000000..f81524646077
--- /dev/null
+++ b/deskutils/notification-daemon/files/patch-src-Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Sun Nov 5 08:46:21 2006
++++ src/Makefile.in Sun Nov 5 08:46:24 2006
+@@ -531,7 +531,7 @@
+
+
+ notificationdaemon-dbus-glue.h: notificationdaemon.xml
+- dbus-binding-tool --mode=glib-server \
++ dbus-binding-tool --mode=glib-server --prefix=notify_daemon \
+ $(srcdir)/notificationdaemon.xml > notificationdaemon-dbus-glue.h
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/deskutils/notification-daemon/files/patch-src-daemon.c b/deskutils/notification-daemon/files/patch-src-daemon.c
index e931c54e6bd8..67a5c548d383 100644
--- a/deskutils/notification-daemon/files/patch-src-daemon.c
+++ b/deskutils/notification-daemon/files/patch-src-daemon.c
@@ -1,62 +1,11 @@
-diff -Naur notification-daemon-0.3.5.orig/src/daemon.c notification-daemon-0.3.5/src/daemon.c
---- src/daemon.c 2006-04-26 10:32:50.000000000 +0200
-+++ src/daemon.c 2006-06-18 05:07:47.000000000 +0200
-@@ -399,14 +399,54 @@
- GValueArray *image_struct;
- GValue *value;
- GArray *tmp_array;
-+ GType type = G_VALUE_TYPE (icon_data);
-+
-+ static const GType types[] = {
-+ G_TYPE_INT,
-+ G_TYPE_INT,
-+ G_TYPE_INT,
-+ G_TYPE_BOOLEAN,
-+ G_TYPE_INT,
-+ G_TYPE_INT
-+ };
-+
-+
-+ if (dbus_g_type_is_struct (type))
-+ {
-+ int n;
-+
-+ if (dbus_g_type_get_struct_size (type) < 7)
-+ {
-+ g_warning("_notify_daemon_process_icon_data expected 7 data members, got only %d", dbus_g_type_get_struct_size (type));
-+ return FALSE;
-+ }
-+
-+ for (n = 0; n < G_N_ELEMENTS (types); ++n)
-+ {
-+ GType check = dbus_g_type_get_struct_member_type (type, n);
-+ if (check != types[n])
-+ {
-+ g_warning("_notify_daemon_process_icon_data expected '%s' at position %d, but got '%s'",
-+ g_type_name (types[n]), n, g_type_name (check));
-+ return FALSE;
-+ }
+--- src/daemon.c.orig Sun Nov 5 08:59:12 2006
++++ src/daemon.c Sun Nov 5 08:59:37 2006
+@@ -1089,7 +1089,7 @@
+ dbus_conn = dbus_g_connection_get_connection(connection);
-- if (!G_VALUE_HOLDS(icon_data, G_TYPE_VALUE_ARRAY))
-+ /* We must check this separately as it's not a constant and can't be part of the types[] array */
-+ if (dbus_g_type_get_struct_member_type (type, 6) != DBUS_TYPE_G_UCHAR_ARRAY)
-+ {
-+ g_warning("_notify_daemon_process_icon_data expected '%s' at position %d, but got '%s'",
-+ g_type_name (DBUS_TYPE_G_UCHAR_ARRAY), 6, g_type_name (dbus_g_type_get_struct_member_type (type,6)));
-+ return FALSE;
-+ }
-+ }
-+ }
-+ else
- {
-- g_warning("_notify_daemon_process_icon_data expected a "
-- "GValue of type GValueArray");
-- return FALSE;
-+ g_warning("_notify_daemon_process_icon_data got wrong data");
-+ return FALSE;
- }
-
-+
- image_struct = (GValueArray *)g_value_get_boxed(icon_data);
- value = g_value_array_get_nth(image_struct, 0);
+ dbus_g_object_type_install_info(NOTIFY_TYPE_DAEMON,
+- &dbus_glib__object_info);
++ &dbus_glib_notify_daemon_object_info);
+ bus_proxy = dbus_g_proxy_new_for_name(connection,
+ "org.freedesktop.DBus",