aboutsummaryrefslogtreecommitdiff
path: root/deskutils/phpicalendar
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2014-11-14 18:15:35 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2014-11-14 18:15:35 +0000
commita158751212463ce2f94edf8dfb7cbae19b605887 (patch)
treebb152b444c077de296e03a4b7af4f7faeab53367 /deskutils/phpicalendar
parentd3c5fdd8306131c77eb24028fbb84d48f6e4c092 (diff)
downloadports-a158751212463ce2f94edf8dfb7cbae19b605887.tar.gz
ports-a158751212463ce2f94edf8dfb7cbae19b605887.zip
Notes
Diffstat (limited to 'deskutils/phpicalendar')
-rw-r--r--deskutils/phpicalendar/Makefile38
-rw-r--r--deskutils/phpicalendar/distinfo4
-rw-r--r--deskutils/phpicalendar/files/patch-config.inc.php11
-rw-r--r--deskutils/phpicalendar/pkg-descr2
-rw-r--r--deskutils/phpicalendar/pkg-plist105
5 files changed, 84 insertions, 76 deletions
diff --git a/deskutils/phpicalendar/Makefile b/deskutils/phpicalendar/Makefile
index 852c0d957276..a010fc001590 100644
--- a/deskutils/phpicalendar/Makefile
+++ b/deskutils/phpicalendar/Makefile
@@ -2,33 +2,49 @@
# $FreeBSD$
PORTNAME= phpicalendar
-PORTVERSION= 2.24
-PORTREVISION= 2
+PORTVERSION= 2.4
+PORTEPOCH= 1
CATEGORIES= deskutils www
-MASTER_SITES= SF/${PORTNAME}/OldFiles
+#MASTER_SITES= SF/${PORTNAME}/files/${PORTNAME}/${PORTNAME}%202.4%20RC7
+# phpicalendar-2.4_20100615.tar.bz2
+# http://sourceforge.net/projects/phpicalendar/files/phpicalendar/phpicalendar%202.4%20RC7/phpicalendar-2.4_20100615.tar.bz2/download
+# /projects/ not /project/
+MASTER_SITES= http://sourceforge.net/projects/${PORTNAME}/files/${PORTNAME}/${PORTNAME}%202.4%20RC7/
+PKGNAMESUFFIX= -RC7
+DISTNAME= ${PORTNAME}-${PORTVERSION}_20100615
MAINTAINER= edwin@mavetju.org
COMMENT= Webbased calendar with iCal support
-USES= tar:tgz
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USES= tar:bz2
NO_BUILD= yes
USE_PHP= session pcre
PLIST_SUB= WWWOWN="${WWWOWN}" WWWGRP="${WWWGRP}"
SUB_FILES= pkg-message
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/${PORTNAME}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/
+
+PORTDOCS= AUTHORS COPYING README TIMEZONES
+
+OPTIONS_DEFINE= DOCS
-post-extract:
- ${FIND} ${WRKDIR} -name .DS_Store -delete
- ${FIND} ${WRKDIR} -name '._*' -delete
+.include <bsd.port.options.mk>
do-install:
${MKDIR} ${STAGEDIR}${WWWDIR}
-.for dir in admin calendars functions images includes languages rss templates
+ @${FIND} ${WRKSRC} -name \*.orig -exec ${RM} {} \;
+ @${MV} ${WRKSRC}/config.inc.php ${WRKSRC}/config.inc.php.sample
+.for dir in admin calendars functions images includes languages lib nicetitle rss templates
@${CP} -Rv ${WRKSRC}/${dir} ${STAGEDIR}${WWWDIR}
.endfor
-.for f in index.php TIMEZONES error.php day.php preferences.php print.php search.php week.php month.php year.php README COPYING AUTHORS
+.for f in caldav.php config.inc.php.sample day.php default_config.php error.php index.php month.php preferences.php print.php search.php week.php year.php
@${CP} -v ${WRKSRC}/${f} ${STAGEDIR}${WWWDIR}
.endfor
- @${CP} -v ${WRKSRC}/config.inc-dist.php ${STAGEDIR}${WWWDIR}/config.inc.php.sample
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+.endif
.include <bsd.port.mk>
diff --git a/deskutils/phpicalendar/distinfo b/deskutils/phpicalendar/distinfo
index 7fc99293c7e3..86347a33857d 100644
--- a/deskutils/phpicalendar/distinfo
+++ b/deskutils/phpicalendar/distinfo
@@ -1,2 +1,2 @@
-SHA256 (phpicalendar-2.24.tgz) = faa46ef2ec0331b668a630504fba9c6b4c7c23a4f0cf05f1e949d08c472cddd5
-SIZE (phpicalendar-2.24.tgz) = 282342
+SHA256 (phpicalendar-2.4_20100615.tar.bz2) = 3a8ce7f941ad1538114f41a6195d49ad03561224d8af7330629ffcf623c7ab98
+SIZE (phpicalendar-2.4_20100615.tar.bz2) = 247360
diff --git a/deskutils/phpicalendar/files/patch-config.inc.php b/deskutils/phpicalendar/files/patch-config.inc.php
new file mode 100644
index 000000000000..5732efd1f852
--- /dev/null
+++ b/deskutils/phpicalendar/files/patch-config.inc.php
@@ -0,0 +1,11 @@
+--- config.inc.php.orig 2009-04-08 06:42:59.000000000 +0200
++++ config.inc.php 2012-05-04 19:43:02.000000000 +0200
+@@ -100,7 +100,7 @@
+ */
+ $list_webcals = array(
+ # 'webcal://dimer.tamu.edu/calendars/seminars/Biochem.ics'
+-'webcal://calendar.sxsw.com/iCal-EXDrB-sa-sxsw@rollerfeet.com.ics'
++# 'webcal://calendar.sxsw.com/iCal-EXDrB-sa-sxsw@rollerfeet.com.ics'
+ );
+ $more_webcals['recur_tests'] = array();
+ $locked_cals = array(
diff --git a/deskutils/phpicalendar/pkg-descr b/deskutils/phpicalendar/pkg-descr
index d7f266812654..e5cabd30c17b 100644
--- a/deskutils/phpicalendar/pkg-descr
+++ b/deskutils/phpicalendar/pkg-descr
@@ -4,4 +4,4 @@ manner with day, week, month, and year navigation, printer view,
RSS-enabled, and searchable. It supports 12 languages, is fully
theme-able, and has complete timezone support.
-WWW: http://phpicalendar.sourceforge.net/
+WWW: http://sourceforge.net/projects/phpicalendar/
diff --git a/deskutils/phpicalendar/pkg-plist b/deskutils/phpicalendar/pkg-plist
index dee813b4e4cb..852ab50fe79b 100644
--- a/deskutils/phpicalendar/pkg-plist
+++ b/deskutils/phpicalendar/pkg-plist
@@ -1,16 +1,21 @@
@owner %%WWWOWN%%
@group %%WWWGRP%%
-%%WWWDIR%%/AUTHORS
-%%WWWDIR%%/COPYING
-%%WWWDIR%%/README
-%%WWWDIR%%/TIMEZONES
%%WWWDIR%%/admin/index.php
+%%WWWDIR%%/caldav.php
%%WWWDIR%%/calendars/Home.ics
%%WWWDIR%%/calendars/US Holidays.ics
%%WWWDIR%%/calendars/Work.ics
%%WWWDIR%%/calendars/publish.php
+%%WWWDIR%%/calendars/recur_tests/ex_set1.ics
+%%WWWDIR%%/calendars/recur_tests/ex_set2.ics
+%%WWWDIR%%/calendars/recur_tests/ex_set3.ics
+%%WWWDIR%%/calendars/recur_tests/ex_set4.ics
+%%WWWDIR%%/calendars/recur_tests/ex_set5.ics
+%%WWWDIR%%/calendars/recur_tests/ex_set6.ics
+%%WWWDIR%%/calendars/test.ics
@sample %%WWWDIR%%/config.inc.php.sample
%%WWWDIR%%/day.php
+%%WWWDIR%%/default_config.php
%%WWWDIR%%/error.php
%%WWWDIR%%/functions/admin_functions.php
%%WWWDIR%%/functions/calendar_functions.php
@@ -19,9 +24,17 @@
%%WWWDIR%%/functions/event.js
%%WWWDIR%%/functions/ical_parser.php
%%WWWDIR%%/functions/init.inc.php
+%%WWWDIR%%/functions/init/configs.php
+%%WWWDIR%%/functions/init/cpaths.php
+%%WWWDIR%%/functions/init/date_range.php
+%%WWWDIR%%/functions/init/sanitize.php
+%%WWWDIR%%/functions/init/set_error_reporting.php
+%%WWWDIR%%/functions/is_daylight.php
%%WWWDIR%%/functions/list_functions.php
-%%WWWDIR%%/functions/overlapping_events.php
-%%WWWDIR%%/functions/sanitize.php
+%%WWWDIR%%/functions/parse/end_vevent.php
+%%WWWDIR%%/functions/parse/overlapping_events.php
+%%WWWDIR%%/functions/parse/parse_tzs.php
+%%WWWDIR%%/functions/parse/recur_functions.php
%%WWWDIR%%/functions/template.php
%%WWWDIR%%/functions/timezones.php
%%WWWDIR%%/functions/userauth_functions.php
@@ -29,6 +42,9 @@
%%WWWDIR%%/images/completed.gif
%%WWWDIR%%/images/confirmed.gif
%%WWWDIR%%/images/important.gif
+%%WWWDIR%%/images/longevent_end.gif
+%%WWWDIR%%/images/longevent_mid.gif
+%%WWWDIR%%/images/longevent_start.gif
%%WWWDIR%%/images/not_completed.gif
%%WWWDIR%%/images/phpical-logo.gif
%%WWWDIR%%/images/recurring.gif
@@ -36,23 +52,26 @@
%%WWWDIR%%/images/tentative.gif
%%WWWDIR%%/images/valid-rss.png
%%WWWDIR%%/includes/event.php
-%%WWWDIR%%/includes/login.php
%%WWWDIR%%/includes/todo.php
%%WWWDIR%%/index.php
%%WWWDIR%%/languages/afrikaans.inc.php
%%WWWDIR%%/languages/brazilian.inc.php
%%WWWDIR%%/languages/bulgarian.inc.php
%%WWWDIR%%/languages/catalan.inc.php
+%%WWWDIR%%/languages/croatian.inc.php
%%WWWDIR%%/languages/czech.inc.php
%%WWWDIR%%/languages/danish.inc.php
%%WWWDIR%%/languages/dutch.inc.php
+%%WWWDIR%%/languages/english-uk.inc.php
%%WWWDIR%%/languages/english.inc.php
%%WWWDIR%%/languages/esperanto.inc.php
+%%WWWDIR%%/languages/estonian.inc.php
%%WWWDIR%%/languages/finnish.inc.php
%%WWWDIR%%/languages/french.inc.php
%%WWWDIR%%/languages/galego.inc.php
%%WWWDIR%%/languages/german.inc.php
%%WWWDIR%%/languages/hungarian.inc.php
+%%WWWDIR%%/languages/indonesian.inc.php
%%WWWDIR%%/languages/italian.inc.php
%%WWWDIR%%/languages/japanese.inc.php
%%WWWDIR%%/languages/korean.inc.php
@@ -61,18 +80,34 @@
%%WWWDIR%%/languages/polish.inc.php
%%WWWDIR%%/languages/portuguese.inc.php
%%WWWDIR%%/languages/russian.inc.php
-%%WWWDIR%%/languages/slovak.inc.php
%%WWWDIR%%/languages/slovensko.inc.php
%%WWWDIR%%/languages/spanish.inc.php
%%WWWDIR%%/languages/swedish.inc.php
%%WWWDIR%%/languages/traditional_chinese.inc.php
+%%WWWDIR%%/lib/HTTP/CalDAV/Server.php
+%%WWWDIR%%/lib/HTTP/CalDAV/Tools/ICalendarParser.php
+%%WWWDIR%%/lib/HTTP/CalDAV/Tools/ReportParser.php
+%%WWWDIR%%/lib/HTTP/WebDAV/Server.php
+%%WWWDIR%%/lib/HTTP/WebDAV/Tools/_parse_lockinfo.php
+%%WWWDIR%%/lib/HTTP/WebDAV/Tools/_parse_propfind.php
+%%WWWDIR%%/lib/HTTP/WebDAV/Tools/_parse_proppatch.php
+%%WWWDIR%%/lib/bennu/bennu.class.php
+%%WWWDIR%%/lib/bennu/iCalendar_components.php
+%%WWWDIR%%/lib/bennu/iCalendar_parameters.php
+%%WWWDIR%%/lib/bennu/iCalendar_properties.php
+%%WWWDIR%%/lib/bennu/iCalendar_rfc2445.php
%%WWWDIR%%/month.php
+%%WWWDIR%%/nicetitle/nicetitle.css
+%%WWWDIR%%/nicetitle/nicetitle.js
+%%WWWDIR%%/nicetitle/ntbg.png
%%WWWDIR%%/preferences.php
%%WWWDIR%%/print.php
+%%WWWDIR%%/rss/feed.png
%%WWWDIR%%/rss/index.php
%%WWWDIR%%/rss/rss.php
%%WWWDIR%%/rss/rss1.0.php
%%WWWDIR%%/rss/rss2.0.php
+%%WWWDIR%%/rss/rss_common.php
%%WWWDIR%%/rss/xml.gif
%%WWWDIR%%/search.php
%%WWWDIR%%/templates/default/admin.tpl
@@ -134,9 +169,6 @@
%%WWWDIR%%/templates/default/todo.tpl
%%WWWDIR%%/templates/default/week.tpl
%%WWWDIR%%/templates/default/year.tpl
-%%WWWDIR%%/templates/green/admin.tpl
-%%WWWDIR%%/templates/green/calendar_nav.tpl
-%%WWWDIR%%/templates/green/day.tpl
%%WWWDIR%%/templates/green/default.css
%%WWWDIR%%/templates/green/error.tpl
%%WWWDIR%%/templates/green/event.tpl
@@ -180,23 +212,10 @@
%%WWWDIR%%/templates/green/images/time_bg.gif
%%WWWDIR%%/templates/green/images/week_on.gif
%%WWWDIR%%/templates/green/images/year_on.gif
-%%WWWDIR%%/templates/green/month.tpl
-%%WWWDIR%%/templates/green/month_large.tpl
-%%WWWDIR%%/templates/green/month_medium.tpl
-%%WWWDIR%%/templates/green/month_small.tpl
-%%WWWDIR%%/templates/green/preferences.tpl
%%WWWDIR%%/templates/green/print.tpl
-%%WWWDIR%%/templates/green/rss_index.tpl
%%WWWDIR%%/templates/green/search.tpl
-%%WWWDIR%%/templates/green/search_box.tpl
%%WWWDIR%%/templates/green/seminar.tpl
-%%WWWDIR%%/templates/green/sidebar.tpl
%%WWWDIR%%/templates/green/todo.tpl
-%%WWWDIR%%/templates/green/week.tpl
-%%WWWDIR%%/templates/green/year.tpl
-%%WWWDIR%%/templates/grey/admin.tpl
-%%WWWDIR%%/templates/grey/calendar_nav.tpl
-%%WWWDIR%%/templates/grey/day.tpl
%%WWWDIR%%/templates/grey/default.css
%%WWWDIR%%/templates/grey/error.tpl
%%WWWDIR%%/templates/grey/event.tpl
@@ -240,23 +259,10 @@
%%WWWDIR%%/templates/grey/images/time_bg.gif
%%WWWDIR%%/templates/grey/images/week_on.gif
%%WWWDIR%%/templates/grey/images/year_on.gif
-%%WWWDIR%%/templates/grey/month.tpl
-%%WWWDIR%%/templates/grey/month_large.tpl
-%%WWWDIR%%/templates/grey/month_medium.tpl
-%%WWWDIR%%/templates/grey/month_small.tpl
-%%WWWDIR%%/templates/grey/preferences.tpl
%%WWWDIR%%/templates/grey/print.tpl
-%%WWWDIR%%/templates/grey/rss_index.tpl
%%WWWDIR%%/templates/grey/search.tpl
-%%WWWDIR%%/templates/grey/search_box.tpl
%%WWWDIR%%/templates/grey/seminar.tpl
-%%WWWDIR%%/templates/grey/sidebar.tpl
%%WWWDIR%%/templates/grey/todo.tpl
-%%WWWDIR%%/templates/grey/week.tpl
-%%WWWDIR%%/templates/grey/year.tpl
-%%WWWDIR%%/templates/red/admin.tpl
-%%WWWDIR%%/templates/red/calendar_nav.tpl
-%%WWWDIR%%/templates/red/day.tpl
%%WWWDIR%%/templates/red/default.css
%%WWWDIR%%/templates/red/error.tpl
%%WWWDIR%%/templates/red/event.tpl
@@ -299,23 +305,9 @@
%%WWWDIR%%/templates/red/images/time_bg.gif
%%WWWDIR%%/templates/red/images/week_on.gif
%%WWWDIR%%/templates/red/images/year_on.gif
-%%WWWDIR%%/templates/red/month.tpl
-%%WWWDIR%%/templates/red/month_large.tpl
-%%WWWDIR%%/templates/red/month_medium.tpl
-%%WWWDIR%%/templates/red/month_small.tpl
-%%WWWDIR%%/templates/red/preferences.tpl
%%WWWDIR%%/templates/red/print.tpl
-%%WWWDIR%%/templates/red/rss_index.tpl
%%WWWDIR%%/templates/red/search.tpl
-%%WWWDIR%%/templates/red/search_box.tpl
-%%WWWDIR%%/templates/red/sidebar.tpl
-%%WWWDIR%%/templates/red/sidebar_year.tpl
%%WWWDIR%%/templates/red/todo.tpl
-%%WWWDIR%%/templates/red/week.tpl
-%%WWWDIR%%/templates/red/year.tpl
-%%WWWDIR%%/templates/tan/admin.tpl
-%%WWWDIR%%/templates/tan/calendar_nav.tpl
-%%WWWDIR%%/templates/tan/day.tpl
%%WWWDIR%%/templates/tan/default.css
%%WWWDIR%%/templates/tan/error.tpl
%%WWWDIR%%/templates/tan/event.tpl
@@ -334,7 +326,6 @@
%%WWWDIR%%/templates/tan/images/background.gif
%%WWWDIR%%/templates/tan/images/day_on.gif
%%WWWDIR%%/templates/tan/images/day_title.gif
-%%WWWDIR%%/templates/tan/images/default.css
%%WWWDIR%%/templates/tan/images/download_arrow.gif
%%WWWDIR%%/templates/tan/images/event_dot.gif
%%WWWDIR%%/templates/tan/images/left_arrows.gif
@@ -360,20 +351,10 @@
%%WWWDIR%%/templates/tan/images/time_bg.gif
%%WWWDIR%%/templates/tan/images/week_on.gif
%%WWWDIR%%/templates/tan/images/year_on.gif
-%%WWWDIR%%/templates/tan/month.tpl
-%%WWWDIR%%/templates/tan/month_large.tpl
-%%WWWDIR%%/templates/tan/month_medium.tpl
-%%WWWDIR%%/templates/tan/month_small.tpl
-%%WWWDIR%%/templates/tan/preferences.tpl
%%WWWDIR%%/templates/tan/print.tpl
-%%WWWDIR%%/templates/tan/rss_index.tpl
%%WWWDIR%%/templates/tan/search.tpl
-%%WWWDIR%%/templates/tan/search_box.tpl
%%WWWDIR%%/templates/tan/seminar.tpl
-%%WWWDIR%%/templates/tan/sidebar.tpl
%%WWWDIR%%/templates/tan/todo.tpl
-%%WWWDIR%%/templates/tan/week.tpl
-%%WWWDIR%%/templates/tan/year.tpl
%%WWWDIR%%/week.php
%%WWWDIR%%/year.php
@owner root