aboutsummaryrefslogtreecommitdiff
path: root/deskutils/pinot/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2017-04-03 09:58:34 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2017-04-03 09:58:34 +0000
commit1482d1097bdc777ba0e1f2f8b6f266748e5c1452 (patch)
tree719a8dd0473ff60692babc42688eec3bb4fe2e7c /deskutils/pinot/Makefile
parent9ed8d0d88168af08994da1c806c21003caee805a (diff)
downloadports-1482d1097bdc777ba0e1f2f8b6f266748e5c1452.tar.gz
ports-1482d1097bdc777ba0e1f2f8b6f266748e5c1452.zip
Notes
Diffstat (limited to 'deskutils/pinot/Makefile')
-rw-r--r--deskutils/pinot/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/deskutils/pinot/Makefile b/deskutils/pinot/Makefile
index f00680c287c5..6d668c2e38ad 100644
--- a/deskutils/pinot/Makefile
+++ b/deskutils/pinot/Makefile
@@ -11,8 +11,6 @@ COMMENT= Personal search and metasearch for the Free Desktop
LICENSE= GPLv2
-BROKEN= depends on C++11 libs while not itself being C++11 compatible
-
BUILD_DEPENDS= desktop-file-install:devel/desktop-file-utils \
update-mime-database:misc/shared-mime-info
LIB_DEPENDS= libxapian.so:databases/xapian-core \
@@ -48,8 +46,9 @@ CONFIGURE_ENV= MKDIR_P="${MKDIR}" TEXTCAT_LIBS="-lexttextcat-2.0"
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib -lboost_system
-USES= autoreconf execinfo gettext libarchive libtool pkgconfig python \
- shebangfix sqlite:3 ssl
+USES= compiler:c++11-lang autoreconf execinfo gettext libarchive \
+ libtool pkgconfig python shebangfix sqlite:3 ssl
+USE_CXXSTD= c++11
USE_XORG= pixman
USE_GNOME= atkmm cairo cairomm glibmm gtk20 gtkmm24 libsigc++20 libxml2 pangomm
USE_LDCONFIG= ${PREFIX}/lib/pinot/backends ${PREFIX}/lib/pinot/filters