aboutsummaryrefslogtreecommitdiff
path: root/deskutils/pinot
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2007-08-03 21:11:54 +0000
committerThierry Thomas <thierry@FreeBSD.org>2007-08-03 21:11:54 +0000
commit0faf6689a98c880b54182fc4e213b97b3bd1b666 (patch)
treeddd479a5bef240657f26de5fbf056ea1c04ee9dd /deskutils/pinot
parentab85db03ab31dcdd92e91969409282e704c11dd4 (diff)
downloadports-0faf6689a98c880b54182fc4e213b97b3bd1b666.tar.gz
ports-0faf6689a98c880b54182fc4e213b97b3bd1b666.zip
Notes
Diffstat (limited to 'deskutils/pinot')
-rw-r--r--deskutils/pinot/Makefile1
-rw-r--r--deskutils/pinot/files/patch-gsoap279e51
2 files changed, 24 insertions, 28 deletions
diff --git a/deskutils/pinot/Makefile b/deskutils/pinot/Makefile
index e98a14ccc48d..b88c12526e9e 100644
--- a/deskutils/pinot/Makefile
+++ b/deskutils/pinot/Makefile
@@ -6,6 +6,7 @@
PORTNAME= pinot
PORTVERSION= 0.75
+PORTREVISION= 1
CATEGORIES= deskutils
MASTER_SITES= ${MASTER_SITE_BERLIOS}
#MASTER_SITES= http://www.chez.com/colinf/pinot/ \
diff --git a/deskutils/pinot/files/patch-gsoap279e b/deskutils/pinot/files/patch-gsoap279e
index 4c9067de8f7a..86423a2647f9 100644
--- a/deskutils/pinot/files/patch-gsoap279e
+++ b/deskutils/pinot/files/patch-gsoap279e
@@ -1,6 +1,6 @@
diff -Naur ./Search/Google/GAPIC.cpp ./Search/Google/GAPIC.cpp
--- ./Search/Google/GAPIC.cpp 2006-11-22 21:09:11.000000000 +0800
-+++ ./Search/Google/GAPIC.cpp 2007-07-29 18:34:02.000000000 +0800
++++ ./Search/Google/GAPIC.cpp 2007-08-04 01:17:43.000000000 +0800
@@ -1,13 +1,13 @@
/* GAPIC.cpp
- Generated by gSOAP 2.7.8c from GoogleSearch.h
@@ -1675,33 +1675,6 @@ diff -Naur ./Search/Google/GAPIC.cpp ./Search/Google/GAPIC.cpp
SOAP_FMAC3 int SOAP_FMAC4 soap_put_gapi1__doGoogleSearch(struct soap *soap, const struct gapi1__doGoogleSearch *a, const char *tag, const char *type)
{
register int id = soap_embed(soap, (void*)a, NULL, 0, tag, SOAP_TYPE_gapi1__doGoogleSearch);
-@@ -2742,16 +2765,16 @@
- SOAP_FMAC3 int SOAP_FMAC4 soap_out_gapi1__doGoogleSearch(struct soap *soap, const char *tag, int id, const struct gapi1__doGoogleSearch *a, const char *type)
- {
- soap_element_begin_out(soap, tag, soap_embedded_id(soap, id, a, SOAP_TYPE_gapi1__doGoogleSearch), type);
-- soap_out_std__string(soap, "key", -1, &a->key, "xsd:string");
-- soap_out_std__string(soap, "q", -1, &a->q, "xsd:string");
-- soap_out_int(soap, "start", -1, &a->start, "xsd:int");
-- soap_out_int(soap, "maxResults", -1, &a->maxResults, "xsd:int");
-- soap_out_bool(soap, "filter", -1, &a->filter, "xsd:boolean");
-- soap_out_std__string(soap, "restrict", -1, &a->restrict_, "xsd:string");
-- soap_out_bool(soap, "safeSearch", -1, &a->safeSearch, "xsd:boolean");
-- soap_out_std__string(soap, "lr", -1, &a->lr, "xsd:string");
-- soap_out_std__string(soap, "ie", -1, &a->ie, "xsd:string");
-- soap_out_std__string(soap, "oe", -1, &a->oe, "xsd:string");
-+ soap_out_std__string(soap, "key", -1, &a->key, "");
-+ soap_out_std__string(soap, "q", -1, &a->q, "");
-+ soap_out_int(soap, "start", -1, &a->start, "");
-+ soap_out_int(soap, "maxResults", -1, &a->maxResults, "");
-+ soap_out_bool(soap, "filter", -1, &a->filter, "");
-+ soap_out_std__string(soap, "restrict", -1, &a->restrict_, "");
-+ soap_out_bool(soap, "safeSearch", -1, &a->safeSearch, "");
-+ soap_out_std__string(soap, "lr", -1, &a->lr, "");
-+ soap_out_std__string(soap, "ie", -1, &a->ie, "");
-+ soap_out_std__string(soap, "oe", -1, &a->oe, "");
- soap_element_end_out(soap, tag);
- return SOAP_OK;
- }
@@ -2833,18 +2856,18 @@
if (soap->error)
return NULL;
@@ -1831,6 +1804,17 @@ diff -Naur ./Search/Google/GAPIC.cpp ./Search/Google/GAPIC.cpp
}
SOAP_FMAC3 int SOAP_FMAC4 soap_put_gapi1__doSpellingSuggestion(struct soap *soap, const struct gapi1__doSpellingSuggestion *a, const char *tag, const char *type)
+@@ -3009,8 +3044,8 @@
+ SOAP_FMAC3 int SOAP_FMAC4 soap_out_gapi1__doSpellingSuggestion(struct soap *soap, const char *tag, int id, const struct gapi1__doSpellingSuggestion *a, const char *type)
+ {
+ soap_element_begin_out(soap, tag, soap_embedded_id(soap, id, a, SOAP_TYPE_gapi1__doSpellingSuggestion), type);
+- soap_out_std__string(soap, "key", -1, &a->key, "");
+- soap_out_std__string(soap, "phrase", -1, &a->phrase, "");
++ soap_out_std__string(soap, "key", -1, &a->key, "xsd:string");
++ soap_out_std__string(soap, "phrase", -1, &a->phrase, "xsd:string");
+ soap_element_end_out(soap, tag);
+ return SOAP_OK;
+ }
@@ -3052,18 +3087,18 @@
if (soap->error)
return NULL;
@@ -1975,6 +1959,17 @@ diff -Naur ./Search/Google/GAPIC.cpp ./Search/Google/GAPIC.cpp
}
SOAP_FMAC3 int SOAP_FMAC4 soap_put_gapi1__doGetCachedPage(struct soap *soap, const struct gapi1__doGetCachedPage *a, const char *tag, const char *type)
+@@ -3231,8 +3278,8 @@
+ SOAP_FMAC3 int SOAP_FMAC4 soap_out_gapi1__doGetCachedPage(struct soap *soap, const char *tag, int id, const struct gapi1__doGetCachedPage *a, const char *type)
+ {
+ soap_element_begin_out(soap, tag, soap_embedded_id(soap, id, a, SOAP_TYPE_gapi1__doGetCachedPage), type);
+- soap_out_std__string(soap, "key", -1, &a->key, "");
+- soap_out_std__string(soap, "url", -1, &a->url, "");
++ soap_out_std__string(soap, "key", -1, &a->key, "xsd:string");
++ soap_out_std__string(soap, "url", -1, &a->url, "xsd:string");
+ soap_element_end_out(soap, tag);
+ return SOAP_OK;
+ }
@@ -3274,18 +3321,18 @@
if (soap->error)
return NULL;