aboutsummaryrefslogtreecommitdiff
path: root/deskutils/pinot
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2007-09-05 21:06:55 +0000
committerThierry Thomas <thierry@FreeBSD.org>2007-09-05 21:06:55 +0000
commitfea6eb7255147a9a804336a9c37fc652f93b79a0 (patch)
tree359cb32c3de2300aaebecbb12a930314054b0d59 /deskutils/pinot
parentaa11fe8441e20b937af8e890482631d6713000b5 (diff)
downloadports-fea6eb7255147a9a804336a9c37fc652f93b79a0.tar.gz
ports-fea6eb7255147a9a804336a9c37fc652f93b79a0.zip
Notes
Diffstat (limited to 'deskutils/pinot')
-rw-r--r--deskutils/pinot/Makefile1
-rw-r--r--deskutils/pinot/files/patch-dbusxapianindex_reload0377
2 files changed, 78 insertions, 0 deletions
diff --git a/deskutils/pinot/Makefile b/deskutils/pinot/Makefile
index 576c94143355..40096a532ec1 100644
--- a/deskutils/pinot/Makefile
+++ b/deskutils/pinot/Makefile
@@ -6,6 +6,7 @@
PORTNAME= pinot
PORTVERSION= 0.76
+PORTREVISION= 1
CATEGORIES= deskutils
MASTER_SITES= ${MASTER_SITE_BERLIOS}
#MASTER_SITES= http://www.chez.com/colinf/pinot/ \
diff --git a/deskutils/pinot/files/patch-dbusxapianindex_reload03 b/deskutils/pinot/files/patch-dbusxapianindex_reload03
new file mode 100644
index 000000000000..08db723aeb27
--- /dev/null
+++ b/deskutils/pinot/files/patch-dbusxapianindex_reload03
@@ -0,0 +1,77 @@
+--- Index/DBusXapianIndex.cpp 2007-08-22 21:58:20.000000000 +0800
++++ Index/DBusXapianIndex.cpp 2007-09-01 11:23:26.000000000 +0800
+@@ -17,15 +17,6 @@
+ */
+
+ #include <iostream>
+-extern "C"
+-{
+-#if DBUS_VERSION < 1000000
+-#define DBUS_API_SUBJECT_TO_CHANGE
+-#endif
+-#include <dbus/dbus.h>
+-#include <dbus/dbus-glib.h>
+-#include <dbus/dbus-glib-lowlevel.h>
+-}
+
+ #include "Languages.h"
+ #include "XapianDatabaseFactory.h"
+@@ -302,7 +293,7 @@
+ /// Asks the D-Bus service to reload its configuration.
+ bool DBusXapianIndex::reload(void)
+ {
+- bool reloading = false;
++ gboolean reloading = FALSE;
+
+ DBusGConnection *pBus = getBusConnection();
+ if (pBus == NULL)
+@@ -333,7 +324,12 @@
+ g_object_unref(pBusProxy);
+ // FIXME: don't we have to call dbus_g_connection_unref(pBus); ?
+
+- return reloading;
++ if (reloading == TRUE)
++ {
++ return true;
++ }
++
++ return false;
+ }
+
+
+--- Index/DBusXapianIndex.h 2007-08-22 21:54:40.000000000 +0800
++++ Index/DBusXapianIndex.h 2007-09-01 11:23:37.000000000 +0800
+@@ -21,12 +21,15 @@
+
+ #include <string>
+ #include <set>
++#include "config.h"
+ extern "C"
+ {
+ #if DBUS_VERSION < 1000000
+ #define DBUS_API_SUBJECT_TO_CHANGE
+ #endif
+ #include <dbus/dbus.h>
++#include <dbus/dbus-glib.h>
++#include <dbus/dbus-glib-lowlevel.h>
+ }
+
+ #include "XapianIndex.h"
+--- UI/GTK2/src/pinot.cc 2007-08-22 22:01:28.000000000 +0800
++++ UI/GTK2/src/pinot.cc 2007-09-01 10:55:10.000000000 +0800
+@@ -29,6 +29,7 @@
+ #include <glibmm/ustring.h>
+ #include <glibmm/miscutils.h>
+ #include <glibmm/convert.h>
++#include "config.h"
+ extern "C"
+ {
+ #if DBUS_VERSION < 1000000
+@@ -50,7 +51,6 @@
+ #include "ViewHistory.h"
+ #include "DownloaderInterface.h"
+ #include "XapianIndex.h"
+-#include "config.h"
+ #include "NLS.h"
+ #include "PinotSettings.h"
+ #include "mainWindow.hh"