aboutsummaryrefslogtreecommitdiff
path: root/deskutils/plan/Makefile
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-05-13 17:27:39 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-05-13 17:27:39 +0000
commit141111a2aba6fdbd6826e1a5c44e68b4240255d6 (patch)
tree0d334c203bb7414f8f1b301322e3bfff17b93dc9 /deskutils/plan/Makefile
parent6965e56ee678e5c7352d6dfe287953a7a3a1096d (diff)
downloadports-141111a2aba6fdbd6826e1a5c44e68b4240255d6.tar.gz
ports-141111a2aba6fdbd6826e1a5c44e68b4240255d6.zip
Notes
Diffstat (limited to 'deskutils/plan/Makefile')
-rw-r--r--deskutils/plan/Makefile50
1 files changed, 29 insertions, 21 deletions
diff --git a/deskutils/plan/Makefile b/deskutils/plan/Makefile
index 1be70c6e2903..f714a76dabd7 100644
--- a/deskutils/plan/Makefile
+++ b/deskutils/plan/Makefile
@@ -7,12 +7,12 @@
# Also update ports/japanese/plan/ (ja-plan) when this port is updated
PORTNAME= plan
-PORTVERSION= 1.8.7
+PORTVERSION= 1.9
CATEGORIES+= deskutils
MASTER_SITES= ftp://plan.ftp.fu-berlin.de/
MASTER_SITE_SUBDIR= applications
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= shaun@inerd.com
COMMENT= An X/Motif schedule planner with calendar
USE_MOTIF= yes
@@ -21,29 +21,37 @@ ALL_TARGET= freebsd
MAN1= netplan.1 plan.1
MAN4= plan.4
-post-patch:
- cd ${WRKSRC} && ${MV} config.h config.h.orig && ${SED} -e 's,%%PREFIX%%,${PREFIX},' \
- < config.h.orig > config.h
+MAKE_ENV+= DATADIR=${DATADIR} EXAMPLESDIR=${EXAMPLESDIR}
+
do-install:
- @${MKDIR} ${PREFIX}/share/doc/plan/examples ;\
- cd ${WRKSRC} ; ${INSTALL_PROGRAM} plan pland netplan notifier ${PREFIX}/bin ;\
- ${INSTALL_SCRIPT} ../misc/Killpland ${PREFIX}/bin ;\
- ${INSTALL_MAN} ../misc/netplan.1 ../misc/plan.1 ${MAN1PREFIX}/man/man1 ;\
- ${INSTALL_MAN} ../misc/plan.4 ${MAN4PREFIX}/man/man4 ;\
- ${INSTALL_DATA} ../misc/plan_cal.ps ../language/* ../misc/Mkdoc ../misc/Mkdoc.nawk \
- ../misc/BlackWhite ../misc/Monochrome ../README \
- ${PREFIX}/share/doc/plan ;\
- cd ${WRKSRC}/../holiday ; ${INSTALL_DATA} \
- holiday_australia holiday_austria holiday_bavarian holiday_belgium \
- holiday_canada holiday_combi holiday_czech holiday_denmark holiday_dutch \
- holiday_finnish holiday_french holiday_frswiss holiday_german holiday_greek \
- holiday_hungary holiday_italy holiday_japan holiday_norway holiday_portugal \
- holiday_quebec holiday_slovak holiday_spain holiday_swedish holiday_uk \
- holiday_us ${PREFIX}/share/doc/plan/examples
+ @${MKDIR} ${EXAMPLESDIR}
+
+ cd ${WRKSRC} \
+ && ${INSTALL_PROGRAM} plan pland netplan notifier ${PREFIX}/bin \
+ && ${INSTALL_SCRIPT} ../misc/Killpland ${PREFIX}/bin \
+ && ${INSTALL_MAN} ../misc/netplan.1 ../misc/plan.1 ${MAN1PREFIX}/man/man1 \
+ && ${INSTALL_MAN} ../misc/plan.4 ${MAN4PREFIX}/man/man4
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}/.. \
+ && ${INSTALL_DATA} misc/plan_cal.ps language/* misc/Mkdoc misc/Mkdoc.nawk \
+ misc/BlackWhite misc/Monochrome README \
+ ${DOCSDIR}
+.endif
+
+ cd ${WRKSRC}/../holiday \
+ && ${INSTALL_DATA} \
+ holiday_australia holiday_austria holiday_bavarian holiday_belgium \
+ holiday_canada holiday_combi holiday_czech holiday_denmark holiday_dutch \
+ holiday_finnish holiday_french holiday_frswiss holiday_german holiday_greek \
+ holiday_hungary holiday_italy holiday_japan holiday_norway holiday_portugal \
+ holiday_quebec holiday_slovak holiday_spain holiday_swedish holiday_uk \
+ holiday_us ${EXAMPLESDIR}
.if !target(post-install)
post-install:
- @${MKDIR} ${PREFIX}/share/netplan.dir
+ @${MKDIR} ${DATADIR}/netplan.dir
.endif
.include <bsd.port.mk>