aboutsummaryrefslogtreecommitdiff
path: root/deskutils/plan
diff options
context:
space:
mode:
authorDaniel Eischen <deischen@FreeBSD.org>2003-11-12 20:31:21 +0000
committerDaniel Eischen <deischen@FreeBSD.org>2003-11-12 20:31:21 +0000
commit6a2839f483b299db1b5f0bf46c8f8514ceb3595d (patch)
tree354a8001e2baf1a0e952c3eb88f2a1af8f3fbf59 /deskutils/plan
parent56ec3e8fa552d07e8be0d6dd49e2499735a04cd2 (diff)
downloadports-6a2839f483b299db1b5f0bf46c8f8514ceb3595d.tar.gz
ports-6a2839f483b299db1b5f0bf46c8f8514ceb3595d.zip
Update plan to 1.8.7. Also incorporated are some portlint fixes.
Submitted by: Sean Farley <sean-freebsd@farley.org>
Notes
Notes: svn path=/head/; revision=93840
Diffstat (limited to 'deskutils/plan')
-rw-r--r--deskutils/plan/Makefile4
-rw-r--r--deskutils/plan/distinfo2
-rw-r--r--deskutils/plan/files/patch-ab46
-rw-r--r--deskutils/plan/pkg-plist80
4 files changed, 65 insertions, 67 deletions
diff --git a/deskutils/plan/Makefile b/deskutils/plan/Makefile
index f6bddb921af9..250895ac2e1f 100644
--- a/deskutils/plan/Makefile
+++ b/deskutils/plan/Makefile
@@ -7,7 +7,7 @@
# Also update ports/japanese/plan/ (ja-plan) when this port is updated
PORTNAME= plan
-PORTVERSION= 1.8.6
+PORTVERSION= 1.8.7
CATEGORIES+= deskutils
MASTER_SITES= ${MASTER_SITE_XCONTRIB} \
ftp://plan.ftp.fu-berlin.de/
@@ -23,7 +23,7 @@ MAN1= netplan.1 plan.1
MAN4= plan.4
post-patch:
- cd ${WRKSRC} && ${MV} config.h config.h.orig && ${SED} -e 's,%%PREFIX%%,$(PREFIX),' \
+ cd ${WRKSRC} && ${MV} config.h config.h.orig && ${SED} -e 's,%%PREFIX%%,${PREFIX},' \
< config.h.orig > config.h
do-install:
@${MKDIR} ${PREFIX}/share/doc/plan/examples ;\
diff --git a/deskutils/plan/distinfo b/deskutils/plan/distinfo
index d0c4897c6246..330b5cf8ee1d 100644
--- a/deskutils/plan/distinfo
+++ b/deskutils/plan/distinfo
@@ -1 +1 @@
-MD5 (plan-1.8.6.tar.gz) = 5750547a2efea21c8d9b77ac7fe151b1
+MD5 (plan-1.8.7.tar.gz) = 76f7f522bb7e03de73d581b8b647fb3b
diff --git a/deskutils/plan/files/patch-ab b/deskutils/plan/files/patch-ab
index 64d8c1f9288a..1178a576b1e7 100644
--- a/deskutils/plan/files/patch-ab
+++ b/deskutils/plan/files/patch-ab
@@ -1,39 +1,37 @@
---- Makefile.orig Wed Mar 19 16:22:33 2003
-+++ Makefile Sun Mar 23 12:07:44 2003
-@@ -7,18 +7,26 @@
+--- Makefile.orig Tue Sep 30 13:52:26 2003
++++ Makefile Wed Nov 12 11:40:42 2003
+@@ -7,18 +7,24 @@
# path and the #, or you'll get compile errors. DO NOT put blanks before and
# after "=", this is parsed and rewritten by the configure script.
#
+DOCBASE=$(PREFIX)/share/doc/plan
+#
# # user-callable executable (plan)
--DIR=/usr/local/bin
-+DIR=$(PREFIX)/bin
+-DIR=/usr/freeware/bin
++DIR=${PREFIX}/bin
# # auxiliary programs (pland, notifier, PS)
--LIB=/usr/local/lib
-+LIB=$(PREFIX)/share
-+# # Example holiday files
+-LIB=/usr/freeware/lib
++LIB=${PREFIX}/share
++# # Example holiday files
+EXAMPLES=$(DOCBASE)/examples
-+# # doc files
++# # doc files
+DOCS=$(DOCBASE)
# # help file (plan.help)
--SBIN=/usr/local/lib
+-SBIN=/usr/freeware/bin
+HELP=$(DOCBASE)
-+#
-+SBIN=$(PREFIX)/bin
# # system programs (netplan)
--HELP=/usr/local/lib
-+HELP=$(DOCBASE)
+-HELP=/usr/freeware/lib
++SBIN=${PREFIX}/bin
# # netplan expects netplan.dir/ here
--NETPLANDIR=/usr/local/lib
+-NETPLANDIR=/usr/freeware/lib
+NETPLANDIR=$(LIB)
# # unformatted nroff manpage (plan.[14])
--MAN=/usr/local/man
+-MAN=/usr/share/man/local/man
+MAN=$(PREFIX)/man/man
# # formatted manpage (plan.[14])
- CATMAN=/usr/catman/local/cat
+ CATMAN=/usr/share/catman/local/cat
# # subdirectory in home dir, or empty
-@@ -34,9 +42,9 @@
+@@ -34,9 +40,9 @@
# # standard Unix compiler generator
YACC=yacc
# # numerical user ID of <nobody> account
@@ -45,7 +43,7 @@
# # used by plan to pre-process holiday files,
# # plan will check if this file really exists
CPP_PATH='/lib/cpp -P -I$(HELP)'
-@@ -49,12 +57,17 @@
+@@ -49,12 +55,17 @@
# # uncomment this for Japanese version of plan
# # JAPAN requires X11R5 and a Japanese env.
JAPANDEFS='-DJAPAN -DESCTOASCII=$(ESCTOJISLATIN) -DLENTOASCII=3 -DLOCALE_SJIS=ja_JP.SJIS -DLOCALE_EUC=ja_JP.EUC'
@@ -59,12 +57,12 @@
HOLIDAY=german
# # do NOT define -O2 on DEC OSF/1 machines!
# # use -O instead of -O2 on HP to avoid warning
--DEBUG=-O
+-DEBUG=-O2 -n32
+DEBUG=${CFLAGS}
# # what to do without make arguments
- DEFTARGET=help
+ DEFTARGET=sgi
#------------------------- end of configuration section ----------------------
-@@ -224,10 +237,10 @@
+@@ -218,10 +229,10 @@
BSDIG_L2= -L/usr/X11/lib -lc
NBSD_L1 = -L/usr/X11R6/lib -lXm -lXt -lX11
NBSD_L2 = -L/usr/X11R6/lib -lc
@@ -79,7 +77,7 @@
LINUX_L1= -L/usr/X11R6/lib -L/usr/lib/X11R6/lib -lSM -lXm -lXt -lX11 -lXpm -lc -lXext -lSM -lICE -lX11
LINUX_L2= -lc
SLINUX_L1= -L/usr/X11R6/lib -L/usr/lib/X11R6/lib -lSM /usr/X11R6/lib/libXm.a -lXt -lX11 /usr/X11R6/lib/libXpm.a -lc -lXext -lSM -lICE -lX11
-@@ -294,7 +307,7 @@
+@@ -286,7 +297,7 @@
@echo " make bsdi BSDI/386"
@echo " make bsdig BSDI/386 with gcc"
@echo " make netbsd NetBSD/i386 1.0A (maybe others too)"
@@ -88,7 +86,7 @@
@echo " make openbsd OpenBSD"
@echo " make svr4 SVR4 Using gcc"
@echo " make news4 Sony NEWS-OS4.x"
-@@ -538,7 +551,7 @@
+@@ -524,7 +535,7 @@
$(CCLINE) -c -DLIB=\"$(LIB)\" $<
holiday.o: holiday.c $(MAKEFILE)
diff --git a/deskutils/plan/pkg-plist b/deskutils/plan/pkg-plist
index 71092edb70a0..5b230180260b 100644
--- a/deskutils/plan/pkg-plist
+++ b/deskutils/plan/pkg-plist
@@ -3,45 +3,45 @@ bin/pland
bin/netplan
bin/notifier
bin/Killpland
-share/doc/plan/Mkdoc
-share/doc/plan/Mkdoc.nawk
-share/doc/plan/plan.help
-share/doc/plan/plan_cal.ps
-share/doc/plan/examples/holiday_australia
-share/doc/plan/examples/holiday_austria
-share/doc/plan/examples/holiday_bavarian
-share/doc/plan/examples/holiday_belgium
-share/doc/plan/examples/holiday_canada
-share/doc/plan/examples/holiday_combi
-share/doc/plan/examples/holiday_czech
-share/doc/plan/examples/holiday_denmark
-share/doc/plan/examples/holiday_dutch
-share/doc/plan/examples/holiday_finnish
-share/doc/plan/examples/holiday_french
-share/doc/plan/examples/holiday_frswiss
-share/doc/plan/examples/holiday_german
-share/doc/plan/examples/holiday_greek
-share/doc/plan/examples/holiday_hungary
-share/doc/plan/examples/holiday_italy
-share/doc/plan/examples/holiday_japan
-share/doc/plan/examples/holiday_norway
-share/doc/plan/examples/holiday_portugal
-share/doc/plan/examples/holiday_quebec
-share/doc/plan/examples/holiday_slovak
-share/doc/plan/examples/holiday_spain
-share/doc/plan/examples/holiday_swedish
-share/doc/plan/examples/holiday_uk
-share/doc/plan/examples/holiday_us
-share/doc/plan/BlackWhite
-share/doc/plan/Monochrome
-share/doc/plan/README
-share/doc/plan/plan.lang.dutch
-share/doc/plan/plan.lang.english
-share/doc/plan/plan.lang.french
-share/doc/plan/plan.lang.german
-share/doc/plan/plan.lang.italian
-share/doc/plan/plan.lang.spanish
+%%DOCSDIR%%/Mkdoc
+%%DOCSDIR%%/Mkdoc.nawk
+%%DOCSDIR%%/plan.help
+%%DOCSDIR%%/plan_cal.ps
+%%DOCSDIR%%/examples/holiday_australia
+%%DOCSDIR%%/examples/holiday_austria
+%%DOCSDIR%%/examples/holiday_bavarian
+%%DOCSDIR%%/examples/holiday_belgium
+%%DOCSDIR%%/examples/holiday_canada
+%%DOCSDIR%%/examples/holiday_combi
+%%DOCSDIR%%/examples/holiday_czech
+%%DOCSDIR%%/examples/holiday_denmark
+%%DOCSDIR%%/examples/holiday_dutch
+%%DOCSDIR%%/examples/holiday_finnish
+%%DOCSDIR%%/examples/holiday_french
+%%DOCSDIR%%/examples/holiday_frswiss
+%%DOCSDIR%%/examples/holiday_german
+%%DOCSDIR%%/examples/holiday_greek
+%%DOCSDIR%%/examples/holiday_hungary
+%%DOCSDIR%%/examples/holiday_italy
+%%DOCSDIR%%/examples/holiday_japan
+%%DOCSDIR%%/examples/holiday_norway
+%%DOCSDIR%%/examples/holiday_portugal
+%%DOCSDIR%%/examples/holiday_quebec
+%%DOCSDIR%%/examples/holiday_slovak
+%%DOCSDIR%%/examples/holiday_spain
+%%DOCSDIR%%/examples/holiday_swedish
+%%DOCSDIR%%/examples/holiday_uk
+%%DOCSDIR%%/examples/holiday_us
+%%DOCSDIR%%/BlackWhite
+%%DOCSDIR%%/Monochrome
+%%DOCSDIR%%/README
+%%DOCSDIR%%/plan.lang.dutch
+%%DOCSDIR%%/plan.lang.english
+%%DOCSDIR%%/plan.lang.french
+%%DOCSDIR%%/plan.lang.german
+%%DOCSDIR%%/plan.lang.italian
+%%DOCSDIR%%/plan.lang.spanish
@exec /bin/mkdir -p %D/share/netplan.dir
@dirrm share/netplan.dir
-@dirrm share/doc/plan/examples
-@dirrm share/doc/plan
+@dirrm %%DOCSDIR%%/examples
+@dirrm %%DOCSDIR%%