aboutsummaryrefslogtreecommitdiff
path: root/deskutils/plasma-applet-teacooker
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-02-13 12:50:49 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-02-13 12:50:49 +0000
commit147a6d6229689e3e4783e1d4184c0eac2a8b08f9 (patch)
treef8eed69d93aa3806a97c365b1a52e3e55016bc34 /deskutils/plasma-applet-teacooker
parentd5bea2df090a627f10d9acc6d3e8a380248f046c (diff)
downloadports-147a6d6229689e3e4783e1d4184c0eac2a8b08f9.tar.gz
ports-147a6d6229689e3e4783e1d4184c0eac2a8b08f9.zip
Notes
Diffstat (limited to 'deskutils/plasma-applet-teacooker')
-rw-r--r--deskutils/plasma-applet-teacooker/Makefile3
-rw-r--r--deskutils/plasma-applet-teacooker/files/patch-CMakeLists.txt10
-rw-r--r--deskutils/plasma-applet-teacooker/files/patch-plasma-teacooker.cpp10
3 files changed, 21 insertions, 2 deletions
diff --git a/deskutils/plasma-applet-teacooker/Makefile b/deskutils/plasma-applet-teacooker/Makefile
index 1312ce506abf..3e46804af915 100644
--- a/deskutils/plasma-applet-teacooker/Makefile
+++ b/deskutils/plasma-applet-teacooker/Makefile
@@ -7,6 +7,7 @@
PORTNAME= teacooker
PORTVERSION= 0.3.0
+PORTREVISION= 1
CATEGORIES= deskutils kde
MASTER_SITES= http://www.kde-apps.org/CONTENT/content-files/
PKGNAMEPREFIX= plasma-applet-
@@ -21,8 +22,6 @@ USE_QT_VER= 4
QT_COMPONENTS= gui dbus network opengl svg webkit xml \
qmake_build moc_build rcc_build uic_build
-BROKEN= Does not compile with KDE 4.2
-
WRKSRC= ${WRKDIR}/TeaCooker
.include <bsd.port.mk>
diff --git a/deskutils/plasma-applet-teacooker/files/patch-CMakeLists.txt b/deskutils/plasma-applet-teacooker/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..ba7d31ae04ea
--- /dev/null
+++ b/deskutils/plasma-applet-teacooker/files/patch-CMakeLists.txt
@@ -0,0 +1,10 @@
+--- ./CMakeLists.txt.orig 2009-02-10 02:03:48.000000000 -0500
++++ ./CMakeLists.txt 2009-02-10 02:04:02.000000000 -0500
+@@ -6,7 +6,6 @@
+ # Find the required Libaries
+ find_package(KDE4 REQUIRED)
+ include(KDE4Defaults)
+-find_package(Plasma REQUIRED)
+
+ add_definitions (${QT_DEFINITIONS} ${KDE4_DEFINITIONS})
+ include_directories(
diff --git a/deskutils/plasma-applet-teacooker/files/patch-plasma-teacooker.cpp b/deskutils/plasma-applet-teacooker/files/patch-plasma-teacooker.cpp
new file mode 100644
index 000000000000..e3e4caa69489
--- /dev/null
+++ b/deskutils/plasma-applet-teacooker/files/patch-plasma-teacooker.cpp
@@ -0,0 +1,10 @@
+--- ./plasma-teacooker.cpp.orig 2009-02-10 02:04:18.000000000 -0500
++++ ./plasma-teacooker.cpp 2009-02-10 02:04:35.000000000 -0500
+@@ -44,7 +44,6 @@
+
+ #include <plasma/svg.h>
+ #include <plasma/theme.h>
+-#include <plasma/widgets/icon.h>
+ #include <plasma/containment.h>
+ // #include <plasma/tooltipmanager.h>
+