aboutsummaryrefslogtreecommitdiff
path: root/deskutils/plasma-applet-yawp
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-03-09 22:45:57 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-03-09 22:45:57 +0000
commitd63a260f2e296e52edf9dbfb29ad56b7500b6964 (patch)
tree89cf493021a2931de46eab965571db902d8ee48e /deskutils/plasma-applet-yawp
parentef0aee74af727f162a452e960e9ad4b408f0e118 (diff)
downloadports-d63a260f2e296e52edf9dbfb29ad56b7500b6964.tar.gz
ports-d63a260f2e296e52edf9dbfb29ad56b7500b6964.zip
Notes
Diffstat (limited to 'deskutils/plasma-applet-yawp')
-rw-r--r--deskutils/plasma-applet-yawp/Makefile10
-rw-r--r--deskutils/plasma-applet-yawp/distinfo6
-rw-r--r--deskutils/plasma-applet-yawp/files/patch-applet__CMakeLists.txt26
-rw-r--r--deskutils/plasma-applet-yawp/files/patch-applet__weatherdataprocessor.cpp11
-rw-r--r--deskutils/plasma-applet-yawp/files/patch-ions__CMakeLists.txt20
-rw-r--r--deskutils/plasma-applet-yawp/files/patch-po__CMakeLists.txt15
-rw-r--r--deskutils/plasma-applet-yawp/pkg-plist7
7 files changed, 87 insertions, 8 deletions
diff --git a/deskutils/plasma-applet-yawp/Makefile b/deskutils/plasma-applet-yawp/Makefile
index 27a75b2f31a6..59327c9da933 100644
--- a/deskutils/plasma-applet-yawp/Makefile
+++ b/deskutils/plasma-applet-yawp/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= yawp
-PORTVERSION= 0.2.3
-PORTREVISION= 2
+PORTVERSION= 0.3.2
CATEGORIES= deskutils kde
MASTER_SITES= SF
PKGNAMEPREFIX= plasma-applet-
@@ -17,11 +16,14 @@ COMMENT= Weather plasma applet for KDE4
USE_BZIP2= yes
USE_CMAKE= yes
-USE_KDE4= automoc4 kdeprefix kdelibs
+USE_KDE4= automoc4 kdeprefix workspace
USE_QT_VER= 4
-QT_COMPONENTS= gui dbus network opengl svg webkit xml \
+QT_COMPONENTS= gui dbus network opengl phonon svg webkit xml xmlpatterns \
qmake_build moc_build rcc_build uic_build
USE_GETTEXT= yes
MAKE_JOBS_SAFE= yes
+post-patch:
+ ${ECHO_CMD} >> ${WRKSRC}/applet/utils.h
+
.include <bsd.port.mk>
diff --git a/deskutils/plasma-applet-yawp/distinfo b/deskutils/plasma-applet-yawp/distinfo
index 5bc58bb5f271..d862a6b5c8b9 100644
--- a/deskutils/plasma-applet-yawp/distinfo
+++ b/deskutils/plasma-applet-yawp/distinfo
@@ -1,3 +1,3 @@
-MD5 (yawp-0.2.3.tar.bz2) = 8b457269ee6bfdf300158885003cb17e
-SHA256 (yawp-0.2.3.tar.bz2) = f143cd5ec24d92e583eee9a6bc81ac224534f18c9f0cd7f7046118c9ab4fb98d
-SIZE (yawp-0.2.3.tar.bz2) = 878491
+MD5 (yawp-0.3.2.tar.bz2) = ba4941e81e61086ccec06584f7ae98dd
+SHA256 (yawp-0.3.2.tar.bz2) = d311f3871258118de7d5032de895d5e11c9d42e1f18fc256bfac1fdbbb5b8daa
+SIZE (yawp-0.3.2.tar.bz2) = 982100
diff --git a/deskutils/plasma-applet-yawp/files/patch-applet__CMakeLists.txt b/deskutils/plasma-applet-yawp/files/patch-applet__CMakeLists.txt
new file mode 100644
index 000000000000..6abb26abaf07
--- /dev/null
+++ b/deskutils/plasma-applet-yawp/files/patch-applet__CMakeLists.txt
@@ -0,0 +1,26 @@
+--- ./applet/CMakeLists.txt.orig 2009-12-06 15:08:29.000000000 -0500
++++ ./applet/CMakeLists.txt 2010-02-05 03:23:32.000000000 -0500
+@@ -54,23 +54,3 @@
+ DESTINATION ${DATA_INSTALL_DIR}/desktoptheme/default/widgets/
+ )
+
+-
+-## This is needed for the CPack package generator.
+-#
+-INSTALL(TARGETS plasma_yawp
+- LIBRARY DESTINATION "${YAWP_PACK_INSTALL_LIB_DIR}"
+- ARCHIVE DESTINATION "${YAWP_PACK_INSTALL_LIB_DIR}"
+- RUNTIME DESTINATION "${YAWP_PACK_INSTALL_LIB_DIR}"
+- COMPONENT Libraries
+- )
+-
+-INSTALL(FILES plasma_yawp.desktop
+- DESTINATION "${YAWP_PACK_SERVICES_DIR}"
+- COMPONENT ApplicationData
+- )
+-
+-STRING(REGEX REPLACE "/usr/" "" YAWP_PACK_DATA_DIR "${DATA_INSTALL_DIR}/desktoptheme/default/widgets/")
+-INSTALL(FILES yawp_theme15.svg
+- DESTINATION "${YAWP_PACK_DATA_DIR}"
+- COMPONENT ApplicationData
+- )
diff --git a/deskutils/plasma-applet-yawp/files/patch-applet__weatherdataprocessor.cpp b/deskutils/plasma-applet-yawp/files/patch-applet__weatherdataprocessor.cpp
new file mode 100644
index 000000000000..ce084e883839
--- /dev/null
+++ b/deskutils/plasma-applet-yawp/files/patch-applet__weatherdataprocessor.cpp
@@ -0,0 +1,11 @@
+--- ./applet/weatherdataprocessor.cpp.orig 2009-12-06 15:08:29.000000000 -0500
++++ ./applet/weatherdataprocessor.cpp 2010-02-05 03:23:32.000000000 -0500
+@@ -30,7 +30,7 @@
+
+ //--- KDE4 ---
+
+-#include <values.h>
++#include <float.h>
+ #if KDE_IS_VERSION(4,3,70)
+ #include <KUnitConversion/Value>
+ #endif
diff --git a/deskutils/plasma-applet-yawp/files/patch-ions__CMakeLists.txt b/deskutils/plasma-applet-yawp/files/patch-ions__CMakeLists.txt
new file mode 100644
index 000000000000..e37bbd57d16d
--- /dev/null
+++ b/deskutils/plasma-applet-yawp/files/patch-ions__CMakeLists.txt
@@ -0,0 +1,20 @@
+--- ./ions/CMakeLists.txt.orig 2010-02-05 03:23:46.000000000 -0500
++++ ./ions/CMakeLists.txt 2010-02-05 03:24:02.000000000 -0500
+@@ -38,17 +38,3 @@
+ install( TARGETS ion_google DESTINATION ${PLUGIN_INSTALL_DIR})
+ install( FILES ${GOOGLE_DESKTOP} DESTINATION ${SERVICES_INSTALL_DIR})
+
+-
+-## This is needed for the CPack package generator.
+-#
+-INSTALL(TARGETS ion_accuweather ion_google
+- LIBRARY DESTINATION "${YAWP_PACK_INSTALL_LIB_DIR}"
+- ARCHIVE DESTINATION "${YAWP_PACK_INSTALL_LIB_DIR}"
+- RUNTIME DESTINATION "${YAWP_PACK_INSTALL_LIB_DIR}"
+- COMPONENT Libraries
+- )
+-
+-INSTALL(FILES ${ACCUWEATHER_DESKTOP} ${GOOGLE_DESKTOP}
+- DESTINATION "${YAWP_PACK_SERVICES_DIR}"
+- COMPONENT ApplicationData
+- )
diff --git a/deskutils/plasma-applet-yawp/files/patch-po__CMakeLists.txt b/deskutils/plasma-applet-yawp/files/patch-po__CMakeLists.txt
new file mode 100644
index 000000000000..3d08d3c06bdc
--- /dev/null
+++ b/deskutils/plasma-applet-yawp/files/patch-po__CMakeLists.txt
@@ -0,0 +1,15 @@
+--- ./po/CMakeLists.txt.orig 2010-02-05 03:24:20.000000000 -0500
++++ ./po/CMakeLists.txt 2010-02-05 03:24:41.000000000 -0500
+@@ -27,12 +27,6 @@
+ RENAME plasma_applet_yawp.mo
+ )
+
+- INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/${_lang}.gmo
+- DESTINATION "${YAWP_PACK_LOCALE_DIR}/${_lang}/LC_MESSAGES/"
+- RENAME plasma_applet_${CMAKE_PROJECT_NAME}.mo
+- COMPONENT ApplicationData
+- )
+-
+ LIST(APPEND _gmoFiles ${_gmoFile})
+ ENDFOREACH(_current_PO_FILE)
+ ADD_CUSTOM_TARGET(pofiles ALL DEPENDS ${_gmoFiles})
diff --git a/deskutils/plasma-applet-yawp/pkg-plist b/deskutils/plasma-applet-yawp/pkg-plist
index 701d4132eea4..d48b85a8b0b1 100644
--- a/deskutils/plasma-applet-yawp/pkg-plist
+++ b/deskutils/plasma-applet-yawp/pkg-plist
@@ -1,11 +1,16 @@
+lib/kde4/ion_accuweather.so
+lib/kde4/ion_google.so
lib/kde4/plasma_yawp.so
-share/apps/desktoptheme/default/widgets/yawp_theme13.svg
+share/apps/desktoptheme/default/widgets/yawp_theme15.svg
+share/kde4/services/ion-accuweather.desktop
+share/kde4/services/ion-google.desktop
share/kde4/services/plasma_yawp.desktop
share/locale/af/LC_MESSAGES/plasma_applet_yawp.mo
share/locale/cs/LC_MESSAGES/plasma_applet_yawp.mo
share/locale/de/LC_MESSAGES/plasma_applet_yawp.mo
share/locale/es/LC_MESSAGES/plasma_applet_yawp.mo
share/locale/fr/LC_MESSAGES/plasma_applet_yawp.mo
+share/locale/he/LC_MESSAGES/plasma_applet_yawp.mo
share/locale/it/LC_MESSAGES/plasma_applet_yawp.mo
share/locale/pl/LC_MESSAGES/plasma_applet_yawp.mo
share/locale/ru/LC_MESSAGES/plasma_applet_yawp.mo