aboutsummaryrefslogtreecommitdiff
path: root/deskutils/preferences.app/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2003-02-08 07:14:44 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2003-02-08 07:14:44 +0000
commit3138a6aef745b6fbe33f4aa45803e68d80c583c1 (patch)
tree476f38e6e45f5157af8db4bc6e36d4699e95c7b8 /deskutils/preferences.app/Makefile
parent9a0799b2c45716d614ed19e6b1906943ecadd73f (diff)
downloadports-3138a6aef745b6fbe33f4aa45803e68d80c583c1.tar.gz
ports-3138a6aef745b6fbe33f4aa45803e68d80c583c1.zip
Notes
Diffstat (limited to 'deskutils/preferences.app/Makefile')
-rw-r--r--deskutils/preferences.app/Makefile58
1 files changed, 58 insertions, 0 deletions
diff --git a/deskutils/preferences.app/Makefile b/deskutils/preferences.app/Makefile
new file mode 100644
index 000000000000..707470bd4e36
--- /dev/null
+++ b/deskutils/preferences.app/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: preferences.app
+# Date created: 04 Feb 2003
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= preferences.app
+PORTVERSION= 1.2.0
+CATEGORIES= deskutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= prefsapp
+DISTNAME= Preferences-${PORTVERSION}
+
+MAINTAINER= dinoex@FreeBSD.org
+
+BUILD_DEPENDS= ${BACKBUNDLEDIR}/libgnustep-back:${PORTSDIR}/x11-toolkits/gnustep-back
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libcallback.a:${PORTSDIR}/devel/ffcall
+RUN_DEPENDS= ${BACKBUNDLEDIR}/libgnustep-back:${PORTSDIR}/x11-toolkits/gnustep-back
+
+USE_BZIP2= yes
+INSTALLS_SHLIB= yes
+PREFIX= ${LOCALBASE}/GNUstep
+USE_GMAKE= yes
+MAKEFILE= GNUmakefile
+ALL_TARGET=
+NO_MTREE= yes
+MODIFY= GNUmakefile.preamble PrefsModule/GNUmakefile.preamble \
+ Modules/Keyboard/GNUmakefile.preamble \
+ Modules/PrefsApp/GNUmakefile.preamble
+
+BACKBUNDLEDIR= ${PREFIX}/System/Library/Bundles/libgnustep-back.bundle/${GNU_ARCH}/${OPSYS:L}/gnu-gnu-gnu
+
+.include <bsd.port.pre.mk>
+
+.if ${MACHINE_ARCH} == "i386"
+GNU_ARCH= ix86
+.else
+GNU_ARCH= ${MACHINE_ARCH}
+.endif
+
+PLIST_SUB+= GNU_ARCH=${GNU_ARCH} OPSYS=${OPSYS:L}
+
+post-patch:
+.for i in ${MODIFY}
+ @${MV} ${WRKSRC}/${i} ${WRKSRC}/${i}.sed
+ ${SED} -e "s= -Werror==" ${WRKSRC}/${i}.sed > ${WRKSRC}/${i}
+.endfor
+
+do-build:
+ @(cd ${WRKSRC}; . ${PREFIX}/System/Makefiles/GNUstep.sh; \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET})
+
+do-install:
+ @(cd ${WRKSRC}; . ${PREFIX}/System/Makefiles/GNUstep.sh; \
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${INSTALL_TARGET})
+
+.include <bsd.port.post.mk>