aboutsummaryrefslogtreecommitdiff
path: root/deskutils/preferences.app/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2003-04-13 07:38:27 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2003-04-13 07:38:27 +0000
commit78917e617ab287d598a9f9bf3a6c647fef473ab8 (patch)
tree931182f68177af0f045cb24bc10655b076dc156b /deskutils/preferences.app/Makefile
parent3361106f3b5506825813eab434eceb114cbd208f (diff)
downloadports-78917e617ab287d598a9f9bf3a6c647fef473ab8.tar.gz
ports-78917e617ab287d598a9f9bf3a6c647fef473ab8.zip
Notes
Diffstat (limited to 'deskutils/preferences.app/Makefile')
-rw-r--r--deskutils/preferences.app/Makefile33
1 files changed, 8 insertions, 25 deletions
diff --git a/deskutils/preferences.app/Makefile b/deskutils/preferences.app/Makefile
index 99ae57f0bfc9..927868477f97 100644
--- a/deskutils/preferences.app/Makefile
+++ b/deskutils/preferences.app/Makefile
@@ -16,46 +16,29 @@ DISTNAME= Preferences-${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= GNUstep workspace manager
-BUILD_DEPENDS= ${BACKBUNDLEDIR}/libgnustep-back:${PORTSDIR}/x11-toolkits/gnustep-back
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libcallback.a:${PORTSDIR}/devel/ffcall
-RUN_DEPENDS= ${BACKBUNDLEDIR}/libgnustep-back:${PORTSDIR}/x11-toolkits/gnustep-back
-
USE_BZIP2= yes
-INSTALLS_SHLIB= yes
PREFIX= ${LOCALBASE}/GNUstep
+NO_MTREE= yes
USE_GMAKE= yes
MAKEFILE= GNUmakefile
ALL_TARGET=
-NO_MTREE= yes
-USE_GCC= 3.2
+INSTALLS_SHLIB= yes
+
MODIFY= GNUmakefile.preamble PrefsModule/GNUmakefile.preamble \
Modules/Keyboard/GNUmakefile.preamble \
Modules/PrefsApp/GNUmakefile.preamble
-BACKBUNDLEDIR= ${PREFIX}/System/Library/Bundles/libgnustep-back.bundle/${GNU_ARCH}/${OPSYS:L}/gnu-gnu-gnu
-
-.include <bsd.port.pre.mk>
-
-.if ${MACHINE_ARCH} == "i386"
-GNU_ARCH= ix86
-.else
-GNU_ARCH= ${MACHINE_ARCH}
-.endif
-
-PLIST_SUB+= GNU_ARCH=${GNU_ARCH} OPSYS=${OPSYS:L}
-
post-patch:
.for i in ${MODIFY}
@${MV} ${WRKSRC}/${i} ${WRKSRC}/${i}.sed
${SED} -e "s= -Werror==" ${WRKSRC}/${i}.sed > ${WRKSRC}/${i}
.endfor
-do-build:
- @(cd ${WRKSRC}; . ${PREFIX}/System/Makefiles/GNUstep.sh; \
- ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET})
+.include <bsd.port.pre.mk>
-do-install:
- @(cd ${WRKSRC}; . ${PREFIX}/System/Makefiles/GNUstep.sh; \
- ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${INSTALL_TARGET})
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+.include "${PORTSDIR}/devel/gnustep/bsd.gnustep.mk"
.include <bsd.port.post.mk>