aboutsummaryrefslogtreecommitdiff
path: root/deskutils/preferences
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-08-07 19:32:11 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-08-07 19:32:11 +0000
commit63e641c82513af0fd4db9e61ab243033e4c4c3c2 (patch)
tree65d7ee545ab32818c25d7e05ce36431d19557f46 /deskutils/preferences
parent9dbe2a10e8e49e68704a8b1efcc38f1de9632a9c (diff)
downloadports-63e641c82513af0fd4db9e61ab243033e4c4c3c2.tar.gz
ports-63e641c82513af0fd4db9e61ab243033e4c4c3c2.zip
Notes
Diffstat (limited to 'deskutils/preferences')
-rw-r--r--deskutils/preferences/Makefile40
-rw-r--r--deskutils/preferences/distinfo2
-rw-r--r--deskutils/preferences/files/patch-Keyboard.m10
-rw-r--r--deskutils/preferences/pkg-descr13
-rw-r--r--deskutils/preferences/pkg-plist56
5 files changed, 121 insertions, 0 deletions
diff --git a/deskutils/preferences/Makefile b/deskutils/preferences/Makefile
new file mode 100644
index 000000000000..b25a18179a14
--- /dev/null
+++ b/deskutils/preferences/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: preferences
+# Date created: 04 Feb 2003
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= preferences
+PORTVERSION= 1.2.0
+PORTREVISION= 4
+CATEGORIES= deskutils gnustep
+MASTER_SITES= SF/prefsapp/prefsapp/${PORTVERSION}
+DISTNAME= Preferences-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= GNUstep workspace manager
+
+LICENSE_COMB= multi
+LICENSE= GPLv2 LGPL21
+
+USE_BZIP2= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+USE_GNUSTEP_LDCONFIG= ${GNUSTEP_SYSTEM_LIBRARIES}
+
+DEAFULT_LIBVERSION= 1.1.1
+MAKE_ENV+= GNUSTEP_INSTALLATION_DOMAIN=SYSTEM
+MODIFY= GNUmakefile.preamble PrefsModule/GNUmakefile.preamble \
+ Modules/Keyboard/GNUmakefile.preamble \
+ Modules/PrefsApp/GNUmakefile.preamble
+
+post-patch:
+.for i in ${MODIFY}
+ @${MV} ${WRKSRC}/${i} ${WRKSRC}/${i}.sed
+ ${SED} -e "s= -Werror==" ${WRKSRC}/${i}.sed > ${WRKSRC}/${i}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/deskutils/preferences/distinfo b/deskutils/preferences/distinfo
new file mode 100644
index 000000000000..fbd4e79bf6e5
--- /dev/null
+++ b/deskutils/preferences/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Preferences-1.2.0.tar.bz2) = f12a93b285e030fc7569d8ea62600d36e9bad69e63c49cc9897e3956590f3914
+SIZE (Preferences-1.2.0.tar.bz2) = 52293
diff --git a/deskutils/preferences/files/patch-Keyboard.m b/deskutils/preferences/files/patch-Keyboard.m
new file mode 100644
index 000000000000..bdf962baf8c3
--- /dev/null
+++ b/deskutils/preferences/files/patch-Keyboard.m
@@ -0,0 +1,10 @@
+--- Modules/Keyboard/Keyboard.m.orig 2002-06-08 10:29:36.000000000 +0200
++++ Modules/Keyboard/Keyboard.m 2010-05-22 11:24:43.000000000 +0200
+@@ -37,6 +37,7 @@
+ #import <AppKit/NSButton.h>
+ #import <AppKit/NSNibLoading.h>
+ #import <AppKit/NSOpenPanel.h>
++#import <Foundation/NSUserDefaults.h>
+
+ #import "Keyboard.h"
+ #import "KeyboardView.h"
diff --git a/deskutils/preferences/pkg-descr b/deskutils/preferences/pkg-descr
new file mode 100644
index 000000000000..902ca42ea64a
--- /dev/null
+++ b/deskutils/preferences/pkg-descr
@@ -0,0 +1,13 @@
+Preferences.app is, functionally, a clone of NeXTstep/OPENSTEP tool of
+the same name. Just like the original program, it's a simple application
+for setting preferences for the GNUstep system, with a friendly interface.
+The program is simple, but powerful -- people can create new modules,
+called "bundles", that add new things to the program that its original
+developers did not think of or even intend -- that don't require
+recompiling the main program. For more information on what bundles can do,
+see StepWise. They are a very powerful tool.
+
+LICENSE: LGPL2 or later (framework)
+LICENSE: GPL2 or later (application)
+
+WWW: http://www.nongnu.org/backbone/
diff --git a/deskutils/preferences/pkg-plist b/deskutils/preferences/pkg-plist
new file mode 100644
index 000000000000..3c0821ac3e21
--- /dev/null
+++ b/deskutils/preferences/pkg-plist
@@ -0,0 +1,56 @@
+GNUstep/System/Applications/Preferences.app/Preferences
+GNUstep/System/Applications/Preferences.app/Resources/English.lproj/Localizable.strings
+GNUstep/System/Applications/Preferences.app/Resources/English.lproj/Preferences.gorm
+GNUstep/System/Applications/Preferences.app/Resources/Info-gnustep.plist
+GNUstep/System/Applications/Preferences.app/Resources/Preferences.desktop
+GNUstep/System/Applications/Preferences.app/Resources/Preferences.tiff
+GNUstep/System/Applications/Preferences.app/Resources/PreferencesInfo.plist
+GNUstep/System/Applications/Preferences.app/Resources/PrefsApp.prefs/PrefsApp
+GNUstep/System/Applications/Preferences.app/Resources/PrefsApp.prefs/Resources/Info-gnustep.plist
+GNUstep/System/Applications/Preferences.app/Resources/PrefsApp.prefs/Resources/PrefsApp.gorm
+GNUstep/System/Applications/Preferences.app/Resources/PrefsApp.prefs/stamp.make
+GNUstep/System/Applications/Preferences.app/Resources/PrefsIcon_Appearances.tiff
+GNUstep/System/Applications/Preferences.app/Resources/PrefsIcon_Keyboard.tiff
+GNUstep/System/Applications/Preferences.app/Resources/PrefsIcon_Localisation.tiff
+GNUstep/System/Applications/Preferences.app/Resources/PrefsIcon_Login.tiff
+GNUstep/System/Applications/Preferences.app/Resources/PrefsIcon_Mouse.tiff
+GNUstep/System/Applications/Preferences.app/Resources/PrefsIcon_Screen.tiff
+GNUstep/System/Applications/Preferences.app/Resources/PrefsIcon_SelectSpooler.tiff
+GNUstep/System/Applications/Preferences.app/Resources/PrefsModule.tiff
+GNUstep/System/Applications/Preferences.app/stamp.make
+GNUstep/System/Library/Frameworks/PrefsModule.framework/Headers
+GNUstep/System/Library/Frameworks/PrefsModule.framework/PrefsModule
+GNUstep/System/Library/Frameworks/PrefsModule.framework/Resources
+GNUstep/System/Library/Frameworks/PrefsModule.framework/Versions/%%MAJORLIBVERSION%%/Headers/PrefsModule.h
+GNUstep/System/Library/Frameworks/PrefsModule.framework/Versions/%%MAJORLIBVERSION%%/PrefsModule
+GNUstep/System/Library/Frameworks/PrefsModule.framework/Versions/%%MAJORLIBVERSION%%/Resources/Info-gnustep.plist
+GNUstep/System/Library/Frameworks/PrefsModule.framework/Versions/%%MAJORLIBVERSION%%/libPrefsModule.so
+GNUstep/System/Library/Frameworks/PrefsModule.framework/Versions/%%MAJORLIBVERSION%%/libPrefsModule.so.%%MAJORLIBVERSION%%
+GNUstep/System/Library/Frameworks/PrefsModule.framework/Versions/%%MAJORLIBVERSION%%/libPrefsModule.so.%%LIBVERSION%%
+GNUstep/System/Library/Frameworks/PrefsModule.framework/Versions/Current
+GNUstep/System/Library/Frameworks/PrefsModule.framework/libPrefsModule.so
+GNUstep/System/Library/Headers/PrefsModule
+GNUstep/System/Library/Libraries/libPrefsModule.so
+GNUstep/System/Library/Libraries/libPrefsModule.so.%%MAJORLIBVERSION%%
+GNUstep/System/Library/Libraries/libPrefsModule.so.%%LIBVERSION%%
+GNUstep/System/Library/Preferences/Keyboard.prefs/Keyboard
+GNUstep/System/Library/Preferences/Keyboard.prefs/Resources/Info-gnustep.plist
+GNUstep/System/Library/Preferences/Keyboard.prefs/Resources/Keyboard.gorm
+GNUstep/System/Library/Preferences/Keyboard.prefs/stamp.make
+GNUstep/System/Tools/Preferences
+@dirrm GNUstep/System/Library/Preferences/Keyboard.prefs/Resources
+@dirrm GNUstep/System/Library/Preferences/Keyboard.prefs
+@dirrm GNUstep/System/Library/Preferences
+@dirrm GNUstep/System/Library/Frameworks/PrefsModule.framework/Versions/%%MAJORLIBVERSION%%/Resources
+@dirrm GNUstep/System/Library/Frameworks/PrefsModule.framework/Versions/%%MAJORLIBVERSION%%/Headers
+@dirrm GNUstep/System/Library/Frameworks/PrefsModule.framework/Versions/%%MAJORLIBVERSION%%
+@dirrm GNUstep/System/Library/Frameworks/PrefsModule.framework/Versions
+@dirrm GNUstep/System/Library/Frameworks/PrefsModule.framework
+@dirrm GNUstep/System/Applications/Preferences.app/Resources/PrefsApp.prefs/Resources
+@dirrm GNUstep/System/Applications/Preferences.app/Resources/PrefsApp.prefs
+@dirrm GNUstep/System/Applications/Preferences.app/Resources/English.lproj
+@dirrm GNUstep/System/Applications/Preferences.app/Resources
+@dirrm GNUstep/System/Applications/Preferences.app
+@dirrmtry Network/Library/Preferences
+@dirrmtry Network/Library
+@dirrmtry Network