aboutsummaryrefslogtreecommitdiff
path: root/deskutils/preferences
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-06-18 19:49:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-06-18 19:49:39 +0000
commit334259184a75bbd6826a0ccd6d4471e886bdb856 (patch)
tree696b131d9fba119380f7eb823e3eb4690ce2da5b /deskutils/preferences
parent962f5bdfaca8d3f66ff3f2492d59846ca2e36dd5 (diff)
downloadports-334259184a75bbd6826a0ccd6d4471e886bdb856.tar.gz
ports-334259184a75bbd6826a0ccd6d4471e886bdb856.zip
- Strip binaries
Notes
Notes: svn path=/head/; revision=390055
Diffstat (limited to 'deskutils/preferences')
-rw-r--r--deskutils/preferences/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/deskutils/preferences/Makefile b/deskutils/preferences/Makefile
index 3577fc894f02..be2142b4145b 100644
--- a/deskutils/preferences/Makefile
+++ b/deskutils/preferences/Makefile
@@ -2,7 +2,7 @@
PORTNAME= preferences
PORTVERSION= 1.2.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= deskutils gnustep
MASTER_SITES= SF/prefsapp/prefsapp/${PORTVERSION}
DISTNAME= Preferences-${PORTVERSION}
@@ -28,4 +28,10 @@ post-patch:
${REINPLACE_CMD} -e 's|^GNUSTEP_INSTALLATION_DIR|#GNUSTEP_INSTALLATION_DIR|' \
${WRKSRC}/GNUmakefile.preamble
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/System/Applications/Preferences.app/Preferences
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/System/Applications/Preferences.app/Resources/PrefsApp.prefs/PrefsApp
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/System/Library/Frameworks/PrefsModule.framework/Versions/0/libPrefsModule.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/GNUstep/System/Library/Preferences/Keyboard.prefs/Keyboard
+
.include <bsd.port.mk>