aboutsummaryrefslogtreecommitdiff
path: root/deskutils/pypanel
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2020-01-27 15:34:18 +0000
committerRene Ladan <rene@FreeBSD.org>2020-01-27 15:34:18 +0000
commitaa2769119334a5045d38419995aca597ea24b1f1 (patch)
tree46f389d2a7bc016aa58737ba87b33fe1dfdfd3fe /deskutils/pypanel
parentad735287aef46d649c1c08ea3d049288113148cb (diff)
downloadports-aa2769119334a5045d38419995aca597ea24b1f1.tar.gz
ports-aa2769119334a5045d38419995aca597ea24b1f1.zip
Notes
Diffstat (limited to 'deskutils/pypanel')
-rw-r--r--deskutils/pypanel/Makefile56
-rw-r--r--deskutils/pypanel/distinfo2
-rw-r--r--deskutils/pypanel/files/patch-pypanel31
-rw-r--r--deskutils/pypanel/files/patch-pypanelrc15
-rw-r--r--deskutils/pypanel/pkg-descr17
5 files changed, 0 insertions, 121 deletions
diff --git a/deskutils/pypanel/Makefile b/deskutils/pypanel/Makefile
deleted file mode 100644
index 514da40ed684..000000000000
--- a/deskutils/pypanel/Makefile
+++ /dev/null
@@ -1,56 +0,0 @@
-# Created by: Florian Unglaub <flo@btw23.de>
-# $FreeBSD$
-
-PORTNAME= pypanel
-PORTVERSION= 2.4
-PORTREVISION= 12
-CATEGORIES= deskutils
-MASTER_SITES= SF
-DISTNAME= PyPanel-${PORTVERSION}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Desktop panel written in Python
-
-DEPRECATED= Unmaintained, uses EOLed python27
-EXPIRATION_DATE= 2020-01-27
-
-LICENSE= GPLv2+
-LICENSE_FILE= ${WRKSRC}/COPYING
-
-LIB_DEPENDS= libfreetype.so:print/freetype2 \
- libImlib2.so:graphics/imlib2
-BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/Xlib/X.py:x11-toolkits/py-xlib@${PY_FLAVOR}
-RUN_DEPENDS:= ${BUILD_DEPENDS}
-
-USES= python:2.7 xorg
-USE_PYTHON= autoplist distutils
-USE_XORG= xft
-
-PORTDOCS= *
-
-OPTIONS_DEFINE= DOCS
-
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|/usr/bin/freetype-config|${LOCALBASE}/bin/freetype-config|; \
- s|/usr/bin/imlib2-config|${LOCALBASE}/bin/imlib2-config|; \
- s|/usr/X11R6/include|${LOCALBASE}/include|; \
- s|"COPYING", "README", ||' ${WRKSRC}/setup.py
- @${REINPLACE_CMD} -e \
- 's|sysconfig\.get_python_lib()|"${PREFIX}/share"|' \
- ${WRKSRC}/setup.py ${WRKSRC}/pypanel
- @${REINPLACE_CMD} -e \
- 's|/usr/lib/libImlib2.so.1|${LOCALBASE}/lib/libImlib2.so|' \
- ${WRKSRC}/setup.py ${WRKSRC}/ppmodule.c
- @${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|' ${WRKSRC}/pypanel
- @${REINPLACE_CMD} -e 's|/usr/share/imlib2|${LOCALBASE}/share/imlib2|' \
- ${WRKSRC}/pypanelrc
-
-post-install:
- @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/ppmodule.so
-
-post-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
-
-.include <bsd.port.mk>
diff --git a/deskutils/pypanel/distinfo b/deskutils/pypanel/distinfo
deleted file mode 100644
index 7d309c38923d..000000000000
--- a/deskutils/pypanel/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (PyPanel-2.4.tar.gz) = 4e612b43c61b3a8af7d57a0364f6cd89df481dc41e20728afa643e9e3546e911
-SIZE (PyPanel-2.4.tar.gz) = 29857
diff --git a/deskutils/pypanel/files/patch-pypanel b/deskutils/pypanel/files/patch-pypanel
deleted file mode 100644
index 15b5229fe1b6..000000000000
--- a/deskutils/pypanel/files/patch-pypanel
+++ /dev/null
@@ -1,31 +0,0 @@
---- pypanel.orig 2005-06-26 23:24:43 UTC
-+++ pypanel
-@@ -95,6 +95,7 @@ class PyPanel(object):
- self.root.change_attributes(event_mask=(X.PropertyChangeMask))
- self.window.map()
- self.display.flush()
-+ self.updatePanel(self.root, self.window, self.panel)
- self.loop(self.display, self.root, self.window, self.panel)
-
- #------------------------------------
-@@ -944,6 +945,9 @@ if __name__ == "__main__":
- main = 2.4
- config = globals().get("VERSION", None)
-
-+ # Get the startup delay
-+ delay = globals().get("STARTUP_DELAY", None)
-+
- # Set locale to user's default
- locale.setlocale(locale.LC_ALL, "")
-
-@@ -953,5 +957,9 @@ if __name__ == "__main__":
- sys.stderr.write("\nA current pypanelrc example can be found here -\n")
- sys.stderr.write("%s/pypanel/pypanelrc\n\n" % sysconfig.get_python_lib())
- del main, config
--
-+
-+ # If delay is set, pause, and let windowmanager load
-+ if delay:
-+ time.sleep(delay)
-+
- PyPanel(display.Display())
diff --git a/deskutils/pypanel/files/patch-pypanelrc b/deskutils/pypanel/files/patch-pypanelrc
deleted file mode 100644
index 71d9500ea267..000000000000
--- a/deskutils/pypanel/files/patch-pypanelrc
+++ /dev/null
@@ -1,15 +0,0 @@
---- pypanelrc.orig 2005-06-26 23:27:37 UTC
-+++ pypanelrc
-@@ -9,6 +9,12 @@
- VERSION = 2.4 # Config file version
-
- #------------------------------------------------------------------------------
-+# Startup delay: The time to wait before painting the pypanel window. This lets
-+# the background load up so that pypanel will be displayed correctly.
-+#------------------------------------------------------------------------------
-+STARTUP_DELAY = 2
-+
-+#------------------------------------------------------------------------------
- # Colors: Format is hex triplet - 0xrrggbb
- #------------------------------------------------------------------------------
- BG_COLOR = "0xd6d6d6" # Panel background and tinting color
diff --git a/deskutils/pypanel/pkg-descr b/deskutils/pypanel/pkg-descr
deleted file mode 100644
index f7d782b5897a..000000000000
--- a/deskutils/pypanel/pkg-descr
+++ /dev/null
@@ -1,17 +0,0 @@
-PyPanel is a lightweight panel/taskbar written in Python and C for X11 window
-managers. It can be easily customized to match any desktop theme or taste.
-PyPanel works with EWMH compliant WMs (Openbox, PekWM, FVWM, and many others).
-
-Some of the customizable features include:
-
- - Transparency with shading/tinting
- - Panel dimensions, location, and layout
- - Font type and colors with Xft and shadow support
- - Button events/actions
- - Clock and workspace name display
- - System tray (notification area)
- - Autohiding
- - Application launcher
- - Custom application icons
-
-WWW: http://pypanel.sourceforge.net/