aboutsummaryrefslogtreecommitdiff
path: root/deskutils/recoll
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:00:51 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-04-01 14:00:51 +0000
commit4e1b79a0a61f4973df8b4b0864d22086c769e219 (patch)
tree78ceaf1b099c56a40c240ab46278cdf4ae9e7c01 /deskutils/recoll
parent7f4572eae4327c4403d9ef714cb6de917650662a (diff)
downloadports-4e1b79a0a61f4973df8b4b0864d22086c769e219.tar.gz
ports-4e1b79a0a61f4973df8b4b0864d22086c769e219.zip
Notes
Diffstat (limited to 'deskutils/recoll')
-rw-r--r--deskutils/recoll/Makefile30
1 files changed, 15 insertions, 15 deletions
diff --git a/deskutils/recoll/Makefile b/deskutils/recoll/Makefile
index fe51c50c2b4b..1fe2d71b5ffb 100644
--- a/deskutils/recoll/Makefile
+++ b/deskutils/recoll/Makefile
@@ -12,12 +12,12 @@ COMMENT= Personal full text search package, based on Xapian
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libxapian.so:${PORTSDIR}/databases/xapian-core
-RUN_DEPENDS= unrar:${PORTSDIR}/archivers/unrar \
- antiword:${PORTSDIR}/textproc/antiword \
- catdoc:${PORTSDIR}/textproc/catdoc \
- wpd2html:${PORTSDIR}/textproc/libwpd010 \
- unrtf:${PORTSDIR}/textproc/unrtf
+LIB_DEPENDS= libxapian.so:databases/xapian-core
+RUN_DEPENDS= unrar:archivers/unrar \
+ antiword:textproc/antiword \
+ catdoc:textproc/catdoc \
+ wpd2html:textproc/libwpd010 \
+ unrtf:textproc/unrtf
USES= bison gmake iconv shebangfix
SHEBANG_FILES= filters/rclimg filters/rclpdf desktop/hotrecoll.py
@@ -35,18 +35,18 @@ OPTIONS_DEFINE= ASPELL CHM DJVU KONQUEROR LATEX IMAGE PDF PS PYTHON \
OPTIONS_DEFAULT= ASPELL IMAGE PDF PS PYTHON SOUND QT4 X11MON
OPTIONS_SUB= yes
-ASPELL_LIB_DEPENDS= libaspell.so:${PORTSDIR}/textproc/aspell
+ASPELL_LIB_DEPENDS= libaspell.so:textproc/aspell
ASPELL_CONFIGURE_WITH= aspell
CHM_DESC= CHM via CHMLIB
-CHM_RUN_DEPENDS= pychm>0:${PORTSDIR}/textproc/pychm
-DJVU_RUN_DEPENDS= djvutxt:${PORTSDIR}/graphics/djvulibre
+CHM_RUN_DEPENDS= pychm>0:textproc/pychm
+DJVU_RUN_DEPENDS= djvutxt:graphics/djvulibre
IMAGE_DESC= Store personal tags or textual descriptions in images
-IMAGE_RUN_DEPENDS= exiftool:${PORTSDIR}/graphics/p5-Image-ExifTool
+IMAGE_RUN_DEPENDS= exiftool:graphics/p5-Image-ExifTool
KONQUEROR_DESC= Konqueror webarchive format with Python
-KONQUEROR_RUN_DEPENDS= kwebkitpart>0:${PORTSDIR}/www/kwebkitpart
+KONQUEROR_RUN_DEPENDS= kwebkitpart>0:www/kwebkitpart
LATEX_USE= tex=dvipsk:run,latex:run
-PDF_RUN_DEPENDS= xpdf:${PORTSDIR}/graphics/xpdf
-PS_RUN_DEPENDS= pstotext:${PORTSDIR}/print/pstotext
+PDF_RUN_DEPENDS= xpdf:graphics/xpdf
+PS_RUN_DEPENDS= pstotext:print/pstotext
PYTHON_USES= python
PYTHON_CONFIGURE_ENABLE= python-module
PYTHON_PLIST_SUB= PYDISTUTILS_EGGINFO="${PYDISTUTILS_EGGINFO}"
@@ -59,8 +59,8 @@ QT4_CONFIGURE_ENABLE= qtgui
QT4_CONFIGURE_ENV= QMAKE="${QMAKE}" QMAKESPEC="${QMAKESPEC}" \
QTDIR="${QT_PREFIX}"
QT4_VARS= QT_NONSTANDARD=yes
-SOUND_RUN_DEPENDS= mutagen-pony:${PORTSDIR}/audio/py-mutagen \
- pykaraoke:${PORTSDIR}/audio/py-karaoke
+SOUND_RUN_DEPENDS= mutagen-pony:audio/py-mutagen \
+ pykaraoke:audio/py-karaoke
X11MON_DESC= X11 session monitoring support
X11MON_USES= fam
X11MON_USE= xorg=ice,sm,x11