aboutsummaryrefslogtreecommitdiff
path: root/deskutils/rubrica/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-03-01 07:07:58 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-03-01 07:07:58 +0000
commite81140b2bf8c25ce9ca636fcce69037a4901b68f (patch)
treef3a41288ecdf19c0c1c648db4fdf32a1dffce881 /deskutils/rubrica/Makefile
parent50aaba18339d6b13b5c115e6ae652f3939078c34 (diff)
downloadports-e81140b2bf8c25ce9ca636fcce69037a4901b68f.tar.gz
ports-e81140b2bf8c25ce9ca636fcce69037a4901b68f.zip
Notes
Diffstat (limited to 'deskutils/rubrica/Makefile')
-rw-r--r--deskutils/rubrica/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/deskutils/rubrica/Makefile b/deskutils/rubrica/Makefile
new file mode 100644
index 000000000000..6916d1158c60
--- /dev/null
+++ b/deskutils/rubrica/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: rubrica
+# Date created: 27 February 2003
+# Whom: Martin Klaffenboeck <martin.klaffenboeck@gmx.at>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rubrica
+PORTVERSION= 1.0.0.c1
+CATEGORIES= deskutils gnome
+MASTER_SITES= http://digilander.libero.it/nfragale/download/rubrica/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.c1$/cr1/}
+
+MAINTAINER= martin.klaffenboeck@gmx.at
+COMMENT= An addressbook for the gnome2 desktop
+
+LIB_DEPENDS= gnomeui-2.200:${PORTSDIR}/x11-toolkits/libgnomeui
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.c1$/cr1/}
+USE_BZIP2= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehack gnomeprefix
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+
+DOC_FILES= AUTHORS COPYING CREDITS ChangeLog INSTALL NEWS README TODO
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+ @${INSTALL_DATA} ${WRKSRC}/doc/examples.rub ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>