aboutsummaryrefslogtreecommitdiff
path: root/deskutils/semantik
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2012-08-28 16:07:29 +0000
committerAlberto Villa <avilla@FreeBSD.org>2012-08-28 16:07:29 +0000
commita69a7aeec8b881d517dad01e1c4e97845e992bdf (patch)
treeebf5fb80bfddc8c0b613e2bf8f64e0e768eefb57 /deskutils/semantik
parent103b49c10b8eb471f2523e68e7e9b6d0a0152db4 (diff)
downloadports-a69a7aeec8b881d517dad01e1c4e97845e992bdf.tar.gz
ports-a69a7aeec8b881d517dad01e1c4e97845e992bdf.zip
Notes
Diffstat (limited to 'deskutils/semantik')
-rw-r--r--deskutils/semantik/Makefile32
-rw-r--r--deskutils/semantik/distinfo4
-rw-r--r--deskutils/semantik/pkg-descr9
-rw-r--r--deskutils/semantik/pkg-plist12
4 files changed, 35 insertions, 22 deletions
diff --git a/deskutils/semantik/Makefile b/deskutils/semantik/Makefile
index 0013aaf07ef5..4035ee731873 100644
--- a/deskutils/semantik/Makefile
+++ b/deskutils/semantik/Makefile
@@ -6,37 +6,46 @@
#
PORTNAME= semantik
-PORTVERSION= 0.7.3
-PORTREVISION= 2
+PORTVERSION= 0.8.0
CATEGORIES= deskutils kde
MASTER_SITES= http://${PORTNAME}.googlecode.com/files/ \
http://freehackers.org/~tnagy/
MAINTAINER= avilla@FreeBSD.org
-COMMENT= KDE mindmapping tool
+COMMENT= KDE mind mapping tool
LICENSE= GPLv3
-USE_BZIP2= yes
-USE_GETTEXT= yes
USE_KDE4= kdehier kdelibs kdeprefix
USE_OCAML= yes
NO_OCAML_RUNDEPENDS= yes
-USE_PYTHON_BUILD= 2.5+
+USE_PYTHON= 2.5+
USE_QT4= corelib gui linguist svg webkit xml \
moc_build qmake_build uic_build
-MAKE_JOBS_SAFE= yes
+USE_BZIP2= yes
CONFIGURE_ENV= PATH="${KDE4_PREFIX}/bin:$$PATH" WAF_HOME="${WRKSRC}"
CPPFLAGS+= -I${LOCALBASE}/include
CFLAGS+= -I${LOCALBASE}/include
+MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+PLIST_SUB+= NLS="@comment "
+.endif
+
pre-configure:
${REINPLACE_CMD} -e 's/kde-config/kde4-config/g' \
-e '/conf.env.CXXFLAGS =/ s|= '"'"'[^'"'"']*|= '"'"'${CXXFLAGS}|' \
- -e 's/-lstr/-lcamlstr/g' \
- -e '/obj.langs/ d' \
${WRKSRC}/wscript
+.if empty(PORT_OPTIONS:MNLS)
+ ${REINPLACE_CMD} -e '/langs/ d' \
+ ${WRKSRC}/wscript
+.endif
do-configure:
@cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./waf configure --prefix=${PREFIX}
@@ -47,10 +56,5 @@ do-build:
do-install:
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./waf install
@${STRIP_CMD} ${PREFIX}/bin/${PORTNAME}
-.for lang in es fr
- @${LOCALBASE}/bin/msgfmt \
- -o ${KDE4_PREFIX}/share/locale/${lang}/LC_MESSAGES/${PORTNAME}.mo \
- ${WRKSRC}/src/po/${lang}.po
-.endfor
.include <bsd.port.mk>
diff --git a/deskutils/semantik/distinfo b/deskutils/semantik/distinfo
index 950eff56ff79..5c1aa2a45548 100644
--- a/deskutils/semantik/distinfo
+++ b/deskutils/semantik/distinfo
@@ -1,2 +1,2 @@
-SHA256 (semantik-0.7.3.tar.bz2) = fb9be0f7b27772ec1debd95ca7b85d9ac68f8242ca097791b7a03317de10e899
-SIZE (semantik-0.7.3.tar.bz2) = 378795
+SHA256 (semantik-0.8.0.tar.bz2) = 0755ed0ef4c2461c97a1591ed5e62a4154e1f10080db0729af5b092a626a144a
+SIZE (semantik-0.8.0.tar.bz2) = 385223
diff --git a/deskutils/semantik/pkg-descr b/deskutils/semantik/pkg-descr
index 5585e1c43c55..fa96200bb683 100644
--- a/deskutils/semantik/pkg-descr
+++ b/deskutils/semantik/pkg-descr
@@ -1,4 +1,4 @@
-The goal of semantik is to help to structure ideas and concepts by
+The goal of Semantik is to help to structure ideas and concepts by
associating them into a tree. The tree is there to help to see how the
ideas interact, and then to develop them further (add ramifications).
@@ -6,10 +6,11 @@ An idea is represented by a shape which can be a text or a picture.
The ideas can be connected, but there is a constraint: an idea cannot
have more than one parent.
-A semantik mind-map can be exported as a picture, or used to generate
-documents. Templates include pdflatex (article, book) and html file
+A Semantik mind map can be exported as a picture, or used to generate
+documents. Templates include pdflatex (article, book) and HTML file
formats.
-Semantik is the replacement for kdissert and requires KDE 4.
+Semantik is the replacement for Kdissert and requires KDE Development
+Platform 4.
WWW: http://freehackers.org/~tnagy/semantik.html
diff --git a/deskutils/semantik/pkg-plist b/deskutils/semantik/pkg-plist
index e4dfce97de82..c2fed539b11a 100644
--- a/deskutils/semantik/pkg-plist
+++ b/deskutils/semantik/pkg-plist
@@ -133,6 +133,7 @@ share/apps/semantik/templates/html/def.css
share/apps/semantik/templates/html/index.html
share/apps/semantik/templates/java.sem.py
share/apps/semantik/templates/java/Kadapplet.java
+share/apps/semantik/templates/java/Makefile
share/apps/semantik/templates/java/Mapview.java
share/apps/semantik/templates/java/main.html
share/apps/semantik/templates/odp.sem.py
@@ -167,6 +168,7 @@ share/apps/semantik/templates/waf
share/apps/semantik/tips
share/icons/hicolor/128x128/apps/semantik.png
share/icons/hicolor/22x22/apps/semantik.png
+share/icons/hicolor/32x32/apps/semantik.png
share/icons/hicolor/48x48/apps/semantik.png
share/icons/hicolor/64x64/apps/semantik.png
share/icons/oxygen/128x128/actions/semantik_sort.png
@@ -184,8 +186,14 @@ share/icons/oxygen/32x32/actions/semantik_point.png
share/icons/oxygen/32x32/actions/semantik_sort.png
share/icons/oxygen/48x48/actions/semantik_move.png
share/icons/oxygen/64x64/actions/semantik_sort.png
-share/locale/es/LC_MESSAGES/semantik.mo
-share/locale/fr/LC_MESSAGES/semantik.mo
+%%NLS%%share/locale/cz/LC_MESSAGES/semantik.mo
+%%NLS%%share/locale/el/LC_MESSAGES/semantik.mo
+%%NLS%%share/locale/es/LC_MESSAGES/semantik.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/semantik.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/semantik.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/semantik.mo
+%%NLS%%@dirrmtry share/locale/cz/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/cz
@dirrm share/apps/semantik/templates/s5/ui/default
@dirrm share/apps/semantik/templates/s5/ui
@dirrm share/apps/semantik/templates/s5