aboutsummaryrefslogtreecommitdiff
path: root/deskutils/showdown
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-06-22 18:46:02 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-06-22 18:46:02 +0000
commit3c814f2bccfd8fc3aaf539f76e178c5a25d0dfc1 (patch)
treeef2e5447cc2693d95c8b6ad72393c71fe8e99b4d /deskutils/showdown
parent1ca2ea6ab8490f4674c31df509360d72d8e4b9d3 (diff)
downloadports-3c814f2bccfd8fc3aaf539f76e178c5a25d0dfc1.tar.gz
ports-3c814f2bccfd8fc3aaf539f76e178c5a25d0dfc1.zip
Notes
Diffstat (limited to 'deskutils/showdown')
-rw-r--r--deskutils/showdown/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/deskutils/showdown/Makefile b/deskutils/showdown/Makefile
index c7e1102518fd..570d01c0fbd1 100644
--- a/deskutils/showdown/Makefile
+++ b/deskutils/showdown/Makefile
@@ -10,14 +10,13 @@ COMMENT= Simple markdown viewer, written in Vala and GTK 3
LICENSE= GPLv3
-BROKEN_powerpc64= fails to compile: unrecognized command line option "-Wno-incompatible-pointer-types"
-
BUILD_DEPENDS= ${LOCALBASE}/lib/libmarkdown.a:textproc/discount \
valac:lang/vala
LIB_DEPENDS= libsoup-2.4.so:devel/libsoup \
libwebkit2gtk-4.0.so:www/webkit2-gtk3
-USES= desktop-file-utils gmake pkgconfig
+USES= compiler:c++11-lang desktop-file-utils gmake gnome \
+ pkgconfig
USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk30 pango
USE_XORG= x11
USE_GITHUB= yes
@@ -35,6 +34,12 @@ PLIST_FILES= bin/showdown \
OPTIONS_DEFINE= DOCS
+.include <bsd.port.pre.mk>
+
+.if ${CHOSEN_COMPILER_TYPE} == gcc
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-GNUmakefile
+.endif
+
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/showdown
@@ -42,4 +47,4 @@ post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>