aboutsummaryrefslogtreecommitdiff
path: root/deskutils/shutter
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2020-03-27 12:10:28 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2020-03-27 12:10:28 +0000
commit3835a289e04a1a72c963f0050e6f6cfa8fdd5f71 (patch)
tree3ebfa050f3f4a466f8eac9f9407c4d67d9b23830 /deskutils/shutter
parent3e1e618952fa936f730e4734161f8d67e4c0d9ff (diff)
downloadports-3835a289e04a1a72c963f0050e6f6cfa8fdd5f71.tar.gz
ports-3835a289e04a1a72c963f0050e6f6cfa8fdd5f71.zip
Notes
Diffstat (limited to 'deskutils/shutter')
-rw-r--r--deskutils/shutter/Makefile34
-rw-r--r--deskutils/shutter/distinfo5
-rw-r--r--deskutils/shutter/files/patch-CVE-2015-085412
-rw-r--r--deskutils/shutter/pkg-plist4
4 files changed, 18 insertions, 37 deletions
diff --git a/deskutils/shutter/Makefile b/deskutils/shutter/Makefile
index 84121e6d0a49..5a0ae5e24582 100644
--- a/deskutils/shutter/Makefile
+++ b/deskutils/shutter/Makefile
@@ -2,16 +2,13 @@
# $FreeBSD$
PORTNAME= shutter
-PORTVERSION= 0.93.1
-PORTREVISION= 5
+PORTVERSION= 0.94.3
CATEGORIES= deskutils
-MASTER_SITES= http://shutter-project.org/wp-content/uploads/releases/tars/
+MASTER_SITES= https://launchpadlibrarian.net/427931700/
MAINTAINER= nivit@FreeBSD.org
COMMENT= Screenshot tool
-BROKEN= unfetchable
-
LICENSE= GPLv3 GPLv2 # the latter for some shipped cursors
LICENSE_COMB= multi
@@ -28,7 +25,7 @@ RUN_DEPENDS= ImageMagick6>=6.9.3.1,1:graphics/ImageMagick6 \
p5-Gtk2-ImageView>=0.05:x11-toolkits/p5-Gtk2-ImageView \
p5-Gtk2-Unique>=0.05:x11-toolkits/p5-Gtk2-Unique \
p5-Gtk2>=1.2491:x11-toolkits/p5-Gtk2 \
- p5-JSON-XS>=3.01:converters/p5-JSON-XS \
+ p5-JSON-MaybeXS>=1.0:converters/p5-JSON-MaybeXS \
p5-JSON>=2.90:converters/p5-JSON \
p5-Locale-gettext>=1.05:devel/p5-Locale-gettext \
p5-Net-DBus>=1.0.0:devel/p5-Net-DBus \
@@ -43,23 +40,20 @@ RUN_DEPENDS= ImageMagick6>=6.9.3.1,1:graphics/ImageMagick6 \
p5-XML-Simple>=2.20:textproc/p5-XML-Simple \
xdg-utils>=1.0.2.20130919:devel/xdg-utils
-INSTALLS_ICONS= yes
-
-METADATA_DESC= Enable Shutter to write Metadata
-METADATA_RUN_DEPENDS= p5-Image-ExifTool>=9.76:graphics/p5-Image-ExifTool
+USES= desktop-file-utils gettext-runtime gnome perl5 shebangfix
+USE_PERL5= run
+INSTALLS_ICONS= yes
NO_BUILD= yes
-OPTIONS_DEFINE= METADATA NLS
-OPTIONS_SUB= yes
-
SHEBANG_FILES= bin/shutter share/shutter/resources/system/upload_plugins/*.pm
SHUTTER_DESKTOP= share/applications/shutter.desktop
-USE_PERL5= run
-USES= desktop-file-utils gettext-runtime gnome perl5 shebangfix
+OPTIONS_DEFINE= METADATA NLS
+OPTIONS_SUB= yes
-.include <bsd.port.options.mk>
+METADATA_DESC= Enable Shutter to write Metadata
+METADATA_RUN_DEPENDS= p5-Image-ExifTool>=9.76:graphics/p5-Image-ExifTool
post-patch:
${REINPLACE_CMD} -e '/OnlyShowIn/d' ${WRKSRC}/${SHUTTER_DESKTOP}
@@ -71,11 +65,11 @@ do-install:
${INSTALL_MAN} share/man/man1/shutter.1.gz ${STAGEDIR}${MANPREFIX}/man/man1/)
@(cd ${WRKSRC}/share && \
${COPYTREE_SHARE} "icons pixmaps" ${STAGEDIR}${LOCALBASE}/share)
-.if ${PORT_OPTIONS:MNLS}
- @(cd ${WRKSRC}/share/locale && \
- ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/share/locale)
-.endif
@(cd ${WRKSRC}/share/shutter && \
${COPYTREE_SHARE} resources ${STAGEDIR}${DATADIR})
+do-install-NLS-on:
+ @(cd ${WRKSRC}/share/locale && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/share/locale)
+
.include <bsd.port.mk>
diff --git a/deskutils/shutter/distinfo b/deskutils/shutter/distinfo
index fc915b5ed63c..c1980322d3ac 100644
--- a/deskutils/shutter/distinfo
+++ b/deskutils/shutter/distinfo
@@ -1,2 +1,3 @@
-SHA256 (shutter-0.93.1.tar.gz) = 536d1f7bc69fff518bf5a6a040d6a2d65beb2eecd5429967c71c25cf991e9625
-SIZE (shutter-0.93.1.tar.gz) = 3432204
+TIMESTAMP = 1578014940
+SHA256 (shutter-0.94.3.tar.gz) = 85befa3e79042e33b1908635f7b922d3dd2e6fbb3418a275160a3bfccd2c9b07
+SIZE (shutter-0.94.3.tar.gz) = 3375447
diff --git a/deskutils/shutter/files/patch-CVE-2015-0854 b/deskutils/shutter/files/patch-CVE-2015-0854
deleted file mode 100644
index fed4e103a473..000000000000
--- a/deskutils/shutter/files/patch-CVE-2015-0854
+++ /dev/null
@@ -1,12 +0,0 @@
---- share/shutter/resources/modules/Shutter/App/HelperFunctions.pm.orig 2015-09-17 16:09:58 UTC
-+++ share/shutter/resources/modules/Shutter/App/HelperFunctions.pm
-@@ -53,7 +53,8 @@ sub new {
-
- sub xdg_open {
- my ( $self, $dialog, $link, $user_data ) = @_;
-- system("xdg-open $link");
-+ my @args = ("xdg-open", "$link");
-+ system(@args);
- if($?){
- my $response = $self->{_dialogs}->dlg_error_message(
- sprintf( $self->{_d}->get("Error while executing %s."), "'xdg-open'"),
diff --git a/deskutils/shutter/pkg-plist b/deskutils/shutter/pkg-plist
index f26eba32e1ba..945000f7641d 100644
--- a/deskutils/shutter/pkg-plist
+++ b/deskutils/shutter/pkg-plist
@@ -766,10 +766,8 @@ share/pixmaps/shutter.png
%%DATADIR%%/resources/system/plugins/shell/sptrim/sptrim
%%DATADIR%%/resources/system/upload_plugins/Template.pm
%%DATADIR%%/resources/system/upload_plugins/upload/Dropbox.pm
-%%DATADIR%%/resources/system/upload_plugins/upload/ITmages.pm
+%%DATADIR%%/resources/system/upload_plugins/upload/Gyazo.pm
%%DATADIR%%/resources/system/upload_plugins/upload/Imgur.pm
-%%DATADIR%%/resources/system/upload_plugins/upload/Minus.pm
%%DATADIR%%/resources/system/upload_plugins/upload/ToileLibre.pm
-%%DATADIR%%/resources/system/upload_plugins/upload/TwitPic.pm
%%DATADIR%%/resources/system/upload_plugins/upload/vgyme.pm
@mode