aboutsummaryrefslogtreecommitdiff
path: root/deskutils/splashsetter
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-01-22 11:29:09 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-01-22 11:29:09 +0000
commit512272608abecdd5d656172e1ae22e7fe4a4e269 (patch)
tree3241ae230234c1adc69225a592068d16b4e0bb8b /deskutils/splashsetter
parentfbd1108f49e97dfa6bd38fe69dc8f6b8ab89bb26 (diff)
downloadports-512272608abecdd5d656172e1ae22e7fe4a4e269.tar.gz
ports-512272608abecdd5d656172e1ae22e7fe4a4e269.zip
Notes
Diffstat (limited to 'deskutils/splashsetter')
-rw-r--r--deskutils/splashsetter/Makefile7
-rw-r--r--deskutils/splashsetter/distinfo2
-rw-r--r--deskutils/splashsetter/files/patch-splash_set_gui_lib.py21
-rw-r--r--deskutils/splashsetter/files/patch-splash_set_lib.py38
-rw-r--r--deskutils/splashsetter/pkg-plist2
5 files changed, 67 insertions, 3 deletions
diff --git a/deskutils/splashsetter/Makefile b/deskutils/splashsetter/Makefile
index 75ba42c616e3..d62802b8c7f0 100644
--- a/deskutils/splashsetter/Makefile
+++ b/deskutils/splashsetter/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= splashsetter
-PORTVERSION= 0.6.2
+PORTVERSION= 0.6.3
CATEGORIES= deskutils gnome
MASTER_SITES= http://webonaut.com/distfiles/${PORTNAME}/
@@ -23,11 +23,12 @@ do-build:
@${REINPLACE_CMD} -e 's|/usr/X11R6|${X11BASE}|g' \
${WRKSRC}/*.py
@${FIND} ${WRKSRC} -name '*.bak' -delete
+ @${FIND} ${WRKSRC} -name '*.orig' -delete
@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
@${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
do-install:
- ${MKDIR} ${X11BASE}/share/gnome/pixmaps/${PORTNAME}
+ ${MKDIR} ${X11BASE}/share/gnome/pixmaps/${PORTNAME}/splash
${MKDIR} ${X11BASE}/libexec/${PORTNAME}
@${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} \
${X11BASE}/libexec/${PORTNAME}/
@@ -37,6 +38,8 @@ do-install:
${X11BASE}/share/gnome/applications/
@${INSTALL_DATA} ${WRKSRC}/*.svg \
${X11BASE}/share/gnome/pixmaps/${PORTNAME}/
+ @${INSTALL_DATA} ${WRKSRC}/*.png \
+ ${X11BASE}/share/gnome/pixmaps/${PORTNAME}/splash/
@${LN} -sf ${X11BASE}/libexec/${PORTNAME}/${PORTNAME} \
${X11BASE}/bin/${PORTNAME}
diff --git a/deskutils/splashsetter/distinfo b/deskutils/splashsetter/distinfo
index 96464c994dc3..d2314415ceeb 100644
--- a/deskutils/splashsetter/distinfo
+++ b/deskutils/splashsetter/distinfo
@@ -1 +1 @@
-MD5 (splashsetter-0.6.2.tar.bz2) = b5f7ea3d924ae57f0d3bd71b76025b74
+MD5 (splashsetter-0.6.3.tar.bz2) = f9437f8e517fd5c675562a7b705cb19e
diff --git a/deskutils/splashsetter/files/patch-splash_set_gui_lib.py b/deskutils/splashsetter/files/patch-splash_set_gui_lib.py
new file mode 100644
index 000000000000..9542e5f9f043
--- /dev/null
+++ b/deskutils/splashsetter/files/patch-splash_set_gui_lib.py
@@ -0,0 +1,21 @@
+--- splash_set_gui_lib.py.orig Thu Jan 22 11:46:50 2004
++++ splash_set_gui_lib.py Thu Jan 22 11:42:38 2004
+@@ -182,6 +182,7 @@
+
+ self.__def_thumb_size = 120
+
++
+ def run_gui(self):
+ self.set_icon(gtk.gdk.pixbuf_new_from_file(SPLASH_SET_ICON))
+ self.connect('destroy', gtk.mainquit)
+@@ -260,8 +261,8 @@
+ def __toolbar_workaround(self, x1 = None, x2 = None):
+
+ if self.__toolbar.get_style() == 2: # 2 is text below icons but is also set if "both-horiz" == 3 should be.
+- self.config = gconf.client_get_default()
+- tc_or = self.config.get_string("/desktop/gnome/interface/toolbar_style")
++ config = gconf_lib()
++ tc_or = config.get_string("/desktop/gnome/interface/toolbar_style")
+ if (tc_or == "both-horiz"):
+ self.__toolbar.set_style(gtk.TOOLBAR_BOTH_HORIZ)
+
diff --git a/deskutils/splashsetter/files/patch-splash_set_lib.py b/deskutils/splashsetter/files/patch-splash_set_lib.py
new file mode 100644
index 000000000000..2e25aa7e38df
--- /dev/null
+++ b/deskutils/splashsetter/files/patch-splash_set_lib.py
@@ -0,0 +1,38 @@
+--- splash_set_lib.py.orig Thu Jan 22 11:46:44 2004
++++ splash_set_lib.py Thu Jan 22 11:44:48 2004
+@@ -105,7 +105,7 @@
+ self.__splash_home_dir = "~/.splash/"
+ self.splash_screen_list = []
+ self.allow_set_splash_now = False
+- self.config = gconf_lib()
++ self.__config = gconf_lib()
+
+
+ def set_random_splash(self):
+@@ -135,14 +135,14 @@
+
+ def load_config(self):
+
+- self.__search_in_system_dir = self.config.get_cb_sysdir_state()
+- self.__splash_search_dir = self.config.get_splash_dir()
++ self.__search_in_system_dir = self.__config.get_cb_sysdir_state()
++ self.__splash_search_dir = self.__config.get_splash_dir()
+
+ if self.__splash_search_dir[-1:] != "/":
+ self.__splash_search_dir += "/"
+
+ if not self.__original_splash:
+- self.__original_splash = self.config.get_current_splash_screen()
++ self.__original_splash = self.__config.get_current_splash_screen()
+ self.active_splash = self.__original_splash
+
+
+@@ -168,7 +168,7 @@
+
+ def set_splash(self):
+ print "new splash:",self.active_splash
+- self.config.set_splash_image(self.active_splash)
++ self.__config.set_splash_image(self.active_splash)
+
+
+ def __load_splash_file_list(self, path, splashlist):
diff --git a/deskutils/splashsetter/pkg-plist b/deskutils/splashsetter/pkg-plist
index da54be3c7741..edb22d72e02a 100644
--- a/deskutils/splashsetter/pkg-plist
+++ b/deskutils/splashsetter/pkg-plist
@@ -12,5 +12,7 @@ libexec/splashsetter/splashsetter
share/gnome/applications/splashsetter.desktop
share/gnome/pixmaps/splashsetter/splashsetter_icon.svg
share/gnome/pixmaps/splashsetter/splashsetter_logo.svg
+share/gnome/pixmaps/splashsetter/splash/splashsetter_splash.png
+@dirrm share/gnome/pixmaps/splashsetter/splash
@dirrm share/gnome/pixmaps/splashsetter
@dirrm libexec/splashsetter