aboutsummaryrefslogtreecommitdiff
path: root/deskutils/splashsetter
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-01-17 07:00:22 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-01-17 07:00:22 +0000
commitbc28ed90adf92b5e33423a0e9e286766e0d0e17a (patch)
treeb5287a7f7aaf5abc0b0cb47ab339e7499e62a89c /deskutils/splashsetter
parent9273e0df2b6d7aaca1663e14b556e35eeb057866 (diff)
downloadports-bc28ed90adf92b5e33423a0e9e286766e0d0e17a.tar.gz
ports-bc28ed90adf92b5e33423a0e9e286766e0d0e17a.zip
Notes
Diffstat (limited to 'deskutils/splashsetter')
-rw-r--r--deskutils/splashsetter/Makefile43
-rw-r--r--deskutils/splashsetter/distinfo1
-rw-r--r--deskutils/splashsetter/pkg-descr6
-rw-r--r--deskutils/splashsetter/pkg-plist16
4 files changed, 66 insertions, 0 deletions
diff --git a/deskutils/splashsetter/Makefile b/deskutils/splashsetter/Makefile
new file mode 100644
index 000000000000..0ef63664ef6c
--- /dev/null
+++ b/deskutils/splashsetter/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: splashsetter
+# Date created: 15 Januar 2004
+# Whom: Franz Klammer <klammer@webonaut.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= splashsetter
+PORTVERSION= 0.6.1
+CATEGORIES= deskutils gnome
+MASTER_SITES= http://webonaut.com/distfiles/${PORTNAME}/
+
+MAINTAINER= klammer@webonaut.com
+COMMENT= Splash screen changer for GNOME
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_REINPLACE= yes
+USE_PYTHON= yes
+USE_GNOME= pygnome2
+
+do-build:
+ @${REINPLACE_CMD} -e 's|/usr/X11R6|${X11BASE}|g' \
+ ${WRKSRC}/*.py
+ @${FIND} ${WRKSRC} -name '*.bak' -delete
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
+ @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
+
+do-install:
+ ${MKDIR} ${X11BASE}/share/gnome/pixmaps/${PORTNAME}
+ ${MKDIR} ${X11BASE}/libexec/${PORTNAME}
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} \
+ ${X11BASE}/libexec/${PORTNAME}/
+ @${INSTALL_DATA} ${WRKSRC}/*.py* \
+ ${X11BASE}/libexec/${PORTNAME}/
+ @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop \
+ ${X11BASE}/share/gnome/applications/
+ @${INSTALL_DATA} ${WRKSRC}/*.svg \
+ ${X11BASE}/share/gnome/pixmaps/${PORTNAME}/
+ @${LN} -sf ${X11BASE}/libexec/${PORTNAME}/${PORTNAME} \
+ ${X11BASE}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/deskutils/splashsetter/distinfo b/deskutils/splashsetter/distinfo
new file mode 100644
index 000000000000..297b6d331b5d
--- /dev/null
+++ b/deskutils/splashsetter/distinfo
@@ -0,0 +1 @@
+MD5 (splashsetter-0.6.1.tar.bz2) = 53d8b6969f7f76d72ae1fb7396ebf0c8
diff --git a/deskutils/splashsetter/pkg-descr b/deskutils/splashsetter/pkg-descr
new file mode 100644
index 000000000000..ad4442d4c6b1
--- /dev/null
+++ b/deskutils/splashsetter/pkg-descr
@@ -0,0 +1,6 @@
+There are so many nice splash screens available but it's bothering to always
+change them manually on GConf. With Splashsetter you can change your splash
+screen with a GUI or randomly if called from the commandline with the
+parameter "--random".
+
+WWW: http://webonaut.com/splashsetter/
diff --git a/deskutils/splashsetter/pkg-plist b/deskutils/splashsetter/pkg-plist
new file mode 100644
index 000000000000..da54be3c7741
--- /dev/null
+++ b/deskutils/splashsetter/pkg-plist
@@ -0,0 +1,16 @@
+bin/splashsetter
+libexec/splashsetter/div_data.py
+libexec/splashsetter/div_data.pyc
+libexec/splashsetter/div_data.pyo
+libexec/splashsetter/splash_set_lib.py
+libexec/splashsetter/splash_set_lib.pyc
+libexec/splashsetter/splash_set_lib.pyo
+libexec/splashsetter/splash_set_gui_lib.py
+libexec/splashsetter/splash_set_gui_lib.pyc
+libexec/splashsetter/splash_set_gui_lib.pyo
+libexec/splashsetter/splashsetter
+share/gnome/applications/splashsetter.desktop
+share/gnome/pixmaps/splashsetter/splashsetter_icon.svg
+share/gnome/pixmaps/splashsetter/splashsetter_logo.svg
+@dirrm share/gnome/pixmaps/splashsetter
+@dirrm libexec/splashsetter