aboutsummaryrefslogtreecommitdiff
path: root/deskutils/strigi
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-03-24 20:26:48 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-03-24 20:26:48 +0000
commit80b5857dd6fb5ea44b97d34c13904643b3713e16 (patch)
treedb6d1bed116711358ac8371f129a6a9a431b6258 /deskutils/strigi
parentf3b931dde5a9adda1757171bb9ae44d154a640e6 (diff)
downloadports-80b5857dd6fb5ea44b97d34c13904643b3713e16.tar.gz
ports-80b5857dd6fb5ea44b97d34c13904643b3713e16.zip
Notes
Diffstat (limited to 'deskutils/strigi')
-rw-r--r--deskutils/strigi/Makefile11
-rw-r--r--deskutils/strigi/files/extrapatch-libstreamanalyzer__plugins__endplugins__CMakeLists.txt (renamed from deskutils/strigi/files/patch-libstreamanalyzer__plugins__endplugins__CMakeLists.txt)3
-rw-r--r--deskutils/strigi/files/patch-libstreamanalyzer__cmake__FindFFmpeg.cmake2
3 files changed, 13 insertions, 3 deletions
diff --git a/deskutils/strigi/Makefile b/deskutils/strigi/Makefile
index 95495e5c7915..42a91c2b4c40 100644
--- a/deskutils/strigi/Makefile
+++ b/deskutils/strigi/Makefile
@@ -21,11 +21,20 @@ USE_GNOME= libxml2
USE_PKGCONFIG= build
USE_FAM= yes
USE_LDCONFIG= yes
-USES= cmake
+USES= cmake:outsource
MAKE_JOBS_UNSAFE= yes
# supported versions: ffmpeg, ffmpeg1, ffmpeg-devel
+# corresponding FFMPEG_SUFFIX: '', '1', '-devel'
FFMPEG_SUFFIX?= #
+CMAKE_ARGS+= -DFFMPEG_SUFFIX:STRING="${FFMPEG_SUFFIX}"
+
+.if !empty(FFMPEG_SUFFIX)
+# Reorder include directories to allow build with multiple ffmpeg installed.
+# This patch must NOT be used, if ffmpeg headers are installed
+# directly to ${LOCALBASE}/include
+EXTRA_PATCHES+= ${FILESDIR}/extrapatch-libstreamanalyzer__plugins__endplugins__CMakeLists.txt
+.endif
post-patch:
${MKDIR} ${WRKSRC}
diff --git a/deskutils/strigi/files/patch-libstreamanalyzer__plugins__endplugins__CMakeLists.txt b/deskutils/strigi/files/extrapatch-libstreamanalyzer__plugins__endplugins__CMakeLists.txt
index c1459ea33cb2..bfa8aaa27bd0 100644
--- a/deskutils/strigi/files/patch-libstreamanalyzer__plugins__endplugins__CMakeLists.txt
+++ b/deskutils/strigi/files/extrapatch-libstreamanalyzer__plugins__endplugins__CMakeLists.txt
@@ -1,4 +1,5 @@
-# Reorder include directories to fix build when multiple ffmpeg installed
+# Reorder include directories to allow build with multiple ffmpeg installed.
+# This patch must NOT be used, if FFMPEG_INCLUDE_DIRS == ${LOCALBASE}/include
#
--- ./libstreamanalyzer/plugins/endplugins/CMakeLists.txt.orig 2011-12-07 20:28:33.000000000 +0000
+++ ./libstreamanalyzer/plugins/endplugins/CMakeLists.txt 2013-03-06 00:58:08.824363575 +0000
diff --git a/deskutils/strigi/files/patch-libstreamanalyzer__cmake__FindFFmpeg.cmake b/deskutils/strigi/files/patch-libstreamanalyzer__cmake__FindFFmpeg.cmake
index d7ba0a266451..37c9af318e40 100644
--- a/deskutils/strigi/files/patch-libstreamanalyzer__cmake__FindFFmpeg.cmake
+++ b/deskutils/strigi/files/patch-libstreamanalyzer__cmake__FindFFmpeg.cmake
@@ -23,7 +23,7 @@
if (NOT FFMPEG_LIBRARIES)
+ # Look for ffmpeg1 by default. Use empty suffix for ffmpeg-0.7
-+ if (NOT FFMPEG_SUFFIX)
++ if (NOT DEFINED FFMPEG_SUFFIX)
+ set(FFMPEG_SUFFIX 1)
+ endif ()
+