aboutsummaryrefslogtreecommitdiff
path: root/deskutils/strigi
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-03-26 15:43:09 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-03-26 15:43:09 +0000
commit089463050a5e448ddefde0caedf053739c9d4696 (patch)
tree66e5c2057d5b19663c2534bd995e9e4bd7e28a11 /deskutils/strigi
parent47092a357183baee44782ae400728a01f56692ee (diff)
downloadports-089463050a5e448ddefde0caedf053739c9d4696.tar.gz
ports-089463050a5e448ddefde0caedf053739c9d4696.zip
Notes
Diffstat (limited to 'deskutils/strigi')
-rw-r--r--deskutils/strigi/Makefile60
-rw-r--r--deskutils/strigi/Makefile.common16
-rw-r--r--deskutils/strigi/files/extrapatch-libstreamanalyzer__plugins__endplugins__CMakeLists.txt14
-rw-r--r--deskutils/strigi/files/patch-libstreamanalyzer__cmake__FindFFmpeg.cmake45
-rw-r--r--deskutils/strigi/files/patch-libstreams__CMakeLists.txt22
-rw-r--r--deskutils/strigi/pkg-plist140
6 files changed, 42 insertions, 255 deletions
diff --git a/deskutils/strigi/Makefile b/deskutils/strigi/Makefile
index 727e11fb42f0..8c10d12b4aa5 100644
--- a/deskutils/strigi/Makefile
+++ b/deskutils/strigi/Makefile
@@ -2,44 +2,36 @@
# $FreeBSD$
PORTNAME= strigi
-PORTVERSION= 0.7.8
-PORTREVISION= 1
+PORTVERSION= ${STRIGI_VERSION}
+PORTREVISION= 2
CATEGORIES= deskutils
-MASTER_SITES= http://www.vandenoever.info/software/strigi/
+DISTFILES= #
MAINTAINER= kde@FreeBSD.org
-COMMENT= Desktop searching program
-
-LIB_DEPENDS= avcodec${FFMPEG_SUFFIX}:${PORTSDIR}/multimedia/ffmpeg${FFMPEG_SUFFIX} \
- clucene-core:${PORTSDIR}/textproc/clucene \
- dbus-1:${PORTSDIR}/devel/dbus \
- exiv2:${PORTSDIR}/graphics/exiv2
-
-USE_QT4= corelib gui dbus moc_build uic_build qmake_build rcc_build
-USE_BZIP2= yes
-USE_GNOME= libxml2
-USE_PKGCONFIG= build
-USE_FAM= yes
-USE_LDCONFIG= yes
-USES= cmake:outsource
-MAKE_JOBS_UNSAFE= yes
-
-# supported versions: ffmpeg, ffmpeg1, ffmpeg-devel
-# corresponding FFMPEG_SUFFIX: '', '1', '-devel'
-FFMPEG_SUFFIX?= #
-CMAKE_ARGS+= -DFFMPEG_SUFFIX:STRING="${FFMPEG_SUFFIX}"
-
-.if !empty(FFMPEG_SUFFIX)
-# Reorder include directories to allow build with multiple ffmpeg installed.
-# This patch must NOT be used, if ffmpeg headers are installed
-# directly to ${LOCALBASE}/include
-EXTRA_PATCHES+= ${FILESDIR}/extrapatch-libstreamanalyzer__plugins__endplugins__CMakeLists.txt
+COMMENT= Strigi desktop search (meta port)
+
+USE_KDE4= strigi_run
+NO_BUILD= yes
+
+OPTIONS_DEFINE= CLIENT DAEMON UTILITIES
+OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
+
+.include <${.CURDIR}/Makefile.common>
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MCLIENT}
+RUN_DEPENDS+= ${LOCALBASE}/bin/strigiclient:${PORTSDIR}/deskutils/strigiclient
+.endif
+
+.if ${PORT_OPTIONS:MDAEMON}
+RUN_DEPENDS+= ${LOCALBASE}/bin/strigidaemon:${PORTSDIR}/deskutils/strigidaemon
+.endif
+
+.if ${PORT_OPTIONS:MUTILITIES}
+RUN_DEPENDS+= ${LOCALBASE}/bin/xmlindexer:${PORTSDIR}/deskutils/strigiutils
.endif
-post-patch:
- ${REINPLACE_CMD} -e \
- 's,$${LIB_DESTINATION}/pkgconfig,libdata/pkgconfig,' \
- ${WRKSRC}/libstreamanalyzer/CMakeLists.txt \
- ${WRKSRC}/libstreams/CMakeLists.txt
+do-install:
+ @${DO_NADA}
.include <bsd.port.mk>
diff --git a/deskutils/strigi/Makefile.common b/deskutils/strigi/Makefile.common
new file mode 100644
index 000000000000..b4ec06c1ee60
--- /dev/null
+++ b/deskutils/strigi/Makefile.common
@@ -0,0 +1,16 @@
+STRIGI_VERSION= 0.7.8
+STRIGI_MASTER_SITES= http://www.vandenoever.info/software/strigi/
+
+.if !defined(NO_BUILD)
+DISTNAME= strigi-${STRIGI_VERSION}
+DISTINFO_FILE= ${.CURDIR}/../strigi/distinfo
+DESCR= ${.CURDIR}/../strigi/pkg-descr
+
+CONFLICTS_INSTALL= strigi-0.*
+
+USE_BZIP2= yes
+USES+= cmake:outsource
+CMAKE_SOURCE_PATH= ${WRKSRC}/${PORTNAME}
+
+PLIST_SUB= SHLIB_VER=${STRIGI_VERSION}
+.endif
diff --git a/deskutils/strigi/files/extrapatch-libstreamanalyzer__plugins__endplugins__CMakeLists.txt b/deskutils/strigi/files/extrapatch-libstreamanalyzer__plugins__endplugins__CMakeLists.txt
deleted file mode 100644
index bfa8aaa27bd0..000000000000
--- a/deskutils/strigi/files/extrapatch-libstreamanalyzer__plugins__endplugins__CMakeLists.txt
+++ /dev/null
@@ -1,14 +0,0 @@
-# Reorder include directories to allow build with multiple ffmpeg installed.
-# This patch must NOT be used, if FFMPEG_INCLUDE_DIRS == ${LOCALBASE}/include
-#
---- ./libstreamanalyzer/plugins/endplugins/CMakeLists.txt.orig 2011-12-07 20:28:33.000000000 +0000
-+++ ./libstreamanalyzer/plugins/endplugins/CMakeLists.txt 2013-03-06 00:58:08.824363575 +0000
-@@ -32,7 +32,7 @@
- endif(XINE_FOUND)
-
- if(FFMPEG_FOUND)
-- include_directories( ${FFMPEG_INCLUDE_DIRS} )
-+ include_directories(BEFORE ${FFMPEG_INCLUDE_DIRS} )
- add_definitions(-D__STDC_CONSTANT_MACROS)
- ADD_STRIGIEA(ffmpeg ffmpegendanalyzer.cpp)
- #set_target_properties( ffmpeg PROPERTIES COMPILE_FLAGS "${FFMPEG_DEFINITIONS}" )
diff --git a/deskutils/strigi/files/patch-libstreamanalyzer__cmake__FindFFmpeg.cmake b/deskutils/strigi/files/patch-libstreamanalyzer__cmake__FindFFmpeg.cmake
deleted file mode 100644
index 37c9af318e40..000000000000
--- a/deskutils/strigi/files/patch-libstreamanalyzer__cmake__FindFFmpeg.cmake
+++ /dev/null
@@ -1,45 +0,0 @@
---- ./libstreamanalyzer/cmake/FindFFmpeg.cmake.orig 2013-03-01 07:07:31.562142000 +0000
-+++ ./libstreamanalyzer/cmake/FindFFmpeg.cmake 2013-03-06 00:32:09.269367542 +0000
-@@ -71,13 +71,15 @@
- ${PC_LIB${_component}_INCLUDEDIR}
- ${PC_LIB${_component}_INCLUDE_DIRS}
- PATH_SUFFIXES
-- ffmpeg
-+ ffmpeg${FFMPEG_SUFFIX}
- )
-
- find_library(${_component}_LIBRARIES NAMES ${_library}
-- HINTS
-+ HINTS
- ${PC_LIB${_component}_LIBDIR}
- ${PC_LIB${_component}_LIBRARY_DIRS}
-+ PATH_SUFFIXES
-+ ffmpeg${FFMPEG_SUFFIX}
- )
-
- set(${_component}_DEFINITIONS ${PC_${_component}_CFLAGS_OTHER} CACHE STRING "The ${_component} CFLAGS.")
-@@ -97,13 +99,18 @@
- # Check for cached results. If there are skip the costly part.
- if (NOT FFMPEG_LIBRARIES)
-
-+ # Look for ffmpeg1 by default. Use empty suffix for ffmpeg-0.7
-+ if (NOT DEFINED FFMPEG_SUFFIX)
-+ set(FFMPEG_SUFFIX 1)
-+ endif ()
-+
- # Check for all possible component.
-- find_component(AVCODEC libavcodec avcodec libavcodec/avcodec.h)
-- find_component(AVFORMAT libavformat avformat libavformat/avformat.h)
-- find_component(AVDEVICE libavdevice avdevice libavdevice/avdevice.h)
-- find_component(AVUTIL libavutil avutil libavutil/avutil.h)
-- find_component(SWSCALE libswscale swscale libswscale/swscale.h)
-- find_component(POSTPROC libpostproc postproc libpostproc/postprocess.h)
-+ find_component(AVCODEC libavcodec${FFMPEG_SUFFIX} avcodec${FFMPEG_SUFFIX} libavcodec/avcodec.h)
-+ find_component(AVFORMAT libavformat${FFMPEG_SUFFIX} avformat${FFMPEG_SUFFIX} libavformat/avformat.h)
-+ find_component(AVDEVICE libavdevice${FFMPEG_SUFFIX} avdevice${FFMPEG_SUFFIX} libavdevice/avdevice.h)
-+ find_component(AVUTIL libavutil${FFMPEG_SUFFIX} avutil${FFMPEG_SUFFIX} libavutil/avutil.h)
-+ find_component(SWSCALE libswscale${FFMPEG_SUFFIX} swscale${FFMPEG_SUFFIX} libswscale/swscale.h)
-+ find_component(POSTPROC libpostproc${FFMPEG_SUFFIX} postproc${FFMPEG_SUFFIX} libpostproc/postprocess.h)
-
- # Check if the required components were found and add their stuff to the FFMPEG_* vars.
- foreach (_component ${FFmpeg_FIND_COMPONENTS})
diff --git a/deskutils/strigi/files/patch-libstreams__CMakeLists.txt b/deskutils/strigi/files/patch-libstreams__CMakeLists.txt
deleted file mode 100644
index 652a79f97cfd..000000000000
--- a/deskutils/strigi/files/patch-libstreams__CMakeLists.txt
+++ /dev/null
@@ -1,22 +0,0 @@
---- ./libstreams/CMakeLists.txt.orig 2013-02-05 21:34:57.000000000 +0000
-+++ ./libstreams/CMakeLists.txt 2013-03-06 22:02:36.587664409 +0000
-@@ -46,9 +46,6 @@
- # check for visibility support
- macro_check_gcc_visibility(__STRIGI_HAVE_GCC_VISIBILITY)
-
--# Generate include/strigi/strigiconfig.h and lib/config.h
--include(ConfigureChecks.cmake)
--
- # check for required packages
- find_package(ZLIB)
- set_package_properties(ZLIB PROPERTIES
-@@ -75,6 +72,9 @@
- TYPE REQUIRED
- )
-
-+# Generate include/strigi/strigiconfig.h and lib/config.h
-+include(ConfigureChecks.cmake)
-+
- feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)
-
- ##### building and testing #####
diff --git a/deskutils/strigi/pkg-plist b/deskutils/strigi/pkg-plist
deleted file mode 100644
index 41a517bd6ebe..000000000000
--- a/deskutils/strigi/pkg-plist
+++ /dev/null
@@ -1,140 +0,0 @@
-bin/deepfind
-bin/deepgrep
-bin/lucene2indexer
-bin/rdfindexer
-bin/strigiclient
-bin/strigicmd
-bin/strigidaemon
-bin/xmlindexer
-include/strigi/analysisresult.h
-include/strigi/analyzerconfiguration.h
-include/strigi/analyzerplugin.h
-include/strigi/archivereader.h
-include/strigi/arinputstream.h
-include/strigi/asyncsocket.h
-include/strigi/asyncsocketclient.h
-include/strigi/bufferedstream.h
-include/strigi/bz2inputstream.h
-include/strigi/classproperties.h
-include/strigi/clientinterface.h
-include/strigi/cpioinputstream.h
-include/strigi/dataeventinputstream.h
-include/strigi/diranalyzer.h
-include/strigi/encodinginputstream.h
-include/strigi/fieldproperties.h
-include/strigi/fieldpropertiesdb.h
-include/strigi/fieldtypes.h
-include/strigi/fileinputstream.h
-include/strigi/filelister.h
-include/strigi/gzipinputstream.h
-include/strigi/indexeddocument.h
-include/strigi/indexmanager.h
-include/strigi/indexplugin.h
-include/strigi/indexpluginloader.h
-include/strigi/indexreader.h
-include/strigi/indexwriter.h
-include/strigi/inputstream.h
-include/strigi/inputstreamreader.h
-include/strigi/kmpsearcher.h
-include/strigi/lzmainputstream.h
-include/strigi/mailinputstream.h
-include/strigi/oleinputstream.h
-include/strigi/processinputstream.h
-include/strigi/qtdbus/strigiasyncclient.h
-include/strigi/qtdbus/strigiclient.h
-include/strigi/qtdbus/strigidbus.h
-include/strigi/qtdbus/strigitypes.h
-include/strigi/query.h
-include/strigi/queryparser.h
-include/strigi/rpminputstream.h
-include/strigi/sdfinputstream.h
-include/strigi/socketclient.h
-include/strigi/streamanalyzer.h
-include/strigi/streamanalyzerfactory.h
-include/strigi/streambase.h
-include/strigi/streambuffer.h
-include/strigi/streamendanalyzer.h
-include/strigi/streameventanalyzer.h
-include/strigi/streamlineanalyzer.h
-include/strigi/streamsaxanalyzer.h
-include/strigi/streamthroughanalyzer.h
-include/strigi/strigi_thread.h
-include/strigi/strigiconfig.h
-include/strigi/strigihtmlgui.h
-include/strigi/stringstream.h
-include/strigi/stringterminatedsubstream.h
-include/strigi/subinputstream.h
-include/strigi/substreamprovider.h
-include/strigi/substreamproviderprovider.h
-include/strigi/tarinputstream.h
-include/strigi/textutils.h
-include/strigi/variant.h
-include/strigi/zipinputstream.h
-lib/cmake/LibSearchClient/LibSearchClientConfig.cmake
-lib/cmake/LibStreamAnalyzer/LibStreamAnalyzerConfig.cmake
-lib/cmake/LibStreamAnalyzer/LibStreamAnalyzerConfigVersion.cmake
-lib/cmake/LibStreams/LibStreamsConfig.cmake
-lib/cmake/LibStreams/LibStreamsConfigVersion.cmake
-lib/cmake/LibStreams/LibStreamsTargets-%%CMAKE_BUILD_TYPE%%.cmake
-lib/cmake/LibStreams/LibStreamsTargets.cmake
-lib/cmake/Strigi/StrigiConfig.cmake
-lib/cmake/Strigi/StrigiConfigVersion.cmake
-lib/libsearchclient.so
-lib/libsearchclient.so.0
-lib/libsearchclient.so.0.7.8
-lib/libstreamanalyzer.so
-lib/libstreamanalyzer.so.0
-lib/libstreamanalyzer.so.0.7.8
-lib/libstreams.so
-lib/libstreams.so.0
-lib/libstreams.so.0.7.8
-lib/libstrigihtmlgui.so
-lib/libstrigihtmlgui.so.0
-lib/libstrigihtmlgui.so.0.7.8
-lib/libstrigiqtdbusclient.so
-lib/libstrigiqtdbusclient.so.0
-lib/libstrigiqtdbusclient.so.0.7.8
-lib/strigi/strigiea_digest.so
-lib/strigi/strigiea_ffmpeg.so
-lib/strigi/strigiea_jpeg.so
-lib/strigi/strigiea_riff.so
-lib/strigi/strigiindex_cluceneng.so
-lib/strigi/strigila_cpp.so
-lib/strigi/strigila_deb.so
-lib/strigi/strigila_namespaceharvester.so
-lib/strigi/strigila_txt.so
-lib/strigi/strigila_xpm.so
-lib/strigi/strigita_au.so
-lib/strigi/strigita_avi.so
-lib/strigi/strigita_dds.so
-lib/strigi/strigita_gif.so
-lib/strigi/strigita_ico.so
-lib/strigi/strigita_pcx.so
-lib/strigi/strigita_rgb.so
-lib/strigi/strigita_sid.so
-lib/strigi/strigita_wav.so
-lib/strigi/strigita_xbm.so
-libdata/pkgconfig/libstreamanalyzer.pc
-libdata/pkgconfig/libstreams.pc
-share/dbus-1/services/org.freedesktop.xesam.searcher.service
-share/dbus-1/services/vandenoever.strigi.service
-share/strigi/fieldproperties/homeless.rdfs
-share/strigi/fieldproperties/nao_data.rdfs
-share/strigi/fieldproperties/ncal_data.rdfs
-share/strigi/fieldproperties/nco_data.rdfs
-share/strigi/fieldproperties/nexif_data.rdfs
-share/strigi/fieldproperties/nfo_data.rdfs
-share/strigi/fieldproperties/nid3_data.rdfs
-share/strigi/fieldproperties/nie_data.rdfs
-share/strigi/fieldproperties/nmo_data.rdfs
-share/strigi/fieldproperties/strigi.rdfs
-@dirrmtry share/strigi/fieldproperties
-@dirrmtry share/strigi
-@dirrmtry lib/strigi
-@dirrmtry lib/cmake/Strigi
-@dirrmtry lib/cmake/LibStreams
-@dirrmtry lib/cmake/LibStreamAnalyzer
-@dirrmtry lib/cmake/LibSearchClient
-@dirrmtry lib/cmake
-@dirrmtry include/strigi/qtdbus
-@dirrmtry include/strigi