aboutsummaryrefslogtreecommitdiff
path: root/deskutils/strigi
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2009-03-24 19:11:23 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2009-03-24 19:11:23 +0000
commit4d55666226a1a32a778ec41abf7265abf57b8c4a (patch)
tree3539d1e0a86996e97b7aaa1846b59e945cb8bc09 /deskutils/strigi
parent9d7f5e7aa1ccf406869750a09b9a7c49547dc190 (diff)
downloadports-4d55666226a1a32a778ec41abf7265abf57b8c4a.tar.gz
ports-4d55666226a1a32a778ec41abf7265abf57b8c4a.zip
Notes
Diffstat (limited to 'deskutils/strigi')
-rw-r--r--deskutils/strigi/Makefile2
-rw-r--r--deskutils/strigi/files/patch-config.h.cmake11
-rw-r--r--deskutils/strigi/files/patch-src__streams__strigi__strigi_thread.h11
3 files changed, 23 insertions, 1 deletions
diff --git a/deskutils/strigi/Makefile b/deskutils/strigi/Makefile
index 196af4c62521..263c4dfc3a31 100644
--- a/deskutils/strigi/Makefile
+++ b/deskutils/strigi/Makefile
@@ -6,7 +6,7 @@
PORTNAME= strigi
PORTVERSION= 0.6.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils
MASTER_SITES= SF
diff --git a/deskutils/strigi/files/patch-config.h.cmake b/deskutils/strigi/files/patch-config.h.cmake
new file mode 100644
index 000000000000..8a05f93576a7
--- /dev/null
+++ b/deskutils/strigi/files/patch-config.h.cmake
@@ -0,0 +1,11 @@
+--- ./config.h.cmake.orig 2009-01-13 00:50:22.000000000 +0300
++++ ./config.h.cmake 2009-03-21 00:02:27.000000000 +0300
+@@ -40,7 +40,7 @@
+ //thread stuff
+ //////////////////////////////
+ #cmakedefine CMAKE_USE_WIN32_THREADS_INIT 1
+-#cmakedefine CMAKE_HAVE_PTHREAD_CREATE 1
++#cmakedefine CMAKE_HAVE_PTHREAD_H 1
+
+ //////////////////////////////
+ //types
diff --git a/deskutils/strigi/files/patch-src__streams__strigi__strigi_thread.h b/deskutils/strigi/files/patch-src__streams__strigi__strigi_thread.h
new file mode 100644
index 000000000000..941077a46cdd
--- /dev/null
+++ b/deskutils/strigi/files/patch-src__streams__strigi__strigi_thread.h
@@ -0,0 +1,11 @@
+--- ./src/streams/strigi/strigi_thread.h.orig 2009-01-13 00:50:17.000000000 +0300
++++ ./src/streams/strigi/strigi_thread.h 2009-03-21 00:01:51.000000000 +0300
+@@ -23,7 +23,7 @@
+
+ #include <config.h>
+
+-#if defined(CMAKE_HAVE_PTHREAD_CREATE)
++#if defined(CMAKE_HAVE_PTHREAD_H)
+ #include <pthread.h>
+ #define STRIGI_MUTEX_DEFINE(x) pthread_mutex_t x
+ #define STRIGI_MUTEX_INIT(x) pthread_mutex_init(x, 0)