aboutsummaryrefslogtreecommitdiff
path: root/deskutils/superswitcher/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2006-01-07 03:13:05 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2006-01-07 03:13:05 +0000
commitc07c1042da4c6612ec1f0e1bca27115b3deb490e (patch)
treebcb50965c0d871b5e66f263841e897aa5716b592 /deskutils/superswitcher/Makefile
parent255abd4c4fe5f0f405589813193e31cc477021c6 (diff)
downloadports-c07c1042da4c6612ec1f0e1bca27115b3deb490e.tar.gz
ports-c07c1042da4c6612ec1f0e1bca27115b3deb490e.zip
Notes
Diffstat (limited to 'deskutils/superswitcher/Makefile')
-rw-r--r--deskutils/superswitcher/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/deskutils/superswitcher/Makefile b/deskutils/superswitcher/Makefile
new file mode 100644
index 000000000000..8be5fadf344f
--- /dev/null
+++ b/deskutils/superswitcher/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: superswitcher
+# Date Created: 02 Jan 2006
+# Whom: Remington Lang <MrL0Lz@gmail.com>
+#
+# $FreeBSD$
+
+PORTNAME= superswitcher
+PORTVERSION= 0.1
+CATEGORIES= deskutils gnome
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= browserbookapp
+
+MAINTAINER= MrL0Lz@gmail.com
+COMMENT= Alt-Tab replacement
+
+BUILD_DEPENDS= gnome-autogen.sh:${PORTSDIR}/devel/gnomecommon
+RUN_DEPENDS= gnome-autogen.sh:${PORTSDIR}/devel/gnomecommon
+
+USE_GMAKE= yes
+USE_GNOME= gtk20 libwnck pango
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/x11//g' ${WRKSRC}/configure
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/superswitcher ${PREFIX}/bin
+
+.include <bsd.port.mk>