aboutsummaryrefslogtreecommitdiff
path: root/deskutils/superswitcher
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-10-24 23:37:25 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-10-24 23:37:25 +0000
commit4acc6fb2a411b291c9c210d82bafe7c62e71c77d (patch)
treebc16420eb52d65511ceb520c00171d219210a473 /deskutils/superswitcher
parent97dfcc1b41c5b4581b1d73128a866beec069c5bf (diff)
downloadports-4acc6fb2a411b291c9c210d82bafe7c62e71c77d.tar.gz
ports-4acc6fb2a411b291c9c210d82bafe7c62e71c77d.zip
Notes
Diffstat (limited to 'deskutils/superswitcher')
-rw-r--r--deskutils/superswitcher/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/deskutils/superswitcher/Makefile b/deskutils/superswitcher/Makefile
index 5acb0981a84a..1a154519cdc1 100644
--- a/deskutils/superswitcher/Makefile
+++ b/deskutils/superswitcher/Makefile
@@ -3,6 +3,7 @@
# Whom: Remington Lang <MrL0Lz@gmail.com>
#
# $FreeBSD$
+#
PORTNAME= superswitcher
PORTVERSION= 0.3
@@ -20,11 +21,16 @@ RUN_DEPENDS= gnome-autogen.sh:${PORTSDIR}/devel/gnome-common
USE_GMAKE= yes
USE_GNOME= gtk20 libwnck pango
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+post-extract:
+ @${FIND} ${WRKSRC} -name Makefile | ${XARGS} ${RM} -f
post-patch:
@${REINPLACE_CMD} -e 's/x11//g' ${WRKSRC}/configure
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/superswitcher ${PREFIX}/bin
+ @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|-D.*_DISABLE_DEPRECATED||g'
.include <bsd.port.mk>