aboutsummaryrefslogtreecommitdiff
path: root/deskutils/taskcoach/files
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2011-03-04 09:06:16 +0000
committerKevin Lo <kevlo@FreeBSD.org>2011-03-04 09:06:16 +0000
commit4545774b4c026d0c4a9597448d800606613c8ce8 (patch)
tree570037eae3e908a997172529079c5a6fdf16a0ee /deskutils/taskcoach/files
parentcb3924853fbcfa38a8bbaf31cb98a598008398a5 (diff)
downloadports-4545774b4c026d0c4a9597448d800606613c8ce8.tar.gz
ports-4545774b4c026d0c4a9597448d800606613c8ce8.zip
Notes
Diffstat (limited to 'deskutils/taskcoach/files')
-rw-r--r--deskutils/taskcoach/files/patch-setup.py29
1 files changed, 29 insertions, 0 deletions
diff --git a/deskutils/taskcoach/files/patch-setup.py b/deskutils/taskcoach/files/patch-setup.py
new file mode 100644
index 000000000000..e830feedc2c8
--- /dev/null
+++ b/deskutils/taskcoach/files/patch-setup.py
@@ -0,0 +1,29 @@
+--- setup.py.orig 2011-02-06 01:18:05.000000000 +0800
++++ setup.py 2011-03-04 16:47:57.000000000 +0800
+@@ -54,7 +54,6 @@
+ 'license': meta.license,
+ 'download_url': meta.download,
+ 'packages': findPackages('taskcoachlib') + findPackages('buildlib'),
+- 'scripts': ['taskcoach.py'],
+ 'classifiers': [\
+ 'Development Status :: 3 - Alpha',
+ 'Intended Audience :: End Users/Desktop',
+@@ -73,14 +72,12 @@
+ setupOptions['classifiers'].append('Natural Language :: %s'%language)
+
+ # Add data files for Debian-based systems:
+-current_dist = [dist.lower() for dist in platform.dist()]
+-if 'debian' in current_dist or 'ubuntu' in current_dist:
+- setupOptions['data_files'] = [\
+- ('share/applications', ['build.in/fedora/taskcoach.desktop']),
+- ('share/pixmaps', ['icons.in/taskcoach.png'])]
++setupOptions['data_files'] = [\
++ ('share/applications', ['build.in/fedora/taskcoach.desktop']),
++ ('share/pixmaps', ['icons.in/taskcoach.png'])]
+
+ system = platform.system()
+-if system == 'Linux':
++if (system == 'Linux') or (system == 'FreeBSD'):
+ setupOptions['package_data'] = {'taskcoachlib': ['bin.in/linux/_pysyncml.so']}
+ elif system == 'Windows':
+ setupOptions['scripts'].append('taskcoach.pyw')