aboutsummaryrefslogtreecommitdiff
path: root/deskutils/taskwarrior
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2009-07-23 09:51:27 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2009-07-23 09:51:27 +0000
commit49abc368d36199705643d0b23e6d06707b5e5b52 (patch)
tree86abca29103ee9aaeffc981271a10a57e2da8a28 /deskutils/taskwarrior
parent7688ca3ba6a714da8397c23d85ee8caceb8908d8 (diff)
downloadports-49abc368d36199705643d0b23e6d06707b5e5b52.tar.gz
ports-49abc368d36199705643d0b23e6d06707b5e5b52.zip
Notes
Diffstat (limited to 'deskutils/taskwarrior')
-rw-r--r--deskutils/taskwarrior/Makefile8
-rw-r--r--deskutils/taskwarrior/files/extra-32bit25
2 files changed, 32 insertions, 1 deletions
diff --git a/deskutils/taskwarrior/Makefile b/deskutils/taskwarrior/Makefile
index dbae78cd2102..ac17dcb274d0 100644
--- a/deskutils/taskwarrior/Makefile
+++ b/deskutils/taskwarrior/Makefile
@@ -21,6 +21,12 @@ GNU_CONFIGURE= yes
MAN1= task.1
MAN5= taskrc.5 task-tutorial.5
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "i386"
+EXTRA_PATCHES= ${PATCHDIR}/extra-32bit
+.endif
+
post-patch:
${REINPLACE_CMD} -e 's|%%DOCSDIR%%|${DOCSDIR}|; s|%%DATADIR%%|${DATADIR}|' \
${WRKSRC}/Makefile.in
@@ -28,4 +34,4 @@ post-patch:
${REINPLACE_CMD} -e '341,348d' ${WRKSRC}/Makefile.in
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/deskutils/taskwarrior/files/extra-32bit b/deskutils/taskwarrior/files/extra-32bit
new file mode 100644
index 000000000000..1e8e3a297697
--- /dev/null
+++ b/deskutils/taskwarrior/files/extra-32bit
@@ -0,0 +1,25 @@
+--- src/Duration.h.orig 2009-07-23 11:41:40.000000000 +0200
++++ src/Duration.h 2009-07-23 11:51:08.000000000 +0200
+@@ -40,7 +40,6 @@
+ bool operator> (const Duration&);
+ ~Duration (); // Destructor
+
+- operator int ();
+ operator time_t ();
+ operator std::string ();
+
+--- src/Duration.cpp.orig 2009-07-23 11:41:44.000000000 +0200
++++ src/Duration.cpp 2009-07-23 11:51:28.000000000 +0200
+@@ -52,12 +52,6 @@
+ }
+
+ ////////////////////////////////////////////////////////////////////////////////
+-Duration::operator int ()
+-{
+- return (int) mDays;
+-}
+-
+-////////////////////////////////////////////////////////////////////////////////
+ Duration::operator time_t ()
+ {
+ return mDays;