aboutsummaryrefslogtreecommitdiff
path: root/deskutils/tel
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-08-28 02:49:31 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-08-28 02:49:31 +0000
commit809e4c7534759ffa533d467be739c3a148595fcb (patch)
tree62f22138002fe9b0156fbf2b34f641edea4f7ac4 /deskutils/tel
parent072cec8c42b4a978e2f5ea4600c980130b3316be (diff)
downloadports-809e4c7534759ffa533d467be739c3a148595fcb.tar.gz
ports-809e4c7534759ffa533d467be739c3a148595fcb.zip
Notes
Diffstat (limited to 'deskutils/tel')
-rw-r--r--deskutils/tel/Makefile30
1 files changed, 22 insertions, 8 deletions
diff --git a/deskutils/tel/Makefile b/deskutils/tel/Makefile
index 36f1562cecec..5e007b502e76 100644
--- a/deskutils/tel/Makefile
+++ b/deskutils/tel/Makefile
@@ -3,21 +3,35 @@
PORTNAME= tel
PORTVERSION= 0.1.7.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= deskutils
-MASTER_SITES= CENKES BERLIOS
+MASTER_SITES= SF/${PORTNAME}.berlios
MAINTAINER= ports@FreeBSD.org
COMMENT= Little console-based phone book manager
-USES= gettext tar:bzip2
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
-NO_STAGE= yes
+LICENSE= MIT
+
+NO_ARCH= yes
+
+USES= gettext python shebangfix tar:bzip2
+SHEBANG_FILES= src/tel.py
+python_OLD_CMD= /usr/bin/env python
+python_CMD= ${PYTHON_CMD}
+USE_PYTHON= distutils
post-patch:
- @${REINPLACE_CMD} \
- -e 's,distutils\.command\.install ,setuptools\.command\.install ,' \
+ @${REINPLACE_CMD} -e \
+ 's|distutils\.command\.install |setuptools\.command\.install |' \
${WRKSRC}/appdistutils.py
+ @${REINPLACE_CMD} -e \
+ 's|$${install_messages}|${PREFIX}/share/locale| ; \
+ s|$${install_app_modules}|${PREFIX}/lib/tel| ; \
+ s|$${install_app_data}|${DATADIR}|' \
+ ${WRKSRC}/src/tel.py
+
+post-install:
+ @${FIND} ${STAGEDIR}${PREFIX}/bin -type l -delete
+ @${LN} -sf ${PREFIX}/lib/tel/tel.py ${STAGEDIR}${PREFIX}/bin/tel
.include <bsd.port.mk>