aboutsummaryrefslogtreecommitdiff
path: root/deskutils/timer-applet/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-04-11 18:28:24 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-04-11 18:28:24 +0000
commit369a97c98336dab316064dfb6c02806f9c0ab63f (patch)
treeed5c761b878631be535356463701ee84e98f7a4e /deskutils/timer-applet/Makefile
parente404df93747922570700e9c2347974656051a059 (diff)
downloadports-369a97c98336dab316064dfb6c02806f9c0ab63f.tar.gz
ports-369a97c98336dab316064dfb6c02806f9c0ab63f.zip
Notes
Diffstat (limited to 'deskutils/timer-applet/Makefile')
-rw-r--r--deskutils/timer-applet/Makefile23
1 files changed, 17 insertions, 6 deletions
diff --git a/deskutils/timer-applet/Makefile b/deskutils/timer-applet/Makefile
index f5eb81b4f06f..49d2d64139bb 100644
--- a/deskutils/timer-applet/Makefile
+++ b/deskutils/timer-applet/Makefile
@@ -6,31 +6,42 @@
#
PORTNAME= timer-applet
-PORTVERSION= 0.5.1
-PORTREVISION= 1
+PORTVERSION= 1.0
CATEGORIES= deskutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= timerapplet
MAINTAINER= jylefort@brutele.be
-COMMENT= Timer applet for the Gnome panel
+COMMENT= A timer applet for the GNOME panel
RUN_DEPENDS= ${X11BASE}/share/gnome/sounds/gtk-events/clicked.wav:${PORTSDIR}/audio/gnomeaudio2
-USE_GNOME= gnomehack gnomeprefix gnomepanel
+USE_GNOME= gnomehack gnomeprefix gnomepanel intlhack
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --bindir=${PREFIX}/libexec # applets belong to libexec
USE_X_PREFIX= yes
USE_REINPLACE= yes
+USE_GMAKE= yes
+GCONF_SCHEMAS= timer-applet.schemas
+INSTALLS_OMF= yes
+OMFDIR= ${PREFIX}/share/gnome/omf/${PORTNAME}
post-patch:
@${REINPLACE_CMD} -e \
- 's|/usr/share/pixmaps/||; \
+ 's|/usr/share/pixmaps/|${PREFIX}/share/gnome/pixmaps/|; \
s|location="timer-applet"|location="${PREFIX}/libexec/timer-applet"|' \
- ${WRKSRC}/timer-applet.server
+ ${WRKSRC}/GNOME_TimerApplet.server.in
@${REINPLACE_CMD} -e \
's|$$(datadir)/sounds|${X11BASE}/share/gnome/sounds|' \
${WRKSRC}/src/Makefile.in
+ @${MKDIR} ${WRKSRC}/omf-install
+
+post-install:
+ ${MKDIR} ${OMFDIR}
+.for lang in C fr
+ ${INSTALL_DATA} ${WRKSRC}/omf-install/${PORTNAME}-${lang}.omf ${OMFDIR}
+ -scrollkeeper-install -q ${OMFDIR}/${PORTNAME}-${lang}.omf
+.endfor
.include <bsd.port.mk>