aboutsummaryrefslogtreecommitdiff
path: root/deskutils/timer-applet/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-05-16 14:10:48 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-05-16 14:10:48 +0000
commit51d35385738cf68045a2d5eae7588b281122d175 (patch)
treedb85f18c8d9f58b2487720bb0b0814204274a00a /deskutils/timer-applet/Makefile
parentc3ced2e51656015b28a7da4bb057d82adc70055d (diff)
downloadports-51d35385738cf68045a2d5eae7588b281122d175.tar.gz
ports-51d35385738cf68045a2d5eae7588b281122d175.zip
Notes
Diffstat (limited to 'deskutils/timer-applet/Makefile')
-rw-r--r--deskutils/timer-applet/Makefile28
1 files changed, 13 insertions, 15 deletions
diff --git a/deskutils/timer-applet/Makefile b/deskutils/timer-applet/Makefile
index d9b8bc696f1d..ecb151c2e47a 100644
--- a/deskutils/timer-applet/Makefile
+++ b/deskutils/timer-applet/Makefile
@@ -6,28 +6,26 @@
#
PORTNAME= timer-applet
-PORTVERSION= 1.3.1
-PORTREVISION= 5
+PORTVERSION= 2.0.1
CATEGORIES= deskutils
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
-MASTER_SITE_SUBDIR= timerapplet
+MASTER_SITES= SFE/timerapplet
MAINTAINER= ports@FreeBSD.org
COMMENT= A timer applet for the GNOME panel
-LIB_DEPENDS= notify:${PORTSDIR}/devel/libnotify
-RUN_DEPENDS= ${LOCALBASE}/share/sounds/gtk-events/clicked.wav:${PORTSDIR}/audio/gnome-audio
+RUN_DEPENDS= ${LOCALBASE}/share/sounds/gtk-events/clicked.wav:${PORTSDIR}/audio/gnome-audio \
+ ${LOCALBASE}/libdata/pkgconfig/dbus-python.pc:${PORTSDIR}/devel/py-dbus \
+ ${LOCALBASE}/libdata/pkgconfig/notify-python.pc:${PORTSDIR}/devel/py-notify
-USE_GNOME= gnomehack gnomeprefix gnomepanel intlhack
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+USE_GNOME= gnomehack gnomeprefix gnometarget intlhack pygnomedesktop
+USE_PYTHON= yes
+USE_GETTEXT= yes
USE_GMAKE= yes
-GCONF_SCHEMAS= timer-applet.schemas
-INSTALLS_OMF= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --libdir=${PREFIX}/libexec
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|/usr/share/pixmaps/|${PREFIX}/share/pixmaps/|' \
- ${WRKSRC}/GNOME_TimerApplet.server.in.in
+GCONF_SCHEMAS= timer-applet.schemas
.include <bsd.port.mk>