aboutsummaryrefslogtreecommitdiff
path: root/deskutils/todo
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-19 01:57:42 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-19 01:57:42 +0000
commit19a8c3cc6a281e5ad0b821cc21a6b8b043a72c8e (patch)
tree5ee5ab782ffb8af3f873d789215765603ebf6694 /deskutils/todo
parent676faeebb9f8aeb39fdf1be25884de457f995666 (diff)
downloadports-19a8c3cc6a281e5ad0b821cc21a6b8b043a72c8e.tar.gz
ports-19a8c3cc6a281e5ad0b821cc21a6b8b043a72c8e.zip
Notes
Diffstat (limited to 'deskutils/todo')
-rw-r--r--deskutils/todo/Makefile33
-rw-r--r--deskutils/todo/distinfo3
-rw-r--r--deskutils/todo/pkg-descr11
3 files changed, 47 insertions, 0 deletions
diff --git a/deskutils/todo/Makefile b/deskutils/todo/Makefile
new file mode 100644
index 000000000000..5600b442793a
--- /dev/null
+++ b/deskutils/todo/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# Ports collection makefile for: todo
+# Date created: Jul 13, 2006
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= todo
+PORTVERSION= 1.6
+CATEGORIES= deskutils
+MASTER_SITES= http://todotxt.com/library/todo.sh/
+DISTNAME= todo.sh
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Todo.txt Managers
+
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
+
+USE_ZIP= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= bin/todo etc/dot.todo
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,/bin/sh,${LOCALBASE}/bin/bash," ${WRKSRC}/todo.sh
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/todo.sh ${PREFIX}/bin/todo
+ @${INSTALL_DATA} ${WRKSRC}/.todo ${PREFIX}/etc/dot.todo
+
+.include <bsd.port.mk>
diff --git a/deskutils/todo/distinfo b/deskutils/todo/distinfo
new file mode 100644
index 000000000000..985ca76dc042
--- /dev/null
+++ b/deskutils/todo/distinfo
@@ -0,0 +1,3 @@
+MD5 (todo.sh.zip) = 5e49fd7f8361fc62be147396a85b7c12
+SHA256 (todo.sh.zip) = dd42faf9e960a274b8bfec95f9f1a29db83b510391ea2d40afd32ee44d0f83fa
+SIZE (todo.sh.zip) = 3654
diff --git a/deskutils/todo/pkg-descr b/deskutils/todo/pkg-descr
new file mode 100644
index 000000000000..98198dfe6ec5
--- /dev/null
+++ b/deskutils/todo/pkg-descr
@@ -0,0 +1,11 @@
+There are approximately 17 million software applications and web sites out
+there built to manage your to do list. But if you're comfortable at the
+command line and you don't want to depend on someone else's data format or
+someone else's server, there's an age-old method that's perfect for tracking
+your stuff: plain text.
+
+Keep on top of all your tasks and projects in a simple file called todo.txt.
+With a few helper scripts, you can slice, dice, sort, distribute, pipe and
+munge your lists any way you please. As it should be.
+
+WWW: http://todotxt.com/