aboutsummaryrefslogtreecommitdiff
path: root/deskutils/todo
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-08-08 21:42:16 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-08-08 21:46:40 +0000
commit0d3e9f1a62cdf03e1d1ec4b5284d887cc70053a5 (patch)
tree0f416b1cdfeb5fdbf4800804365aefd48ffcd34f /deskutils/todo
parente52c0266c99e9b5de18af55c2bb9bd4a208df7b6 (diff)
downloadports-0d3e9f1a62cdf03e1d1ec4b5284d887cc70053a5.tar.gz
ports-0d3e9f1a62cdf03e1d1ec4b5284d887cc70053a5.zip
deskutils/todo: Fix config path (TODOTXT_GLOBAL_CFG_FILE)
- Bump PORTREVISION for package change PR: 257647 Reported by: Duane <parakleta@darkreality.org>
Diffstat (limited to 'deskutils/todo')
-rw-r--r--deskutils/todo/Makefile3
-rw-r--r--deskutils/todo/files/patch-todo.sh11
2 files changed, 14 insertions, 0 deletions
diff --git a/deskutils/todo/Makefile b/deskutils/todo/Makefile
index 50bdce4a635e..9a8af2e89264 100644
--- a/deskutils/todo/Makefile
+++ b/deskutils/todo/Makefile
@@ -27,6 +27,9 @@ CONFLICTS_INSTALL= deforaos-todo devtodo
SHEBANG_FILES= todo.sh todo_completion
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/todo.sh
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/todo.sh ${STAGEDIR}${PREFIX}/bin/todo
${INSTALL_DATA} ${WRKSRC}/todo.cfg ${STAGEDIR}${PREFIX}/etc/todo.cfg
diff --git a/deskutils/todo/files/patch-todo.sh b/deskutils/todo/files/patch-todo.sh
new file mode 100644
index 000000000000..794b6c7923bd
--- /dev/null
+++ b/deskutils/todo/files/patch-todo.sh
@@ -0,0 +1,11 @@
+--- todo.sh.orig 2020-08-12 04:44:46 UTC
++++ todo.sh
+@@ -622,7 +622,7 @@ TODOTXT_DEFAULT_ACTION=${TODOTXT_DEFAULT_ACTION:-}
+ TODOTXT_SORT_COMMAND=${TODOTXT_SORT_COMMAND:-env LC_COLLATE=C sort -f -k2}
+ TODOTXT_DISABLE_FILTER=${TODOTXT_DISABLE_FILTER:-}
+ TODOTXT_FINAL_FILTER=${TODOTXT_FINAL_FILTER:-cat}
+-TODOTXT_GLOBAL_CFG_FILE=${TODOTXT_GLOBAL_CFG_FILE:-/etc/todo/config}
++TODOTXT_GLOBAL_CFG_FILE=${TODOTXT_GLOBAL_CFG_FILE:-%%PREFIX%%/etc/todo.cfg}
+ TODOTXT_SIGIL_BEFORE_PATTERN=${TODOTXT_SIGIL_BEFORE_PATTERN:-} # Allow any other non-whitespace entity before +project and @context; should be an optional match; example: \(w:\)\{0,1\} to allow w:@context.
+ TODOTXT_SIGIL_VALID_PATTERN=${TODOTXT_SIGIL_VALID_PATTERN:-.*} # Limit the valid characters (from the default any non-whitespace sequence) for +project and @context; example: [a-zA-Z]\{3,\} to only allow alphabetic ones that are at least three characters long.
+ TODOTXT_SIGIL_AFTER_PATTERN=${TODOTXT_SIGIL_AFTER_PATTERN:-} # Allow any other non-whitespace entity after +project and @context; should be an optional match; example: )\{0,1\} to allow (with the corresponding TODOTXT_SIGIL_BEFORE_PATTERN) enclosing in parentheses.