aboutsummaryrefslogtreecommitdiff
path: root/deskutils/tomboy
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:35:50 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:35:50 +0000
commitf1bb12de8e50bf76ae21f37debda60994ec7fd99 (patch)
tree1671d4beef381f12d939e34b344eb385a3af4f19 /deskutils/tomboy
parent29adee7bb42244f34736c5c24ed18a9b269d0925 (diff)
Notes
Diffstat (limited to 'deskutils/tomboy')
-rw-r--r--deskutils/tomboy/Makefile25
-rw-r--r--deskutils/tomboy/distinfo6
-rw-r--r--deskutils/tomboy/pkg-plist71
3 files changed, 85 insertions, 17 deletions
diff --git a/deskutils/tomboy/Makefile b/deskutils/tomboy/Makefile
index d8870780c13e..c3044c0cf9f2 100644
--- a/deskutils/tomboy/Makefile
+++ b/deskutils/tomboy/Makefile
@@ -3,28 +3,30 @@
# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
#
# $FreeBSD$
-# $Id: Makefile,v 1.22 2006/02/16 02:44:45 tmclau02 Exp $
+# $Id: Makefile,v 1.25 2006/09/15 02:47:48 tmclau02 Exp $
#
PORTNAME= tomboy
-PORTVERSION= 0.3.5
-PORTREVISION= 5
+PORTVERSION= 0.4.1
CATEGORIES= deskutils gnome
-MASTER_SITES= http://www.beatniksoftware.com/tomboy/releases/
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
+DIST_SUBDIR= gnome2
MAINTAINER= bsd-sharp-list@forge.novell.com
COMMENT= Personal note taking system for the GNOME desktop
-LIB_DEPENDS= gtkspell.0:${PORTSDIR}/textproc/gtkspell
-BUILD_DEPENDS= gapi-fixup:${PORTSDIR}/x11-toolkits/gtk-sharp10 \
- ${LOCALBASE}/lib/mono/dbus-sharp/dbus-sharp.dll:${PORTSDIR}/devel/dbus-sharp
-RUN_DEPENDS= gapi-fixup:${PORTSDIR}/x11-toolkits/gtk-sharp10 \
- ${LOCALBASE}/lib/mono/dbus-sharp/dbus-sharp.dll:${PORTSDIR}/devel/dbus-sharp
+LIB_DEPENDS= gtkspell.0:${PORTSDIR}/textproc/gtkspell \
+ dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+BUILD_DEPENDS= gapi2-fixup:${PORTSDIR}/x11-toolkits/gtk-sharp20
+RUN_DEPENDS= gapi2-fixup:${PORTSDIR}/x11-toolkits/gtk-sharp20
+USE_BZIP2= yes
USE_GNOME= gnomehack gnometarget intltool gnomeprefix gnomepanel
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
+INSTALLS_ICONS= yes
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -36,7 +38,7 @@ GCONF_SCHEMAS= tomboy.schemas
# Tomboy's Evolution plugin relies on gmime# and not evo# according to
# configure. Enable if either evo or gmime# is installed.
-.if defined (WITH_EVOLUTION) || exists (${X11BASE}/bin/evolution) || exists (${LOCALBASE}/lib/mono/gmime-sharp/gmime-sharp.dll)
+.if defined (WITH_EVOLUTION) || exists (${LOCALBASE}/bin/evolution) || exists (${LOCALBASE}/lib/mono/gmime-sharp/gmime-sharp.dll)
CONFIGURE_ARGS+= --enable-evolution=yes
BUILD_DEPENDS+= ${LOCALBASE}/lib/mono/gmime-sharp/gmime-sharp.dll:${PORTSDIR}/mail/gmime2-sharp
RUN_DEPENDS+= ${LOCALBASE}/lib/mono/gmime-sharp/gmime-sharp.dll:${PORTSDIR}/mail/gmime2-sharp
@@ -49,7 +51,8 @@ post-patch:
@${REINPLACE_CMD} -e 's|(libdir)/dbus-1.0|(prefix)/share/dbus-1|g' \
${WRKSRC}/data/Makefile.in
@${REINPLACE_CMD} -e 's|`$$PKG_CONFIG --variable=libdir libpanelapplet-2.0`|"$$libdir"|g; \
- s|PANELAPPLET_SERVER_DIR="$$libdir|PANELAPPLET_SERVER_DIR="$$prefix/libdata|g' \
+ s|PANELAPPLET_SERVER_DIR="$$libdir|PANELAPPLET_SERVER_DIR="$$prefix/libdata|g; \
+ s|PANELAPPLET_SERVER_DIR="$$PANELAPPLET_LIBDIR|PANELAPPLET_SERVER_DIR="$$prefix/libdata|g' \
${WRKSRC}/configure
post-install:
diff --git a/deskutils/tomboy/distinfo b/deskutils/tomboy/distinfo
index d72b196b09aa..107266dda727 100644
--- a/deskutils/tomboy/distinfo
+++ b/deskutils/tomboy/distinfo
@@ -1,3 +1,3 @@
-MD5 (tomboy-0.3.5.tar.gz) = 57e9829d80d8452f002e0a3856bd2c48
-SHA256 (tomboy-0.3.5.tar.gz) = 1af5290924b65b9e55d40816ad0797cf6e81df727bfb4a8642e700c1bb35a0ac
-SIZE (tomboy-0.3.5.tar.gz) = 665599
+MD5 (gnome2/tomboy-0.4.1.tar.bz2) = 40e0f51d832d04f762851fc9a88c01ea
+SHA256 (gnome2/tomboy-0.4.1.tar.bz2) = 389f01838a2a597c78fca7066636ee4867f3896012c47a964278ad6639ae2338
+SIZE (gnome2/tomboy-0.4.1.tar.bz2) = 774805
diff --git a/deskutils/tomboy/pkg-plist b/deskutils/tomboy/pkg-plist
index ed2f9e98cb05..6a645e3173a3 100644
--- a/deskutils/tomboy/pkg-plist
+++ b/deskutils/tomboy/pkg-plist
@@ -4,6 +4,7 @@ lib/tomboy/Plugins/ExportToHTML.dll
lib/tomboy/Plugins/FixedWidth.dll
lib/tomboy/Plugins/NoteOfTheDay.dll
lib/tomboy/Plugins/PrintNotes.dll
+lib/tomboy/Plugins/StickyNoteImport.dll
lib/tomboy/Tomboy.exe
lib/tomboy/Tomboy.exe.config
lib/tomboy/libtomboy.la
@@ -11,42 +12,106 @@ lib/tomboy/libtomboy.so
libdata/bonobo/servers/GNOME_TomboyApplet.server
libdata/pkgconfig/tomboy-plugins.pc
share/dbus-1/services/com.beatniksoftware.Tomboy.service
-share/gnome/gnome-2.0/ui/GNOME_TomboyApplet.xml
-share/gnome/pixmaps/tintin.png
+share/gnome/applications/DefaultPlugins.desktop
+share/gnome/applications/tomboy.desktop
+share/gnome/help/tomboy/C/figures/tomboy-new-note.png
+share/gnome/help/tomboy/C/figures/tomboy-panel.png
+share/gnome/help/tomboy/C/figures/tomboy-preferences-editing.png
+share/gnome/help/tomboy/C/figures/tomboy-preferences-hotkeys.png
+share/gnome/help/tomboy/C/figures/tomboy-tools.png
+share/gnome/help/tomboy/C/legal.xml
+share/gnome/help/tomboy/C/tomboy.xml
+share/gnome/help/tomboy/es/figures/tomboy-new-note.png
+share/gnome/help/tomboy/es/figures/tomboy-panel.png
+share/gnome/help/tomboy/es/figures/tomboy-preferences-editing.png
+share/gnome/help/tomboy/es/figures/tomboy-preferences-hotkeys.png
+share/gnome/help/tomboy/es/figures/tomboy-tools.png
+share/gnome/help/tomboy/es/legal.xml
+share/gnome/help/tomboy/es/tomboy.xml
+share/gnome/help/tomboy/sv/figures/tomboy-new-note.png
+share/gnome/help/tomboy/sv/figures/tomboy-panel.png
+share/gnome/help/tomboy/sv/figures/tomboy-preferences-editing.png
+share/gnome/help/tomboy/sv/figures/tomboy-preferences-hotkeys.png
+share/gnome/help/tomboy/sv/figures/tomboy-tools.png
+share/gnome/help/tomboy/sv/legal.xml
+share/gnome/help/tomboy/sv/tomboy.xml
+share/gnome/omf/tomboy/tomboy-C.omf
+share/gnome/omf/tomboy/tomboy-es.omf
+share/gnome/omf/tomboy/tomboy-sv.omf
+share/gnome/pixmaps/tomboy.png
+share/icons/hicolor/16x16/apps/tomboy.png
+share/icons/hicolor/22x22/apps/tomboy.png
+share/icons/hicolor/48x48/apps/tomboy.png
+share/icons/hicolor/scalable/apps/tomboy.svg
share/locale/bg/LC_MESSAGES/tomboy.mo
+share/locale/bn/LC_MESSAGES/tomboy.mo
+share/locale/bn_IN/LC_MESSAGES/tomboy.mo
share/locale/ca/LC_MESSAGES/tomboy.mo
share/locale/cs/LC_MESSAGES/tomboy.mo
share/locale/da/LC_MESSAGES/tomboy.mo
share/locale/de/LC_MESSAGES/tomboy.mo
+share/locale/dz/LC_MESSAGES/tomboy.mo
+share/locale/el/LC_MESSAGES/tomboy.mo
share/locale/en_CA/LC_MESSAGES/tomboy.mo
share/locale/en_GB/LC_MESSAGES/tomboy.mo
share/locale/es/LC_MESSAGES/tomboy.mo
+share/locale/et/LC_MESSAGES/tomboy.mo
share/locale/eu/LC_MESSAGES/tomboy.mo
share/locale/fi/LC_MESSAGES/tomboy.mo
share/locale/fr/LC_MESSAGES/tomboy.mo
+share/locale/gl/LC_MESSAGES/tomboy.mo
+share/locale/gu/LC_MESSAGES/tomboy.mo
+share/locale/hi/LC_MESSAGES/tomboy.mo
share/locale/hu/LC_MESSAGES/tomboy.mo
share/locale/is/LC_MESSAGES/tomboy.mo
share/locale/it/LC_MESSAGES/tomboy.mo
share/locale/ja/LC_MESSAGES/tomboy.mo
share/locale/ko/LC_MESSAGES/tomboy.mo
+share/locale/ku/LC_MESSAGES/tomboy.mo
share/locale/lt/LC_MESSAGES/tomboy.mo
+share/locale/lv/LC_MESSAGES/tomboy.mo
+share/locale/mk/LC_MESSAGES/tomboy.mo
+share/locale/ml/LC_MESSAGES/tomboy.mo
share/locale/nb/LC_MESSAGES/tomboy.mo
share/locale/ne/LC_MESSAGES/tomboy.mo
share/locale/nl/LC_MESSAGES/tomboy.mo
-share/locale/no/LC_MESSAGES/tomboy.mo
+share/locale/or/LC_MESSAGES/tomboy.mo
share/locale/pa/LC_MESSAGES/tomboy.mo
share/locale/pl/LC_MESSAGES/tomboy.mo
+share/locale/pt/LC_MESSAGES/tomboy.mo
share/locale/pt_BR/LC_MESSAGES/tomboy.mo
share/locale/ro/LC_MESSAGES/tomboy.mo
share/locale/ru/LC_MESSAGES/tomboy.mo
share/locale/rw/LC_MESSAGES/tomboy.mo
share/locale/sq/LC_MESSAGES/tomboy.mo
+share/locale/sr/LC_MESSAGES/tomboy.mo
+share/locale/sr@Latn/LC_MESSAGES/tomboy.mo
share/locale/sv/LC_MESSAGES/tomboy.mo
+share/locale/ta/LC_MESSAGES/tomboy.mo
+share/locale/th/LC_MESSAGES/tomboy.mo
share/locale/tr/LC_MESSAGES/tomboy.mo
share/locale/uk/LC_MESSAGES/tomboy.mo
share/locale/vi/LC_MESSAGES/tomboy.mo
share/locale/zh_CN/LC_MESSAGES/tomboy.mo
+share/locale/zh_HK/LC_MESSAGES/tomboy.mo
+share/locale/zh_TW/LC_MESSAGES/tomboy.mo
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
@dirrmtry share/locale/rw/LC_MESSAGES
@dirrmtry share/locale/rw
+@dirrmtry share/locale/ku/LC_MESSAGES
+@dirrmtry share/locale/ku
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN
+@dirrm share/gnome/omf/tomboy
+@dirrm share/gnome/help/tomboy/sv/figures
+@dirrm share/gnome/help/tomboy/sv
+@dirrm share/gnome/help/tomboy/es/figures
+@dirrm share/gnome/help/tomboy/es
+@dirrm share/gnome/help/tomboy/C/figures
+@dirrm share/gnome/help/tomboy/C
+@dirrm share/gnome/help/tomboy
@dirrm lib/tomboy/Plugins
@dirrm lib/tomboy