aboutsummaryrefslogtreecommitdiff
path: root/deskutils/toolboxkit
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2006-12-18 17:04:07 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2006-12-18 17:04:07 +0000
commitd6063247a17bca5d8e10ec1c8f5f1677c765fe82 (patch)
treea4e38817f1743d55390d4ac71f06cf2eb60476ed /deskutils/toolboxkit
parent30a95b2e2a891d47681fc9c824f1e74a661b742f (diff)
downloadports-d6063247a17bca5d8e10ec1c8f5f1677c765fe82.tar.gz
ports-d6063247a17bca5d8e10ec1c8f5f1677c765fe82.zip
Notes
Diffstat (limited to 'deskutils/toolboxkit')
-rw-r--r--deskutils/toolboxkit/Makefile28
-rw-r--r--deskutils/toolboxkit/distinfo3
-rw-r--r--deskutils/toolboxkit/pkg-descr3
-rw-r--r--deskutils/toolboxkit/pkg-plist7
4 files changed, 41 insertions, 0 deletions
diff --git a/deskutils/toolboxkit/Makefile b/deskutils/toolboxkit/Makefile
new file mode 100644
index 000000000000..270df112774b
--- /dev/null
+++ b/deskutils/toolboxkit/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: toolbox
+# Date created: 18 Dec 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= toolbox
+PORTVERSION= 0.8
+CATEGORIES= deskutils
+MASTER_SITES= http://ftp.azc.uam.mx/mirrors/gnu/savannah/files/toolbox/Release.pkg/0.8/
+PKGNAMESUFFIX= kit${PKGNAMESUFFIX2}
+DISTNAME= Toolbox-${PORTVERSION}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Toolbox bundle for GNUstep
+
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+USE_GNUSTEP_LDCONFIG= ${LOCALLIBDIR}
+
+WRKSRC= ${WRKDIR}/Toolbox
+USE_GNUSTEP_MAKE_DIRS+= Toolbox
+
+.include <bsd.port.mk>
diff --git a/deskutils/toolboxkit/distinfo b/deskutils/toolboxkit/distinfo
new file mode 100644
index 000000000000..e65e5eae030e
--- /dev/null
+++ b/deskutils/toolboxkit/distinfo
@@ -0,0 +1,3 @@
+MD5 (Toolbox-0.8.tar.gz) = abac897a64feb1c9f48d2f68a7658318
+SHA256 (Toolbox-0.8.tar.gz) = 7aa3c313e2b34e4b37059affbaaf382306fed0e97bb0d908ae6645f1e4641400
+SIZE (Toolbox-0.8.tar.gz) = 85333
diff --git a/deskutils/toolboxkit/pkg-descr b/deskutils/toolboxkit/pkg-descr
new file mode 100644
index 000000000000..b907c15c8704
--- /dev/null
+++ b/deskutils/toolboxkit/pkg-descr
@@ -0,0 +1,3 @@
+Toolbox bundle for GNUstep, part of the Toolbox.
+
+WWW: http://www.nongnu.org/toolbox/
diff --git a/deskutils/toolboxkit/pkg-plist b/deskutils/toolboxkit/pkg-plist
new file mode 100644
index 000000000000..1852542d9051
--- /dev/null
+++ b/deskutils/toolboxkit/pkg-plist
@@ -0,0 +1,7 @@
+Local/Library/Headers/Toolbox/BundleLoader.h
+Local/Library/Headers/Toolbox/ToolboxBundleProtocol.h
+Local/Library/Headers/Toolbox/Utilities.h
+Local/Library/Libraries/libToolbox.so
+Local/Library/Libraries/libToolbox.so.%%MAJORLIBVERSION%%
+Local/Library/Libraries/libToolbox.so.%%LIBVERSION%%
+@dirrm Local/Library/Headers/Toolbox